x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I increase the texture pool?

So when I run my game and map in the editor the texture pool seems to be 4gb and all the textures stream nicely as they should while I'm running around. When I launch from a batch file though I can see in the log that it's setting the texture pool to 1000mb and breaking that limit occasionally so during gameplay a lot of the textures on the assets just randomly go blurry or pop in and out.

I know you can increase the texture pool but I'm not sure how. Does anybody know?

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Feb 13 '15 at 09:29 PM in Everything Else

avatar image

SpaceBearDev
21 5 9 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

At the console:

 r.Streaming.PoolSize=1500

Will change the Pool Size to 1500MB

Make the change permanent by editing your DefaultEngine.ini to include:

 [/Script/Engine.RendererSettings]
  r.Streaming.PoolSize=1500

more ▼

answered Feb 25 '16 at 05:40 PM

avatar image

c.greb
41 1 3 7

avatar image Imevil50 Feb 28 '16 at 12:43 PM

Where is the DefaultEngine.ini located?

avatar image Bobeer May 03 '16 at 02:04 PM

C:\Users\UserName\Documents\Unreal Projects\Project name\Config\DefaulEngine

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Engine\Config\Windows\WindowsEngine.ini has a PoolSizeVRAMPercentage=70 setting under [TextureStreaming] heading. Perhaps you could play with that key/value somewhere in your .ini files and see if you get better results.

0 means unlimited streaming.

more ▼

answered Feb 14 '15 at 03:58 AM

avatar image

amigo
1.1k 52 32 90

avatar image SpaceBearDev Feb 14 '15 at 10:08 AM

Thanks! Do you know where I could add that to the projects ini files so that I don't need to change it in the engine? It would also help because then everyone else on the team would have the same setting automatically.

avatar image amigo Feb 14 '15 at 04:48 PM

Perhaps inside Engine.ini (or Game.ini) in your project's Saved/Config/[platform] folder.

As a matter of convention I'm not 100% sure, as most of the .inis end up loaded, but there's probably a "proper" place for it. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question