x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.7: console key isn't being saved

The console key you can configure in Project Settings / Input, at the bottom of this tab, is currently transient. Any changes made to it takes effect only while the editor remains open; when you restart the editor, the Console Keys property is reset to its default.

This is a problem for me because I cannot figure out which is the default console key. It looks like an asterisk, but pressing Numpad *, 8, or shift+8 doesn't opens the console. Also the button below ESC doesn't works, it might be an issue with international keyboards (mine is Brazilian ABNT2). The button below ESC (apostrophe for me, ') opens the Gameplay Debug Tool.

I tried several symbol keys (', Num *, = ), and also a non symbol key (9), in none of the cases the console key was saved.

Product Version: Not Selected
Tags:
more ▼

asked Feb 15 '15 at 02:27 AM in Using UE4

avatar image

Ixiguis
1.2k 57 60 253

avatar image AndrewHurley Feb 16 '15 at 04:20 PM

Hello Ixiguis,

Do you have the (~) on your keyboard? This is called a tilde, and is what we use to currently open the Console.

Also would you mind telling me which version of 4.7 you are using?

Either way the editor should save the keybindings you change or edit, however there could be a compatibility issue with the alternate keyboard you are using. I will do some testing on my end to reproduce what you are reporting.

Thank you,

Andrew Hurley

avatar image Ixiguis Feb 17 '15 at 08:13 PM

Yes, ~ in my keyboard is to the right of Ç, which is to the right of L. Also, it is not immediately consumed (as in, if I press ~ once nothing happens, if I press ~ then A it will output Ã, or if I press ~ then spacebar it will output ~).

Pressing my ~ key does not opens the console. Neither does the key below ESC, which for me is the apostrophe and it opens the debug tool instead.

I'm using the 4.7 built from github source, up to Sunday's (February 15) commits.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey again Ixiguis,

It had not previously occurred to me that you were attempting to set the console key-binding within the 'Project Settings.'

Try going into the 'Editor Preferences' and within the 'Keyboardy Shortcuts' section mapping the key to the console window. Use the image below as reference on how to do this.

Editor Preferences Keyboard Shortcuts alt text

You can map any key on your keyboard to this function. Let me know if this resolves your issue or if you need further assistance.

Thank you,

Andrew Hurley

more ▼

answered Feb 20 '15 at 03:52 PM

avatar image Ixiguis Feb 20 '15 at 04:10 PM

Didn't work as well.

First I tried changing it to apostrophe. It would still open the gameplay debug tool.

Then I tried Num * and 9, both had no effect.

But even if it did work, there's still the issue that the console key isn't saved in project settings.

avatar image Ixiguis Feb 22 '15 at 06:09 PM

You could try changing your keyboard layout in Windows' control panel to Brazilian ABNT2, perhaps then you'd experience the same issue I'm having.

avatar image AndrewHurley Mar 06 '15 at 12:51 AM

Hey again Ixguis,

Apologies for the late reply! Things have been quite exciting here at Epic this past week! Unreal Engine 4 is Free!

Anyway, I found a bug report entered into our system for this issue, and it is marked to be fixed in an upcoming version of the Engine. I appreciate your patience during the testing process.

Let me know if you have any other questions or need additional assistance.

Regards,

Andrew Hurley

avatar image gsfreema Jan 20 '17 at 03:28 PM

This issue does appear to be fixed now. Issue UE-4533 still exists and is marked as Backlogged. It can likely be closed as fixed.

avatar image AndrewHurley Jan 20 '17 at 04:07 PM

Thanks for the notification gsfreema. I have gone ahead and updated the issue internally so it also reflects on the public issues tracker.

UE-4533

Cheers,

Andrew H

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question