x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.6] Plugin not compiling

Hello,

I'd like to make a plugin and followed the documentation to make a blank one as a starting point as instructed here: https://docs.unrealengine.com/latest/INT/Programming/Plugins/index.html#pluginexamples

I created a blank C++ Unreal project as starting point.

However, the plugin's source never show up in Visual Studio (I'm using the Community 2013 version). When I start my project from VS or the launcher, it detects that the plugin need rebuilding and starts recompiling without success (I think the exit message is "Target is up to date."). It then tells me that my project can't be recompiled, that I should try to compile it manually and exits.

What am I doing wrong?

My plugin folder

Product Version: Not Selected
Tags:
pluginstest.zip (16.1 kB)
more ▼

asked Feb 15 '15 at 05:55 AM in C++ Programming

avatar image

Nolendil
6 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Check the include in your plugin's build.cs file

"Nol/NolBlankPlugin/Private",

It probably should be NolBlankPlugin/Private (shouldn't need project name)

I'm also not sure that just the header file will compile and without any other files, it probably won't show up in VS, because there is nothing there.

more ▼

answered Feb 15 '15 at 06:23 AM

avatar image

Byte1
11 1 2 4

avatar image Nolendil Feb 25 '15 at 10:12 PM

Thanks for your answer. I changed the build.cs file but it gives the same result. I also tried using UObjectPlugin that does contain some functions (even if still only a header) and it is also the same. I find it weird that the documentation would advise to use those as a base if they don't work.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I wrote this recently...

https://answers.unrealengine.com/questions/166800/plugin-not-compiling.html

The major cause is the spelling of the plugin and such. So you can take that .zip file in there and carefuly compare what files and such are needed.

more ▼

answered Feb 15 '15 at 06:42 AM

avatar image

SND R Keene
968 31 120 113

avatar image Nolendil Feb 25 '15 at 10:15 PM

Thanks for your answer. I read your post but I checked everything over and over and everything seems spelled correctly. I must miss something. After reading the same files so many times, my brain wouldn't spot even an obvious mistake now :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question