x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blender fbx export contains garbage animations

When I export the animation as fbx for UE4 there are lot of garbage animations some of which are 2 frames long and others are same length as the required animation.

Once I made a walk cycle (~15-20 bones) of 180 frames with 30 fps and the exported fbx was 40MB!!! Lot of it was garbage animations in which the mesh was just twisted and deformed like hell, but my correct animation was somewhere among them.

In short when I import the fbx there are like 20 other animations imported along with the animation i want and I have to delete the others

So can anybody tell me how to avoid it? or how to manage and export multiple animations as fbx?

what i do is make the animation using keyframing , ik and directly select the armature and mesh and export is using FBX with selected objects , baked animation ,all actions ,NLA strips checked in export.

Please guide me

Product Version: Not Selected
Tags:
more ▼

asked Feb 15 '15 at 07:42 AM in Using UE4

avatar image

Commander Shepard
817 62 83 220

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

If you have auto keying on in blender, any time you move an object in the scene (like a light or a camera) it will create a new action. When you export animations from blender you're likely keeping the "all actions" button ticked, which will export the animations for your lights and things alongside your skeletal animations, and try and apply it somehow to your mesh (hence why it looks extremely deformed). If you're only trying to export one animation, just uncheck the all actions button in the exporter. If you want to get rid of the extra actions shift-click on the X button in the action editor when you have the garbage animation selected in blender.

more ▼

answered Feb 15 '15 at 09:32 AM

avatar image

greynz
237 25 15 26

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question