x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

'Clear Timer' doesn't stop the timer

As the title says. The following level blueprint starts the timer and it increases the number. It then arrives at the 'Clear Timer' when the number is 10 or above but the node doesn't actually do anything.

alt text

Product Version: Not Selected
Tags:
timerwontstop.png (122.3 kB)
more ▼

asked Feb 16 '15 at 02:17 PM in Bug Reports

avatar image

looper
78 4 5 10

avatar image looper Feb 16 '15 at 06:47 PM

Just tested identical blueprints in fresh projects on 4.6.1 and Preview 7 and the problem is only on Preview 7.

avatar image JeromeParent Feb 16 '15 at 07:20 PM

Specifically the Clear Timer node, or the Set Timer Delegates one too? Because if the delegates are broken then I need to enter a bug report since it will screw my project over pretty bad.

avatar image looper Feb 16 '15 at 07:35 PM

Problem with Set Timer Delegate too.

Also tested Pause Timer on both engine versions and it didn't work on either. Is something wrong with my installations or do you also have that problem?

avatar image JeromeParent Feb 16 '15 at 09:26 PM

I've never used Pause Timer.

I'll try the timer delegates tonight on 4.7.7 at home and enter a bug if it also happens to me.

avatar image lagrange Feb 25 '15 at 06:42 PM

I agree this looks like a bug. I just upgraded a game with lots of functionality from 4.6.1 to 4.7 and now most is broken because I'm using timers a lot. Neither "set timer to 0.0 (by name or delegate)" nor "clear timer (by name or delegate)" seems to work for me.

I also agree that is looks like you can clear the timer from external execution paths but not from within an execution initiated by the timer event / delegate (as stated by @greynz).

I'll have to wait with the upgrade to 4.7 until this is fixed because it's too much work changing all the timers everywhere.

Also, I haven't used the boolean functions "Timer exists" or "Timer active" much, but these just say "not within scope" when I run them. I might just be using them wrong though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey looper-

Thank you for the report. I was able to reproduce the behavior you mentioned and have logged the Clear Timer bug into our internal tracking database (UE-9932).

Cheers

Doug Wilson

more ▼

answered Feb 16 '15 at 07:58 PM

avatar image JeromeParent Feb 16 '15 at 09:27 PM

Can you also check if you can reproduce the Set Timer Delegates not working (as in the screenshot below) on 4.7.7?

avatar image Doug E ♦♦ STAFF Feb 16 '15 at 09:34 PM

I was able to reproduce the issue as looper posted originally, have you noticed an issue with Set Timer Delegate in 4.7 as well?

avatar image JeromeParent Feb 16 '15 at 09:39 PM

I do not have access to 4.7.7 at this moment (only later tonight), but looper mentioned that Set Timer Delegate no longer worked in 4.7.7 so I was just wondering if you had seen the same problem, because that will be a pretty big problem for me if its true :P

avatar image Jared Therriault Feb 17 '15 at 04:45 PM

I have the same issue in a 4.8 promoted build. I've been using macros to fill the void.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

There is a "Pause Timer" that might do something, but I would recommend using Set Timer Delegate instead of Set Timer in this situation. I use this setup all the time without issue.

alt text

capture.png (79.3 kB)
more ▼

answered Feb 16 '15 at 02:49 PM

avatar image

JeromeParent
1.2k 63 33 96

avatar image looper Feb 16 '15 at 03:56 PM

Thank you for your fast response. I tried your setup as seen below (at least that's how I understood it) but it still doesn't stop. It keeps printing 'STOP'. alt text

timerwontstop2.png (143.4 kB)
avatar image Shadowriver Feb 16 '15 at 04:02 PM

Try doing the same without delegate timers as i'm not sure you can even operate delegate timer same as function name timer

avatar image looper Feb 16 '15 at 04:05 PM

Same result.

avatar image JeromeParent Feb 16 '15 at 04:24 PM

That's pretty weird because I use timers that way everywhere in my game and they start/stop correctly... I'm still on 4.6.1, hopefully they didn't break in 4.7 or something.

For example this code below works fine. The "Continuous LOS Check" event stops firing when I execute the Set Timer Delegate node on the right. alt text

Maybe try to delete and re-create the custom event with a different name.

capture.png (134.7 kB)
avatar image looper Feb 16 '15 at 04:32 PM

Looks more and more like it could be a bug then I guess. I am using Preview 7. But it feels like a pretty huge one to not being able to stop timers :)

avatar image greynz Feb 22 '15 at 09:11 AM

It seems like you are only unable to stop a timer from within the timer. If you do start timer -> delay 1 second -> stop timer it will work. Unfortunately stopping a timer from within itself is pretty critical...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question