x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.6.1] NavMesh not saved with the map

I got in my map a NavMeshBoundsVolume placed with the settings:
Static
No Generate Overlap Events
No Collision

RecastNavMesh-Default with:
Enable Drawing
No rebuild at RunTime

In the Project Settings -> Navigation Mesh:
No Rebuild at Runtime

In the Project Settings -> Navigation System:
All unchecked, only "Add Players to Generation Seeds" enabled

1º- Build the map with the navmesh...
2º- Play and replay in the editor and work fine.
3º- Save all and close all.
4º- Open the engine, open the map = NO NAVMESH

Notes:
The model of the ground are a static mesh placed in the map using a box collision created in the engine (Model editor).
All time the editor say NAVMESH NEEDS TO BE REBUILD.

Product Version: Not Selected
Tags:
more ▼

asked Feb 16 '15 at 05:21 PM in Bug Reports

avatar image

Hevedy
651 64 78 119

avatar image TJ V ♦♦ STAFF Feb 16 '15 at 09:15 PM

Hi Hevedy,

I attempted to reproduce this in-house but so far I haven't been able too. Is this only reproducible in your project or can you also repro it in a new project?

avatar image Hevedy Feb 16 '15 at 10:44 PM

I going to test that tomorrow, and post here the results, i got more problems similar in the older versions of the engine.

avatar image Hevedy Feb 17 '15 at 11:26 AM

First of all, fail in all my maps of the project, all the maps have a sub-level (the same in all maps) with the light, fog & post process only. When change between the levels, the closed level at re-open bump no navmesh. *When i compile the maps (build) don't open the swarm or show nothing about compiling, but generate the navmesh.
No luck at the moment in new projects.

avatar image Hevedy Feb 17 '15 at 01:18 PM

Now, i have created a new project and then in the default map add a navmesh volume with the size of 2000x2000x200. Then go to the project settings and change in the in the Navigation Mesh -> Uncheck the "Rebuild at Runtime" if is checked, then go to the Navigation System and uncheck all, only check the "Add Players to Generation Seeds".
Now go to the editor preferences and to -> Level Editor - Miscellaneous and uncheck Update BSP Automatically & Update Navigation Automatically.
Now in the map make a a build, save all, close all,then open the editor and open the project and the map = NO NAVMESH. (Or without close nothing, click in load map and load the same map).
* Now you can change between the maps of the project and going to have the same problem all time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Hevedy,

I was able to reproduce this in 4.6.1. I found a report in our system for this same issue and it has now been fixed in our latest internal build. You should see this updated in a future release.

The only workaround that I know for this would be to to enable 'Update Navigation Automatically' again. When I reproduced it, this was the cause of the issue.

Cheers,

TJ

more ▼

answered Feb 17 '15 at 07:19 PM

avatar image

TJ V ♦♦ STAFF
41k 1009 183 494

avatar image Hevedy Feb 17 '15 at 07:48 PM

For the 4.7 release will be ready?

avatar image TJ V ♦♦ STAFF Feb 17 '15 at 08:01 PM

It's not impossible that it could make it in to 4.7, but it will likely be in the build after that.

avatar image Hevedy Jul 23 '15 at 10:05 AM

Is this fixed in the 4.9 ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question