x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Accessed None error from node

Hi, I'm getting hundreds of accessed none errors in my chunk creator but I don't really understand why or what they do? They're all pointing towards the set entrance piece which sets one of the 4 sections in my chunk. Any help would be great.

alt text

Product Version: Not Selected
Tags:
01.png (246.1 kB)
02.png (511.4 kB)
more ▼

asked Feb 17 '15 at 11:04 AM in Blueprint Scripting

avatar image

syphage
21 1 2 5

avatar image Zenshu May 14 '17 at 09:16 AM

I have just recently started getting this error and cannot for the life of me figure out what is causing it. Essentially I have a variable that is a reference to another actor in my project, which is a direct copy of another project I have with the only difference being the old project is top down and this new one is 3rd person. The issue only occurs in the third person project and occurs every time the reference to the actor is called by anything. I just can't figure out why it works perfectly in my topdown project but duplicated exactly in my third person project I get "Error Blueprint Runtime Error: Accessed None trying to read property Inventory Reference from function: 'ExecuteUbergraph_ThirdPersonCharacter' from node: Show Inventory in graph: EventGraph in object: ThirdPersonCharacter with description: Accessed None trying to read property Inventory Reference" or some variation of it every time my Inventory actor BP is attempted to be referenced. Previously whenever I ran into this issue it was because a function was being called before the parent had had time to actually be created in the world and adding a small delay prior to calling the function in the event graph would fix it...this time however that is absolutely not the issue and thus far nothing has worked in trying to remedy the problem, aside from deleting the actor and recreating it and the 50 or so functions within it I am at a loss.

avatar image Nachtmahr May 14 '17 at 10:10 AM

Make a new Post. Attach screenshots where you create/reference the Inventory and where you try to access the inventory.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

This is more often than not caused by a null reference. If you're trying to access an object or one of its properties, use the IsValid? node first to see if it's an existing object. If you try to act upon it and it does not yet exist or has been destroyed, you will get this error. Sometimes it happens when you don't even call the function that would fire it. Always check your references (and in C++, your pointers).

more ▼

answered Feb 17 '15 at 02:09 PM

avatar image

Jared Therriault
399 26 22 52

avatar image Motanum Dec 08 '16 at 10:23 PM

I just ran into this issue. Seems like some arrays dont get time to be populated with objects, before they are called in the loading phase. The isValid execute node solved this issue for me. Example of use.

alt text

avatar image Crazzyt9 Apr 23 '18 at 02:12 AM

Thank you, I recently was having this issue and your fix solved the problem instantly! Very Much Appreciated!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is usually caused by having two events (Like say, On Key Press A and On Key Press B) in a blueprint that have flow of control cross over between them.

This causes memory corruption style issues, and often in completely unrelated areas of blueprints something fails with the mysterious "Access None" message.

Also I do not recommend ever having variable access and such cross between streams. That is just ugly and not supportable.

It would be nifty if the editor detected function crossover like this. It would have saved me a ton of time and headaches.

So here is an example.

Like this....

alt text

And here it is fixed....

alt text

DON'T CROSS THE STREAMS https://hollywoodhatesme.files.wordpress.com/2011/11/streams.jpg

more ▼

answered Mar 10 '15 at 05:28 AM

avatar image

SND R Keene
968 31 120 113

avatar image syphage Mar 17 '15 at 02:56 PM

Hey thanks for this, I clicked answered on somebody else's post a while back because I gave up, just saw this post you made and tried it out, fixed straight away

avatar image aureon Apr 03 '15 at 11:22 AM

Is this real? Still a present bug? Why can we even do that if it's that problematic?

avatar image SND R Keene Jan 13 '16 at 05:44 PM

Further use of Unreal Engine over several months has clarified this issue.

It is not having a node be called from two events. That ALONE is ok. The problem is if you use an output of a node from one event in another event. The output will be invalid if the node it comes from was not called before the common node.

So my above screen shot example will actually work just fine. But if the Delta Seconds was used in the common print node (e.g. Delta was {d}) then in the Begin Play event it will be invalid (likely garbage or 0).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

ok I got solve my problem. thanks

more ▼

answered Jan 12 '16 at 02:57 AM

avatar image

shimozurdo
6 1 3

avatar image stabbedbyapanda Jul 25 '16 at 04:14 AM

And how did you fix it? Quite rude to ask for help then figure out said problem and not even post it.

avatar image finwefeanor Aug 18 '16 at 01:27 PM

I agree with stabbedbyapanda. If you solve it then please post your answer.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Basically what this means is the input into this node is none or null or whatever you wanna call it.

An invalid reference. It seems your array is out of bounds or not filled or something like that ;)

more ▼

answered Feb 17 '15 at 01:38 PM

avatar image

Erasio
5.9k 291 86 293

avatar image syphage Feb 17 '15 at 02:42 PM

Ah thank you, found an array that's telling me that it's not in scope, I'm guessing that it's probably that

avatar image Mortusnyte Mar 11 '15 at 09:34 PM

I built my entire project using Branches --> Not= to "None" to check for validity not knowing about the "Is Valid" node. Took me a while to fix that and other related issues :P

avatar image devel.bmad Apr 30 '15 at 10:10 AM

"Is Valid" doesen't seem to work for me in this case.. still the same error

avatar image Lanthorn Feb 07 '17 at 11:50 PM

I've been testing this for a while now, and I can confirm - sometimes the Accessed None error occurs when there certainly is a reference, and its right before your eyes, and your casting to it properly. Adding an IsValid sometimes suppresses the error, but sometimes it will occur anyway.

As my project has grown, I have had to add a vast quantity of IsValids through my blueprints to maintain stability, which begs the question - why do we need to IsValid something at every node to avoid these errors, especially when the event occurs regardless of the error? Is it the complexity of a blueprint or project, or some other factor that starts to demand all these validations?

I can justify a blueprint bloated with IsValids to prevent a bloated log file, but is that worth it?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question