x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.7_P8 - Externally Referenced Warnings

This was being investigated on the forums in the 4.7 Preview thread, moving the relevant information here for clarity.

  1. preview 7 was preventing my Skydome and Ocean materials from being applied, turns out it was a known issue relating to a blueprints Construction Script (which is where the materials were being applied, DynamicMaterialInstance's). It was also giving warnings of Externally Referenced items in the Map Check.

  2. preview 8 fixed that issue, however I am still receiving warnings when performing a Map Check, and a warning on save about externally referenced items. Here is a screenshot of the warnings: alt text

    Here are the most recent relevant posts

I tested out my project with preview 8 and am happy to report that the issue I was having with DynamicMaterialInstance's not being created through the Construction Script, which was preventing those materials from being applied, has been fixed in the new release.

However I am still receiving the "Externally Referenced" warnings I mentioned to Eric above. They are still being shown in the Map Check section of the Message Log, and I get a warning when I try to save the level about the externally referenced assets (which are not actually externally referenced).

I checked this with an already upgraded copy of the project, and also converted another new copy from 4.6.1 to make sure, and both of them show the warnings. It's not a big deal really but it could be confusing if left as is.

I just uploaded the newly converted copy of the project in case it will help you guys, you can download the project here: https://drive.google.com/file/d/0B3u_RPl4K60iOHIxVHpLSGsxbDg/view?usp=sharing

Eric Ketchum Replied:

Hey DotCam -

I am not finding any errors on loading your project in 4.7p8. I also spent a good amount of time trying to convert a project created in 4.6.1 to 4.7p8, both a C++ GitHub build/C++ project and a launcher variety with no success? Can you let me know if you are doing anything in C++ that would or does alter the components that are throwing the errors for you?

Let me know -

I replied back with more info:

The code is fairly straightforward, it is just a BuoyancyMovementComponent that can be attached to actors (such as the Buoy's in scene) and an OceanManager class that is the base class for the BP_Ocean blueprint. All it does is perform the calculations required for buoyancy when requested by the BuoyancyMovementComponent.

Neither of those classes affect the appearance of the ocean, they only calculate the wave height for Buoyancy. The Skydome itself is 100% blueprint. Nothing there that should be causing the warnings in editor

I deleted some files from the upload in the Intermediate, Saved, and Build folders to reduce the download size, so to make sure I just tested a fresh copy from the upload just now. When first opening the project, there are no Map Errors/Warnings, however if I go to the build button's dropdown box and select "Map Check" all of the warnings re-appear, and if I attempt to save I receive a warning dialog related to the external references error.

Would you guys prefer I create an issue on AnswerHub for this? I don't mind posting it all here, either way is fine by me. Thanks for looking into it Eric!


Upon request I have moved this over to AnswerHub, with my last post above being the latest info.

Thanks guys!

Product Version: Not Selected
Tags:
mapcheck.png (262.5 kB)
more ▼

asked Feb 18 '15 at 08:32 PM in Bug Reports

avatar image

DotCam
3.1k 74 34 147

avatar image Lovecraft_K ♦♦ STAFF Feb 18 '15 at 10:06 PM

Hey DotCam -

Can you possibly upload a 4.6.1 version of your project for us to test the conversion process on? I think something is happening in the local conversion process that is not being seen with the converted project.

Let me know, and thank you again for moving this over and summarizing everything too!

Eric Ketchum

avatar image DotCam Feb 18 '15 at 10:33 PM

Sure no problem, but there is a catch...

The code in BuoyancyMovementComponent will not compile for version 4.7 right out of the box, there were changes made to the UMovementComponent class in 4.7, specifically the "UpdatedComponent" property, which was changed from a UPrimitiveComponent to a USceneComponent.

There should be a total of 5 errors where "UpdateComponent" needs to be replaced with the new property UpdatedPrimitive in order to compile properly for 4.7.

You can always just grab the BuoyancyMovementComponent.CPP from the previous link and overwrite it, that would be the simplest way. There are no other changes made to the code.

Here's the download for version 4.6.1

Thanks!

avatar image Lovecraft_K ♦♦ STAFF Feb 19 '15 at 04:23 PM

Hey -

I was certain that this would cause the External References but I am not getting them even after converting on my local machine. I want to confirm are you updating as a Copy or a Convert in Place and also are you using a GitHub 4.7 Branch or are you using the Launcher 4.7 preview 8? Also when you are updating I want to make sure that your code is recompiling via the engine as you open the new 4.7 project?

Thank You for your help and patience -

Eric Ketchum

avatar image DotCam Feb 19 '15 at 04:42 PM

Hey Eric,

I have been using only the Launcher based 4.7 preview 8 version (and was before in preview 7 as well), and yes the first time I convert the project the engine is building the code for me without visual studio open.

Since I reported this I have been using "Convert in Place" each time since I am un-zipping a fresh copy from one of the two downloads. I didn't see the need for it at the time, but let me know if I should try using create a copy.

If you are not seeing it on your end at all, is it possible these warnings could be coming from the cache in AppData\Local\UnrealEngine? I am currently running a Verify from the launcher on preview 8, will let you know if that changes anything.

Thanks!

EDIT - I performed the Verify on 4.7p8 but it has not made a difference

(comments are locked)
10|2000 characters needed characters left

6 answers: sort voted first

Hi, I've made the the shift to v4.7 P8 from v4.6.1. I'm getting these warnings as well. But only when I open a new map in the editor. I can go between the levels in-game without any issue. I do not get any warning after quitting the level nor while loading the editor. The warning only appears when I load a new map in the editor.

Edit: Alright, I got it fixed based on a suggestion from another post with a similar issue: https://answers.unrealengine.com/questions/152144/ue461-externally-referenced-on-basic-map.html

Changing the project and folder name and then reopening it did the trick.

more ▼

answered Feb 20 '15 at 11:42 AM

avatar image

Stormrage256
942 82 75 117

avatar image DotCam Feb 20 '15 at 07:02 PM

Whaaaat...

How can this work?? It sounds ridiculous at first, but it actually works...

Ok so I renamed the folder to OceanDemo244, opened it, saved, closed, renamed to OceanDemo, re-opened, preformed a Map Check and all of the Externally Referenced warnings no longer appear.

That is really strange. Thank you for the help @Stormrage256!

@Eric have fun trying to track this one down... :P

avatar image Fezvez Mar 06 '15 at 04:58 AM

I didn't get exactly which folder this was about, and then I read your post (and realized that it was the whole .uproject folder) and miraculously, it works now!

avatar image JDuaneJ Sep 03 '15 at 01:37 AM

Gotta love duct tapes, ship it! Thanks guys. btw, still visible in 4.9

(comments are locked)
10|2000 characters needed characters left

Hi All,

Bad new, the Externally Referenced Warnings problem is not fixed in Mac version 4.7.4 Good new, the rename dir tips is always fixing the problem

Quadbyte

more ▼

answered Apr 05 '15 at 07:44 PM

avatar image

quadbyte
1 1 2 3

avatar image Lovecraft_K ♦♦ STAFF Apr 06 '15 at 02:59 PM

Hi Quadbyte -

We are looking into this issue again.

Thank You for your report -

Eric Ketchum

avatar image Lovecraft_K ♦♦ STAFF Apr 06 '15 at 07:58 PM

Hi Quadbyte -

Are you building from Source or using the Launcher version of the Editor?

Thank You

Eric Ketchum

avatar image quadbyte Apr 07 '15 at 04:55 AM

I'am using from the Launcher, which started for me a 4.7.4 editor version

avatar image Lovecraft_K ♦♦ STAFF Apr 08 '15 at 07:37 PM

Hi Quadbyte -

The next time you come across this issue in a sample project or small project that you do not mind sharing, can you please upload a copy here or to me via the private messages on the forum.

Thank You

Eric Ketchum

avatar image spaceharry Apr 13 '15 at 11:38 AM

This happens to me to when converting the project from 4.51 binary to 4.75 release source (guess it would be the same for converting to 4.75 binary, but didnt tried it yet). Renaming the folder makes some of the "external referencing" errors go away. But some (for a bp for example) are still there.

Even more now, when I renamed a folder from for example boids to boidss, the folder called boids is still there but empty. Don't know if that helps by finding a solution for this problem.

Edit: I just saw that even the boids folder which shouldn't exists anymore, is empty in the editor but when i check in windows explorer it still has files in it. And when I want to delete the folder in the editor it gives me warning about those files beeing deleted. Edit: This thing is happening on Windows.

On occassion I could send you some part of my project related to this error maybe. Would you more need the 4.51 version or the converted one?

Also other problems for converting my project happend in 4.7 preview and are still happening like that I have to include Media Player in proguard.txt file make my project launch in distribution build on android withouth crash:

https://answers.unrealengine.com/questions/177637/47-android-shipping-crash-on-launch.html

So far this is not such a big problem, but might be later on when video playback will be available in game on Android. I know that Android priority is not nr.1 on epic list, but maybe still worth a ticket as I am apparently not the only one with this conversion problem.

avatar image spaceharry Apr 13 '15 at 03:30 PM

After the external referencing errors got worse and worse even when trying the trick with renaming the folders I converted my project again from 4.51 to 4.75, but this time not with convert in place but instead with make a copy.

So far no referencing errors. But I think this was the same at beggining last time. So I wait now if it happens again and in case report back here.

avatar image NoahBeggs Sep 01 '15 at 12:30 AM

Just had this problem with a project being transferred from 4.8.3 to 4.9. Thank goodness for weird but effective solutions haha

avatar image N4cerBocaj Sep 01 '15 at 10:27 AM

Noah Beggs - how did you remove those 'externally referenced' warnings. I got 190 of them when opening my project in 4.9. Which if these solutions worked for you? Thanks

(comments are locked)
10|2000 characters needed characters left

this solution should work:

Redirector related error

more ▼

answered Sep 06 '15 at 12:48 PM

avatar image

paradoc
1.2k 48 29 86

(comments are locked)
10|2000 characters needed characters left

I was having the same issue going from 4.8 to 4.9. If you have a folder name with a "." in the name, just moving the "dot" seems to work. Hope that works for you.

more ▼

answered Sep 27 '15 at 10:10 PM

avatar image

Randy Jones
1 5 6

(comments are locked)
10|2000 characters needed characters left

I got this when converting a project from 4.8 to 4.9 and I think I found the source of the problem.

At the same time, I was looking up how to properly rename projects. I noticed that using the proper 'Create a Copy' method for making a new, updated version of an old project places everything in a folder with the same name expect for an appended version number. However, the config and project name entries were left as they were. By renaming the old project and making sure that the folder name matches the project file name, all the warnings stopped appearing.

more ▼

answered Oct 12 '15 at 11:36 AM

avatar image

Maffyland
1 1 1

avatar image aoakenfoArchiact Nov 12 '15 at 07:32 PM

Similar warning issues when copying a project from 4.9.2 to 4.10 using the Launcher. Making a copy of the folder manually and using the 'convert in place' option eliminated warnings.

avatar image ItsJustStan Dec 10 '15 at 09:37 AM

It is probably when copying the folder and then it indeed copy's all but the engine thinks the user added files like textures and models and such are also used by the other engine version (externally used). So changing the name is only option that works or maby delete the old copy of the project also works.

(comments are locked)
10|2000 characters needed characters left

Had the same problem switching form 4.11 to 4.12 (on Mac). To solve I had to deleted the Saved folder AND rename my project file (the yourprojectname.uproject file inside the project folder) After doing it, no more warnings at all. Hope it helps.

more ▼

answered Jan 22 '17 at 11:30 PM

avatar image

BlackGolem
11 2 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question