x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

SQLite in 4.6

Hello, how I'm supposed to include the sqlite into ue4? When I'm trying to include the SQLiteDatabaseConnection.h file I have an error:

Cannot open include file: 'SQLiteSupportPrivatePCH.h': No such file or directory

I have folled this topic and applied all the mentioned pathes: https://answers.unrealengine.com/questions/143256/46-how-to-use-sqlitesupport.html

Product Version: Not Selected
Tags:
more ▼

asked Feb 19 '15 at 07:39 AM in C++ Programming

avatar image

JaroMast
380 32 21 41

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey buddy - I fought with this same issue just now for about 2 hours - I'm not sure this is correct, but this limp you by:

Check your Engine\Source\Runtime\SQLiteSupport\Public directory for the file - I found mine actually in the Private directory. I copied it over to public so it could be found and I was able to get a successful build.

.h files for consistency should be placed in Public not Private.

I also had to use #include "../SQLiteSupport/Public/SQLiteResultSet.h" to get my project to locate the SQLite headers as well, so I'm thinking that there is something a little weird going on the with build rules.

But if you do that you should at least get a build till we get some more info on this.

Devs - can we please get a confirm/correction here?

more ▼

answered Feb 21 '15 at 10:06 PM

avatar image

devlyn811
349 21 18 35

avatar image Taimo__ Apr 17 '15 at 12:24 AM

The bug is discussed and reported here: https://answers.unrealengine.com/questions/184626/sqlitesupport-module-currently-broken.html#answer-185268 Strange that it worked for you by simple copying

avatar image devlyn811 Apr 17 '15 at 01:29 PM

What's strange is that it took me almost 2 hours. Outside of simply being a matter of file location, which should be easily fixed. I read through your referenced post - I'm not sure what they were doing that they had so much trouble... I fixed it locally figuring that someone would have discovered this thread, but it looks like the issue was already known and would have been easy to fix...

avatar image pranav2w Aug 08 '15 at 04:29 AM

Please help me...I have stuck in my project.

I had downloaded SQLiteUE4 from : https://github.com/KhArtNJava/SQLite3UE4

I am able to build the project successfully. I am able to see the database content in editor play. But whenever i try to launch/package the project it fails.

Here is the log file. http://shrib.com/see/AyNEcEsOXfTQHHJ...o6twF2joq?v=nc

avatar image devlyn811 Aug 10 '15 at 03:42 AM

I'm not seeing anything in your log link - it is leading to a blank page...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question