x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor crashes when using custom GameInstance (4.7 preview 8)

Hi all,

Lately I've been having trouble with the following issue:

UE-3480 Launching a project with a custom Game Instance assigned will receive an error and crash the launching window

I've come to learn that this issue was apparently fixed back in preview 5, however I've been experiencing it consistently throughout 4.7. When I launch my project without the GameInstance file in the Content folder, the project launches fine (aside from the "Can't find file for asset" messages).

It's pretty puzzling. Does anyone else have any experience with this issue, or any insight?

Product Version: Not Selected
Tags:
more ▼

asked Feb 22 '15 at 01:49 AM in Bug Reports

avatar image

zerofiftyone
204 26 28 93

avatar image TJ V ♦♦ STAFF Feb 23 '15 at 08:49 PM

Hi zerofiftyone,

The JIRA you mentioned was for a crash that occurred if you created a new GameInstance & add it to the project > then pressed Launch. I just attempted to reproduce this in 4.7. Preview 8 but so far I haven't been able to. What steps are you using?

avatar image zerofiftyone Feb 24 '15 at 10:13 AM

Ah, so it appears to be a separate issue. The problem I have occurs when converting an existing 4.6.1 project up to 4.7. When that project has a custom GameInstance file assigned, the editor crashes on launch (by which I mean on opening the project, not running the game).

Sorry for any confusion; I assumed from the bug description that this was the same issue!

Edit: Here's the crash report: http://pastebin.com/Mf85PKHw

avatar image TJ V ♦♦ STAFF Feb 24 '15 at 05:41 PM

I tried creating a new 4.6.1 project > create & add a new Game Instance > then convert it to 4.7 Preview 8. So far it is working correctly for me. Do you have a small test project that you can upload that has the issue?

avatar image zerofiftyone Feb 24 '15 at 08:38 PM

Well this is interesting. I just tried with a new project and it seemed to work. Even when I imported the GameInstance file from the original project it still worked.

Weird. I'll do some more digging to figure out what's going on with my project that's causing this.

avatar image zerofiftyone Feb 24 '15 at 09:26 PM

Follow-up:

I got it working. The problem seemed to be with that particular GameInstance file. For reasons I can't understand, the project works fine now that I've rebuilt that file from scratch and used that instead.

Thanks for your help TJ. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Fixed it. I ended up having to scrap the GameInstance file, upgrade the project to 4.7 and then rebuild the GameInstance file from scratch.

I don't understand why it works, but it does! That's game development, folks!

:D

Edit:

But there's a twist! Turns out that my project is still broken :(. Once I closed it and reopened it, the problem arose again. :(

more ▼

answered Feb 24 '15 at 09:37 PM

avatar image

zerofiftyone
204 26 28 93

avatar image zerofiftyone Feb 25 '15 at 01:51 AM

It turns out the ACTUAL problem was down to a bad macro library, a similar case to this thread: https://answers.unrealengine.com/questions/161024/47-p3-source-blueprints-causing-crash-on-load.html

Once I got rid of the macro library and replaced the references, the project seemed to launch okay. /fingerscrossed

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question