x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VS2013 Code Completion?

Hey,

just started playing around with the engine and tried to do the pizza platformer modification from the youtube programmer introduction video.. What I noticed is that Visual Studio basically is no help at all. There's no code completion, there are no recommendations at all. For example I try to set the radius for the boundingsphere and type "TouchSphere->".. Nothing. This really bothers me because I hate searching for writing errors. I also like to browse through all the functions I can use on an object to see what I can do and what could be useful. Is it just my Visual Studio (using VS2013 Premium btw) or is it a problem in general?

Thanks for helping!

Product Version: Not Selected
Tags:
more ▼

asked Mar 24 '14 at 11:56 PM in C++ Programming

avatar image

LustyArgonian
83 5 8 12

avatar image Dark-Veil STAFF Mar 24 '14 at 11:59 PM

Sorry you are having trouble! This has worked fine in Express versions in the past. It might take a while for Visual Studio to digest all of the symbols before code completion starts working. Is completion working OK for new simple C++ projects you create using the Visual Studio New Project wizard? Just curious. Also try pressing Ctrl + Alt + Space to summon a completion window manually to see if that works. I'll test this again tomorrow when I'm in the office.

--Mike

avatar image LustyArgonian Mar 25 '14 at 12:18 AM

Hey Mike,

thanks for your fast reply! Actually I used VS2012 on a regular basis for C++ development but only yesterday I switched to VS2013 for UE4. Just created a simple hello world project and everything worked as expected. It's really strange. I just tried to do the FPS tutorial from the UE wiki. My GameMode file now works with code completion and there are no intellisense errors anymore but my character file still shows intellisense errors and there's no code completion even after several minutes. Don't really know why this is happening.

--Daniel

// Edit: Summoning a completion window manually also isn't possible. Seems like intellisense just doesn't recognize the objects as objects.

avatar image Dark-Veil STAFF Mar 26 '14 at 04:08 PM

I'm entered a task in our database about this, and we're going to have an engineer or two spend some time looking at IntelliSense issues with VS Express. We absolutely want this to be working reliably. Please let us know if you guys find specifically reproducible issues or workarounds though.

--Mike

avatar image Footman Mar 26 '14 at 11:19 PM

By Visual Studio 2013 everything works well only with Visual Assist addon.

avatar image Dark-Veil STAFF Mar 27 '14 at 03:28 AM

Thanks Footman, that is good to hear.

Many developers at Epic use Visual Assist and we know it works really well with Unreal Engine, but our intention is to make IntelliSense work great for users without that add-on too.

The IntelliSense compiler from Microsoft is actually a version of the EDG C++ compiler. It parses our C++ code by invoking a compiler frontend over the source. You can actually see when it is compiling by looking in the bottom right corner of Visual Studio. You'll see a little animated 'down arrow' icon while it is working. It compiles the code and only provides reliable results (including 'squiggles') after it has finished running. Usually it finishes pretty quickly, and it will cache the results and handles incremental changes to code files in a robust way.

The EDG compiler relies on our project files being setup correctly. That means that the IntelliSense section of the project's settings needs to have the correct include paths and definitions for every project. It's a little hard to get this perfect because of Unreal Engine's extremely modular granularity, where Visual Studio only allows unique definitions and include paths on a per-project basis, but in general it usually works really well. We combine the includes and definitions for modules within any project and set those as the IntelliSense includes and definitions. It's not perfect however.

Help us improve this by finding concrete repro cases in our C++ sample games and "empty" C++ projects.

--Mike

avatar image Footman Mar 25 '14 at 12:11 AM

On Windows VS 2013:

  • Completion and goto definition within Engine folder

  • No competition and goto definition within game project folder

On Mac Xcode:

  • No right competition and goto definition anywhere after 1,5 hours indexing.

I am dealing with this problem already several days because i can not work this way. No good solution yet.

avatar image LustyArgonian Mar 25 '14 at 12:33 AM

There's even no completion within the engine project for me. What version of VS did you try? Express?

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

I had the same problem as you, Visual Studio seems to be very bad on it's own if you want to program in c++, but when I installed https://www.wholetomato.com/ most of the IDE features that you are expecting seem to work.

It's still sometimes very slow and it shows you errors which only go away if you recompile, but it's usable.

more ▼

answered Mar 25 '14 at 12:25 AM

avatar image

maikklein
115 28 25 34

avatar image LustyArgonian Mar 25 '14 at 12:41 AM

Well that looks like an awesome tool in general but I don't really want to purchase it right now and a third party tool shouldn't be the solution to this problem. Thanks anyway!

(comments are locked)
10|2000 characters needed characters left

Try the following:

  • Build solution

  • Close VS

  • In the editor File->Refresh VS Project

  • File->Open VS

Give it 5-10 seconds to rescan files

more ▼

answered Mar 26 '14 at 12:36 AM

avatar image

phoboz
998 37 13 60

avatar image d1sasterpiece Mar 26 '14 at 10:27 PM

I just tried this and this seems to reset the code completion and makes it work for a small amound of time.

I just ran into the same problem when editing another file. The described solution does reset the completion, but it does not seem to be very reliable at all and is quite frustrating making coding for me impossible right now.

Hope the bug gets fixed. If I can provide any additional info to help, I'm happy to do so, I'm not sure what to look for, not very accustomed to C++ and Visual Studio 2013 (Pro)

(comments are locked)
10|2000 characters needed characters left

I was having the same problem as you, following the tutorial and no code completion in sight, really annoying! But after keeping visual studio 2013 running a little while suddenly it just popped right in.

The only thing that I changed was that I was following this answer: https://answers.unrealengine.com/questions/3647/how-to-improve-compile-times-for-a-c-project.html , so I'm not sure if it was that change or the waiting that turned the code completion on.

more ▼

answered Mar 25 '14 at 11:21 PM

avatar image

Flassari
11 2

avatar image KDeLorey Mar 27 '14 at 05:48 AM

Visual Studio take awhile to index the code and create IntelliSense files. Once it's done it should work a lot better. You can generally see it parsing files in the status bar.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question