x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Is there a way to stop particles partially disappearing inside objects?

I've created a simple particle system that fires a single particle, and spawns a shockwave particle on collision with an object. My problem is that the shockwave particle always ends up being partially hidden inside the object that the original particle collided with. The portion of the particle that's hidden depends on the camera angle.

For example, this is a screenshot of what the shockwave particle should look like: alt text

And this is how the particle actually appears when spawned from a collision event: alt text

Is there a sorting layer I can use to make particles always appear over static meshes and other objects, or any other way to prevent the particle being partially hidden by the object? Thanks for any guidance.

Product Version: Not Selected
Tags:
shockwave1.png (19.7 kB)
shockwave2.png (253.4 kB)
more ▼

asked Feb 23 '15 at 03:17 AM in Using UE4

avatar image

Nibsley
31 4 6 8

avatar image IanBreeg Feb 24 '15 at 08:56 AM

It also looks like it might be the wrong rotation value. Are you sure it's perfectly aligned to the surface normal? You might want to use decals for such type of effects.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

A few things here, the reason you are seeing this clipping is because it is a camera facing sprite. At this angle of the camera you will get clipping. Few options, you can try the particle module "camera offset" this will offset the particle towards the camera the amount you enter. This will help in some cases but might not solve your problem. Another option is to spawn or rotate your emitter of the surface normal and lock your sprite to a single axis. This will always keep the sprite aligned with the wall or surface. If this is an impact effect or explosion in the blueprint you can do a line trace to the wall and use that surface normal to set the emitters spawn rotation so that it is always consistent.

One last trick is to add depth fade in your material. By adding this to your translucency channel it will fade out any parts that intersect with the wall. Try messing with the settings and you can get a nice soft falloff.

more ▼

answered Mar 08 '15 at 07:41 PM

avatar image

Matt Hancy STAFF
26 1 1 4

avatar image Nibsley Mar 10 '15 at 04:52 PM

The camera offset module actually worked perfectly in this case, thanks so much for the answer!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

One last piece of info that might help. If you are doing a line trace or getting a hit result you can do a "break Hit result" and get the Impact normal of the object you hit. If you plug that into a function called "Make Rot from X" and then plug that into your rotation of the emitter you spawn. It will always rotate the positive X of your emitter with the surface normal of the wall.

more ▼

answered Mar 08 '15 at 07:47 PM

avatar image

Matt Hancy STAFF
26 1 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If you actually want the particle to face you and not align itself to the surface, the material used in your particle must be set to Translucent and have Disable Depth Test enabled.

See my included picture.

alt text

more ▼

answered Jul 17 '16 at 03:38 PM

avatar image

gOtHiCmetalhead
1 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question