x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

cannot resolve RC1015 & C1083 /w UE4.7.0 & VS2013

This is the first time I've installed (on this machine or otherwise) VS2013 and UE4. I try do to the Hello World tutorial but I get the dreaded messeges when I fire up a new blank C++ project without the starter content from the engine launcher:

Project Conversion Failed

The project failed to compile with this version of the engine. Would you like to open the project in Visual Studio?

The log shows the followoing:

 ![The project failed to compile with this version of the engine. Build output is as follows:
 
 Running C:/Program Files/Epic Games/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe FML Development Win64 -project="E:/UE4 projects/FML/FML.uproject" -rocket -editorrecompile -progress
 Parsing headers for FMLEditor
 Reflection code generated for FMLEditor
 Performing 7 actions (4 in parallel)
 [2/7] Resource ModuleVersionResource.rc.inl
 [3/7] Resource FML.rc
 E:\UE4 projects\FML\Source\FML\Resources\Windows\FML.rc(8) : fatal error RC1015: cannot open include file 'windows.h'.
 
 PCH.FML.FML.h.cpp
 C:\Program Files\Epic Games\4.7\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3) : fatal error RC1015: cannot open include file 'windows.h'.
 
 C:\Program Files\Epic Games\4.7\Engine\Source\Runtime\Core\Public\HAL\PlatformIncludes.h(5) : fatal error C1083: Cannot open include file: 'new': No such file or directory
 -------- End Detailed Actions Stats -----------------------------------------------------------
 ERROR: UBT ERROR: Failed to produce item: E:\UE4 projects\FML\Binaries\Win64\UE4Editor-FML.dll
 Cumulative action seconds (4 processors): 0.00 building projects, 0.50 compiling, 0.00 creating app bundles, 0.00 generating debug info, 0.00 linking, 0.00 other
 UBT execution time: 10.17 seconds][1]


Using: UE 4.7.0 preview 8 (I don't have any other version installed), this is the installer version, not source.

VS2013 Ultimate

Win8.1 pro

Windows SDK for 8.1 is also installed. I've also Repaired VS to no avail then uninstalled and reinstalled it.


I've followed the instructions here: https://docs.unrealengine.com/latest/INT/Programming/Development/VisualStudioSetup/index.html BUT! At the place where I can change the Max Cache Translation Units, it's locked on 2 for me and I can't change it. Also installed the visualizer and extension: https://docs.unrealengine.com/latest/INT/Programming/Development/VisualStudioSetup/UnrealVS/index.html

I've uninstalled VS2012 but many files have been left behind. Don't know if to manually delete them or not. Anyhow I've deleted the enviroment variables for 2012 and the 2013 are corrent and are: E:\Program Files (x86)\Microsoft\Visual Studio 12.0\Common7\Tools\

I've changed my windows log-on name to contain English characters only and anyhow the path of the installations paths of UE, VS and the project itself are always containing only english latters and numbers. It did not change older settings. Could it be because my username was originally (and perhaps still is) non-english this screws it up? Like I've written the project and installations folders are all english letters and numbers only.


UE4 on is on is running A-OK. I had VS2012 and I've uninstalled it to make room for VS2013. Borh versions were ultimate.


In my project folder I've located the .uproject file and right-clicked on Generate Visual Studio project files.

I get the following message:

Missing new1 Modules

The following modules aew missing or built with a different engine version:

UE4Editor-new1.dll

Would you like to rebuild them now?

new1 is the name of the project. Selecting Yes prompts:

new1 could not be compiled. Try rebuilding from source menually.

As I've mentioned I'm not working with the source. Installer only.

WHAT DO I DO NOW? Also attached the in new1.rar.txt the output of an attempt to create a new project. Thanks in advance :)

link text

link text

[1]: /storage/temp/30773-1.jpg

Product Version: Not Selected
Tags:
1.jpg (182.4 kB)
info.txt (8.3 kB)
new1.rar.txt (717.9 kB)
more ▼

asked Feb 23 '15 at 08:12 AM in Installation & Setup

avatar image

Archonite
26 3 5 5

avatar image Tim C ♦♦ STAFF Feb 23 '15 at 05:07 PM

Hi Archonite,

I tried to reproduce the issue that you described, but have not had any success so far. It looks like you have already spent some time trying to track down this issue, and it seems like you have already covered what usually solves these errors. I do have some questions for you.

  • Have you tried verifying the Engine installation through the Launcher?

  • Do you have a link for the tutorial you were following?

  • Are you able to create Blueprint projects and this issue only occurs when trying to create a Code project (or add code to a Blueprint project)?

The only thing I have not been able to check is trying to build a project using Visual Studio 2013 Ultimate. None of us here use the Ultimate version. We will be providing the release version 4.7 soon. If you download the previous release version (4.6.1), do you still see the same results?

Tim

avatar image Archonite Feb 23 '15 at 07:49 PM

Thank you for your reply.

How do I verify the engine? I do know I've downloaded and installed only 4.7.0 p8. If it's a separate operation, please do tell me how to do it.

The tutorial here.

I've opened a new BP project and played with it a little and everything was ok. Then I've added a new C++ class as an actor and it failed prompting the following message:

Failed to add class MyActor. Failed to compile newly created game module.

It created some files (as it didn't let me try another shot with the same class name) and that's it. It didn't fired up visual studio or anything.

I don't have 4.6.1 but I'll free some space and I'll try.

avatar image Tim C ♦♦ STAFF Feb 23 '15 at 09:31 PM

To verify the installation of one of the binary versions of the Engine, you would go to the Library section of your Launcher and click the down-arrow for the version of the Engine you have installed. One of the options in the menu that appears will be Verify. Selecting that option will run through the installation to check that everything is correct.

Verify

If you look at your project folder using Windows Explorer, does it contain a Source folder and a Visual Studio solution file?

verify.png (29.7 kB)
avatar image Archonite Feb 24 '15 at 07:55 AM

OK I've installed 4.6.1, verified it and when I've added a c++ actor the message was it was successful and visual studio opened up. When I tried to build there were errors. I don't know if that's ok or not, I just tried to build the project as is as VS opened up. Building C++ from scratch also worked with 4.6.1.

I've verified 4.7 and there was no indication for any errors but the problem still remain.

Yes, there is a source folder with all the files inside (excluding those it could not create like window.h) and there's a .sln file and a .sdf file.

avatar image Tim C ♦♦ STAFF Feb 24 '15 at 05:02 PM

I just ran through the Quick Start guide again without any problems (using version 4.7 preview 8, Windows 7, and VS 2013 Professional). I wanted to outline what I observed and hopefully you can let me know exactly where things started happening differently for you.

  • Created a new Blank Blueprint project (I also tried it with a Basic Code project, which opened both Visual Studio and the Editor).

  • Added a new Actor C++ class to the project.

  • The Editor compiled the new code class and performed a Hot Reload. The new class was opened in Visual Studio.

  • Added the code mentioned in the Quick Start guide.

  • Built the project in Visual Studio.

  • Added an instance of the new Actor class to the level.

  • Started Play-In-Editor mode.

From what you have said already, it seems like the third step is where things start happening differently for you. Is that correct? I am going to see if I can get someone to run through the Quick Start guide on a Windows 8.1 machine to rule out the OS version as the culprit.

I do have a few more questions and observations for you:

  • What are the build errors that you saw with version 4.6.1?

  • Were you trying to build immediately after adding a new Actor class without modifying any of the default code that comes with the new class?

  • What are your Solution Configuration and Solution Platform set to?

  • For the project that is giving you trouble in 4.7 preview 8, if you open the solution file in Visual studio, does it open successfully?

  • Do you get the same errors (C1083 and RC1015) if you try to build that solution in Visual Studio?

  • I was able to open the sample project that you provided in your original post in 4.7 preview 8, and was able to build that project in Visual Studio without any errors.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Problem solved! My Windows user-name was in non-english characters and changing just the log-on name and having all the paths for the project and installations in english is not enough. So I made a new user and now it works.

I hope that by EU5 it will be more tolerant to non-english characters in the system.

Thank you for your help and I hope that other people who got stuck like me for this stupid reason will find this thread and solve their problem with less agony.

more ▼

answered Feb 27 '15 at 07:39 AM

avatar image

Archonite
26 3 5 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

UE build tool does not provide a new C++ project with proper values for "Include Directories" and "Library Directories". You can fix this issue by setting this values, for example you can open properties of UE4 project which is in the solution too and copy values to your project. Two marked values were empty. Set them and build again.

Project Settings

more ▼

answered Apr 09 '15 at 03:30 PM

avatar image

khizhaster
16 6

avatar image j0rg3n Sep 24 '15 at 09:18 AM

For me, the empty settings were possible to fix by simply selecting "Inherit from Project Defaults" (the project does inherit from the right property sheets, it's just that the properties in question have been explicitly cleared in the project file).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

(couldn't comment for some reason) That is correct. The problem starts at the first compiling phase.

Now I've started a new C++ project in 4.6.1 (accidently with starter content) and after the compilation ends and VS starts with no errors I press on F7 to build (The batch builder does nothing when I press on start) and the output window prints this: (no code was changed)

 1>------ Build started: Project: foursix2, Configuration: Development_Editor x64 ------
 1>  Parsing headers for foursix2Editor
 1>  Reflection code generated for foursix2Editor
 1>  Performing 8 actions (4 in parallel)
 1>  [3/8] Resource foursix2.rc
 1>  [2/8] Resource ModuleVersionResource.rc.inl
 1>E:\UE4 projects\foursix2\Source\foursix2\Resources\Windows\foursix2.rc(8): fatal error RC1015: cannot open include file 'windows.h'.
 1>  
 1>  PCH.foursix2.foursix2.h.cpp
 1>C:\Program Files\Epic Games\4.6\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3): fatal error RC1015: cannot open include file 'windows.h'.
 1>  
 1>C:\Program Files\Epic Games\4.6\Engine\Source\Runtime\Core\Public\HAL\PlatformIncludes.h(5): fatal error C1083: Cannot open include file: 'new': No such file or directory
 1>  -------- End Detailed Actions Stats -----------------------------------------------------------
 1>ERROR : UBT error : Failed to produce item: E:\UE4 projects\foursix2\Binaries\Win64\UE4Editor-foursix2.dll
 1>  Cumulative action seconds (4 processors): 0.00 building projects, 0.62 compiling, 0.00 creating app bundles, 0.00 generating debug info, 0.00 linking, 0.00 other
 1>  UBT execution time: 9.35 seconds
 1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ""C:\Program Files\Epic Games\4.6\Engine\Build\BatchFiles\Build.bat" foursix2Editor Win64 Development "E:\UE4 projects\foursix2\foursix2.uproject" -rocket" exited with code -1.
 ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

The UE closes and when I try to open the project again in the editor I get error:

Missing foursix2 Modules

The following modules are missing or built with a different engine version:

UE4Editor-foursix2.dll

Would you like to rebuild then now?

Pressing on YES give the following error:

Error foursix2 could not be compiled. Try rebuilding from source manually.

Doing another 4.6.1 project starting with blueprint and adding a c++ actor gives this message:

Successfully added class AActorTest. Would you like to edit the code now?

Choosing YES and opening VS. Then in VS I refresh the project and the new project is loaded at the toolbar. The configurations are Development Editor and Windows. I hit F7 to build and get this in the output:

 1>------ Build started: Project: foursix3, Configuration: Development_Editor x64 ------
 1>  Parsing headers for foursix3Editor
 1>  Reflection code generated for foursix3Editor
 1>  Performing 8 actions (4 in parallel)
 1>  [3/8] Resource foursix3.rc
 1>  [2/8] Resource ModuleVersionResource.rc.inl
 1>C:\Program Files\Epic Games\4.6\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3): fatal error RC1015: cannot open include file 'windows.h'.
 1>  
 1>E:\UE4 projects\foursix3\Source\foursix3\Resources\Windows\foursix3.rc(8): fatal error RC1015: cannot open include file 'windows.h'.
 1>  
 1>  PCH.foursix3.foursix3.h.cpp
 1>C:\Program Files\Epic Games\4.6\Engine\Source\Runtime\Core\Public\HAL\PlatformIncludes.h(5): fatal error C1083: Cannot open include file: 'new': No such file or directory
 1>  -------- End Detailed Actions Stats -----------------------------------------------------------
 1>ERROR : UBT error : Failed to produce item: E:\UE4 projects\foursix3\Binaries\Win64\UE4Editor-foursix3.dll
 1>  Cumulative action seconds (4 processors): 0.00 building projects, 0.42 compiling, 0.00 creating app bundles, 0.00 generating debug info, 0.00 linking, 0.00 other
 1>  UBT execution time: 8.74 seconds
 1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ""C:\Program Files\Epic Games\4.6\Engine\Build\BatchFiles\Build.bat" foursix3Editor Win64 Development "E:\UE4 projects\foursix3\foursix3.uproject" -rocket" exited with code -1.
 ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I didn't touch any of the code.

All the solutions (4.7 and 4.6) are opened without any troubles in VS.

I get the feelings that the problem might the win8.1 and VS ultimate combo. I'll download later Pro and try again.

more ▼

answered Feb 24 '15 at 05:48 PM

avatar image

Archonite
26 3 5 5

avatar image Tim C ♦♦ STAFF Feb 24 '15 at 06:49 PM

Before you try installing VS Professional, it may be simpler/faster to try removing/re-installing the Windows 8.1 SDK first, just to make sure nothing is corrupted there.

avatar image Archonite Feb 25 '15 at 10:34 PM

I've installed VS2013 pro (after uninstalling ult) and UE4.7 and the same problem still persist. How can I wipe-clean VS from my computer and try again? I don't know what to do anymore :(

avatar image Tim C ♦♦ STAFF Feb 26 '15 at 04:26 PM

I could have sworn that I asked you about this before, but reading back through this post I can't find it mentioned anywhere. I guess I was just thinking it and not actually typing.

Could you try temporarily disabling your anti-virus software, then try building again in Visual Studio? In older versions of the Engine, this helped a few users who were seeing these same errors.

avatar image Archonite Feb 28 '15 at 08:45 AM

I don't have a dedicated anti-virus. Just the Microsoft Windows Defender that comes with Windows.

avatar image Archonite Feb 28 '15 at 10:11 AM

OK, I've shut Windows Defenfer off, updated to UE4.7.1 and the problems still occur. I'm pretty sure by this point that the User Name (not just the log-on name) in Windows must be English characters only regardless of where UE, VS and the project are installed/located.

avatar image Tim C ♦♦ STAFF Mar 02 '15 at 10:27 PM

I'm glad to hear that you seem to have found a workaround for this issue. We are still interested in seeing if we might be able to find a way to resolve this issue. Would you mind sharing your Windows user name that was causing the problem, or at least what non-latin characters were included in the Windows user name? We would like to try to create a test case for this issue, and knowing what characters were causing the issue for you may help us track it down.

avatar image Archonite Mar 08 '15 at 07:11 AM

Oops missed that reply. Sorry.

my user name is: שי The language is Hebrew .

In UE when it tried to read a path with Hebrew characters it would be seen as gibberish characters ("A"s with circles and dots of kinds) but like I said before, installations, paths and project names were in English-only.

I have no idea why the non-latin characters cause such issues. In Unity, while not officially supporting hebrew at all, it has no problems with files (and probably paths) in Hebrew except for printing it end-to-start (because Hebrew is written right-to-left).

Also I had UDK before UE4 and I had no such issues with my user name ever (while still maintaining that all paths and names are English only since I knew UDK doesn't like non-eng also). I've never extended the engine nor worked with uScript so I might have had problems there but I never got far enough to test it out.

avatar image Archonite Feb 24 '15 at 07:54 PM

Will do. But before that I'll update to 4.7 which as came out of beta today. Perhaps somehow it would be fixed by a fluk. I'll return with the results after re-installing the SDK and installing the new 4.7.

avatar image Archonite Feb 24 '15 at 08:51 PM

There isn't an option to uninstall the stuff at the SDK (not that I've found) so I've downloaded it again and manually executed the installers. Before that the main installer of the package printed that everything is already installed after some lenghty check.

Anyhow I've upgraded to the new 4.7 and verified and... the problem still persist :(

Should I try to uninstall VS and reinstall pro or community?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question