x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

3ds Max to UE4 - UV Channel 1

Hello,

I'm having trouble with all my models I've been trying to export into Unreal Engine from 3ds Max Design. They all seem to import with overlapping UVs from the channel 1 (I think anyway), even though I have not set any UV channels on the number 1 in 3ds max or when importing the FBX I have un-ticked textures, materials and tried many different import ticking options with no luck. I set a UV Unwrap in 3ds max and it looks like this in UE4 on channel 0 - alt text

There are many small objects in the model which have been unfolded and have spaces in-between them. This is what it looks like when I select the Channel 1 drop down - alt text

Very messy! I have no idea how that got there or how to remove it? I've collapsed the objects in 3ds max and removed all UVs and started it over from fresh, but still this happens and I guess this is what is causing the error of overlapping UVs popping up when I build the lighting in the engine?

Any help would be appreciated :) Thank you!

Product Version: Not Selected
Tags:
uvchannel0.jpg (509.1 kB)
uvchannel1.jpg (311.7 kB)
more ▼

asked Feb 24 '15 at 11:22 AM in Using UE4

avatar image

QBert
23 5 4 9

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I just thought of something... If I create the same unwrap UVW for both Map Channel 1 & 2 in 3DS Max, then will this fix the problem? (I'm not at my UE4 computer currently)

edit: Yes this seems to work, there seemed to be a second channel being created either during the export process or import process. I have created a second lot of UVs on channel 2 in 3DS Max and it has fixed the overlapping problem.

more ▼

answered Feb 24 '15 at 11:25 PM

avatar image

QBert
23 5 4 9

avatar image Tim Hobson ♦♦ STAFF Feb 26 '15 at 01:35 AM

By default (since 4.5) a lightmap channel (UV Channel 1 in UE4) is created on import unless you uncheck the import option for "Generate Lightmap UV." This is where the second UV you were finding was coming from.

avatar image DFish32 Mar 06 '15 at 04:48 AM

Why can't we use that channel that is created when checking the box for "Generate Lightmap UV" on the import of an fbx ?

avatar image Tim Hobson ♦♦ STAFF Mar 06 '15 at 07:59 PM

The one that is generated will generate to Channel 1 by default. You can use any channel you like for your lightmap. The default is 1 though. If you need to generate it to a different level you can specify this in the build settings.

https://wiki.unrealengine.com/LightingTroubleshootingGuide#How_do_I_generate_lightmap_UVs_in_the_editor.3F

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question