x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Floats read 0 in 4.7

I just ported my project from 4.6 to 4.7 and literally 99% of everything I've added in blueprints in the entire game doesn't work at all. It either doesn't show up or has a crazy effect.

My zoom fov is zooming into a single pixel point. My sprint modifier stops me dead. etc....

It appears that every single existing float variable that's present in the game is reading as 0 when I go to output it to screen. If I create a new float variable, it seems to hold and it reads the value fine but I have hundreds of these things being used all over the place and I don't even know where to begin to attempt and repair this.

EDIT: Renaming the variable and compiling the blueprint seems to solve the issue.

Unsure if INT, BOOL, BYTE, ENUM, STRING...etc are affected yet.

http://youtu.be/buBZ-m-XGuM

UPDATE: It appears every variable with a default value has been wiped clean. Any variables that set their values are still ok.

When I rename variables in a parent blueprint, it wipes all of the default values in every single child blueprint.

This is game breaking and I am forced to remain on 4.6

Update: INTs are broken

I duplicated the project and converted in place to 4.7 and I also ran 4.7 and opened as a copy and the results are the same.

Product Version: Not Selected
Tags:
more ▼

asked Feb 24 '15 at 09:17 PM in Blueprint Scripting

avatar image

Hitpawz
551 22 29 45

avatar image Mortusnyte Feb 24 '15 at 09:26 PM

Thanks for the heads up... I hope you made a back up before porting. It sounds like your values all got reset to their default value.

I hope someone can help out.

avatar image Hitpawz Feb 25 '15 at 06:38 PM

Thanks for the response.

Mortusnyte, yea I still have my 4.6 version that works fine and is what I'm still working on until this can be solved.

Ben, I haven't seen a single person in the Skype group or anywhere in the forums or anything experience the same issue as me. I'm quite certain if I start a new project that it will transfer over fine. Something is inside my particular project that is causing this as I've tried it several times now and I keep getting the same thing.

Since we probably can't pinpoint the repro very easily, I'm zipping up the entire project and uploading it to my website. It will be roughly 1.75gb and take 25mins to upload.

Is there a private email or message box I can send this link to you at? Or could you maybe add me on Skype and we can work it out that way? I'm "hitpawz".

avatar image Dan.OConnor STAFF Feb 25 '15 at 06:51 PM

Could you attach your log file? It should be located in your project's Saved/Logs directory.

avatar image Hitpawz Feb 25 '15 at 07:21 PM

Looking at it myself, it's going crazy mainly due to all of the variables not being set correctly to feed the whole chain of events properly like setting meshes and whatnot.

The entire project is uploaded. Let me know if you would like the link and if so, please give me a private location to forward that to you.

link text

rats_saveme.log (532.7 kB)
avatar image Dan.OConnor STAFF Feb 25 '15 at 09:36 PM

Hmm.. nothing obvious in the logs. I messaged you on the forums.

avatar image Hitpawz Feb 25 '15 at 10:25 PM

Reply sent. Please let me know if there's any issues.

avatar image MkII Feb 25 '15 at 10:53 PM

Hey Hipawz,

I believe I am also facing the same issue, so you're not alone! I've noticed at least two instances of this in my port of my project from 4.6.1 to 4.7.0. One is a float variable with a default value of 60, which the editor is reading as 0 during runtime, and the other is a vector, value of (0,1,0), which the editor is reading as (0,0,0) at runtime. I've not had any time to investigate my project further - I'm sticking on 4.6.1 for now. However, if Epic would like my project as an example to see for themselves, I'm sure I can get it to them!

Good luck!

avatar image Hitpawz Feb 25 '15 at 11:01 PM

Is it wrong for me to feel better knowing other people are suffering the same? I think it is. But...it's nice to know I'm not crazy.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

This was caused by default values for inherited values being initialized to zero, rather than the values in their 'super' blueprint. For instance, lets say I have two blueprints: BP_Super, and BP_Child. with BP_Child being based on BP_Super. Values in BP_Child could show up as 0, even if they were set to something non-zero in BP_Super.

This error has been fixed by this github pr. It will be included in 4.7.3.

more ▼

answered Mar 03 '15 at 08:35 PM

avatar image

Dan.OConnor STAFF
495 14 7 17

avatar image Slavq Mar 03 '15 at 09:21 PM

This github link gives me 404 error... It seems like it's the same bug like in THIS topic, it's great that it has been fixed, but when we can expect 4.7.3? And why not 4.7.2?

avatar image Dan.OConnor STAFF Mar 03 '15 at 11:51 PM

4.7.2 is on its way out the door. 4.7.3 is the next available build. If the github link is giving you a 404 error make sure that you're logged in to a UE associated github account.

avatar image Hitpawz Mar 04 '15 at 01:35 AM

Awesome sleuthing guys. 4.7 is a wonderful release. Thanks for taking the time to investigate it and getting me personally back on track while you worry about everybody else too. Much appreciated.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I don't want to mark this as a full blown answer for this because there's still a problem.

Thanks to Dan, the fundamental problem has been discovered. It turns out the problem lies in the fact that the child blueprint has had all of its default values reset. The main blueprint itself is actually fine.

Resetting the child blueprint's variables does actually fix it but here's the lingering problem. None of that persists across editor sessions as every time I reload the project, that same blueprint keeps having its values wiped out. The editor won't let me delete the child either due to it being referenced all over the place in casts and basically errors out when I try to replace references on delete.

It doesn't take a long time to go through the child blueprint and hit the yellow arrows on all the values to reset them to default, but it still doesn't answer why it keeps wiping itself.

more ▼

answered Feb 28 '15 at 03:27 PM

avatar image

Hitpawz
551 22 29 45

avatar image Dan.OConnor STAFF Mar 01 '15 at 03:48 AM

Thanks for posting an update - hopefully other people find your bug report useful. I'm still working on a real fix.

avatar image Benitoe STAFF Mar 02 '15 at 09:15 AM

Hi Hitpawz,

No problems with not marking as an answer, I'm on the periphery now with this and I'm sure Dan will give me a kick if he wants my help, but it looks like Dan's clearly on point with this one.

Cheers

Ben.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Hitpawz,

I'm currently trying to reproduce this so we can get the issue resolved, but I'm finding it hard to reproduce what you are describing and was wondering if you could take a few minutes to try and help me get a repro on this issue.

So far I have tried generating very simple blueprints that make use of the default values of float variables. Think something along the lines of 5 float variables with non zero defaults displayed using a sequence of print strings on a begin play event. I have created the same blueprint in 4.5/4.6 and copied to 4.7 with no problems so far, I also created a new project in 4.6 and recreated these assets then migrated a copy of this to 4.7 - again no problems.

If you create a similar blueprint in 4.6 and copy it to 4.7, I would be curious to know if you experience the same issues and if so could you possibly attach that blueprint to this thread?. This way I can take a look at an asset we know is suffering from these problems and rule out any missing steps trying to reproduce.

Thanks!

Ben.

more ▼

answered Feb 25 '15 at 05:12 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question