x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Widget corruption when I click-drag mouse from name field

Running 4.6.1 launcher version.

While working on a UMG interface, Often I will create several widgets, and then rename many in a row. So I click and select a widget in the main window (or the hierarchy dropdown), then click, hold the mouse button and drag the mouse to select the whole widget name, in the top right corner of the details tab. If I just click once, it doesnt usually select the whole name, so I click and drag the mouse cursor to select the whole name. If I accidently drag too far, and the mouse goes into the main window, it moves the selected widget into the top right corner of the screen, and re-parents the widget to the root or canvas panel.

Sometimes I can just click undo and theres no real damage, but usually I have to delete the widget entirely to be able to continue work. A few times it has messed up the parent widget as well. Last weekend, I was renaming a custom widget, and it corrupted my entire UMG widget blueprint, and the custom widget. Trying to select the widgets to delete them would cause the editor to crash, and I had to delete the umg blueprint from windows, and restore from a backup.

Product Version: Not Selected
Tags:
more ▼

asked Feb 25 '15 at 02:44 AM in Bug Reports

avatar image

Interitus384
81 10 17 27

avatar image Rudy Q ♦♦ STAFF Feb 25 '15 at 04:58 PM

Hello Interitus384,

I was unable to reproduce this issue on my end. Just to clarify, you are having an issue renaming widgets via the Details panel?

Example:

alt text

renamehelp.png (38.5 kB)
avatar image Interitus384 Feb 26 '15 at 01:44 AM

Nope, renaming the widgets I'm fine with. Its just that when I click and drag to select the whole name in the edit box, I sometimes do it too quick, and drag the mouse too far and into the main window, which causes the problems. I'll try making a video or something to clarify.

avatar image Interitus384 Feb 26 '15 at 02:00 AM

Ok, I tested a little in a new project and tried to record a video, which didnt get any clear results. But, i think I identified the problem.

alt text

If I click and drag in the text box highlighted in green, no problems. But if I miss, and click and drag anywhere on the details pane, it moves the selected widget. So if I'm doing several objects quickly, I'm much more likely to miss. And this seems to occasionally cause some unexpected problems. It's only caused a crash and corruption of data once, but most of the it moves the widgets around and even in my little test some of them were being hidden.

umgprob1.jpg (101.2 kB)
avatar image Rudy Q ♦♦ STAFF Feb 27 '15 at 10:30 PM

Hello Interitus384,

The only way that I could reproduce clicking and dragging anything in the designer tab without actually clicking on the widget itself was to click the little button highlighted in red. Is this what is causing your issue. Could you try clicking and dragging on the button shown to see if this is what you are seeing?

alt text

clickinghelp.png (31.6 kB)
avatar image Interitus384 Feb 28 '15 at 02:23 AM

Clicking there, and any of the grey around the box was causing it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Interitus384,

I was able to reproduce this effect on our end. I have submitted a report ( UE-11206) to have this feature relocated or removed. It has been sent to the developers for further consideration. I will provide updates with any pertinent information as it becomes available.

Make it a great day

more ▼

answered Mar 02 '15 at 07:40 PM

avatar image

Rudy Q ♦♦ STAFF
47.3k 545 132 525

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question