Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7] Navmesh doesn't build at runtime (It is checked)

I am working on a procedurally generated dungeon for my university assignment. In 4.6 the navmesh worked on anything that was created during runtime but after switching to 4.7 the navmesh isn't built on anything that is created during play.

How can I fix this? I assume the issue is that it isn't being built at runtime but I could be wrong. Any help would be greatly appreciated.

Product Version: Not Selected
more ▼

asked Feb 26 '15 at 10:48 AM in C++ Programming

avatar image

90 9 10 20

avatar image MieszkoZ STAFF Feb 26 '15 at 11:23 AM

Could use some more info about your setup. Can you double-check your navigation properties in Project Settings? Also, are you using BSPs? Any additional details will be helpful.


avatar image Karner Feb 26 '15 at 11:28 AM

I'm using InstancedStaticMeshes. Everything is ticked for rebuilding, both on the abstract, recast and navmesh; I have tried registering the components in code during their construction but with no luck.

alt text

In this image you can see that the navigation is not being built inside the rooms, the boxes are collisions for the generation.

untitled.png (675.7 kB)
avatar image MieszkoZ STAFF Feb 27 '15 at 09:10 AM

Instanced static meshes are a special case. I need to repro it and I'll get back to you.

avatar image Redsett Feb 27 '15 at 07:45 AM

I'm also having this issue just spawning Blueprints with meshes in them. It has been working up until 4.7.

I'm spawning StaticMeshes but only near the origin of the map does it build "some" navmesh, but it just keeps rebuilding "some" small portion of it. Seems to be at random.

avatar image Redsett Feb 27 '15 at 07:47 AM

Is rebuilding navmesh at runtime broken completely right now?

avatar image MieszkoZ STAFF Feb 27 '15 at 09:09 AM

No, we use it all the time and it is not broken. We fixed a number of issues under the hood and its possible that your BPs worked by change. I need more details to be able to tell what's wrong. Specifically make sure all relevant parts are marked as Can Ever Affect Navigation and have pawn or vehicle collision enabled.

avatar image Redsett Feb 28 '15 at 06:24 AM

Not sure what the problem is then. Maybe I can provide enough info here to get in me in right direction.

alt text alt text

This is what I get when after starting. It keeps rebuilding a small area. alt text

This is what it looks like after 3min or so. alt text

It build navmesh fine without doing it at runtime though. alt text

avatar image Redsett Mar 02 '15 at 05:07 PM

So If I move one after the game starts, it builds the navmesh properly. But still not doing anything by itself.

alt text

avatar image Karner Mar 03 '15 at 11:16 AM

This is the exact same issue I'm having; with the same settings.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Found the problem. The navigation system heading in the project settings was overwriting the settings that I had changed in the level itself. I corrected them, saved and then added the navigation system back into the level and it now builds correctly.

more ▼

answered Mar 03 '15 at 01:48 PM

avatar image

90 9 10 20

avatar image MieszkoZ STAFF Mar 03 '15 at 01:50 PM

Yeah, that's a kind of a "feature" that's on our list of things to improve. Sorry! And keep on rocking! :D

avatar image Karner Mar 03 '15 at 01:51 PM

Thanks for the help Mieszko; appreciate it :D

avatar image Redsett Mar 03 '15 at 05:30 PM

What exactly did you end up doing? I'm unable to find "navigation system heading in the project settings." :P


avatar image Karner Mar 03 '15 at 07:10 PM

Go to Settings (Next to Marketplace) Then general > Navigation Mesh / Settings and then tick rebuild at runtime.

avatar image Redsett Mar 04 '15 at 02:51 AM

Thanks, I had "Build on Runtime" checked but not "Force Rebuild on Load". That fixed it.

Thanks for leading me to the right place.

avatar image Xarol Sep 07 '15 at 02:24 AM

I am having the same problem but force rebuild on load seems to make things worse. Also, the comment for "Force Rebuild on Load" seems backwards in 4.7. Is it correct?

Finally, is this issue fixed in UE 4.9 or does epic plan to fix it soon?

Thanks, -X

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

wow this drove me crazy for hours before finding that the project settings are overriding the in-level setting... It would be nice to at least write it in the tooltip!

more ▼

answered Mar 30 '17 at 01:13 PM

avatar image

11 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question