x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7] Fbx import from Maya deletes it

Whenever I export my model from Maya directly into the project folder, with the fbx exporter, overwriting an existing fbx, it is forced to be deleted and then reimported.

in order this happens:

alt text just after this I get this in Unreal

alt text and then I can go back in Maya and export it

alt text but it has already been deleted and now is just re imported, losing collisions and material references.

Product Version: Not Selected
Tags:
uebug01.jpg (84.8 kB)
uebug02.jpg (197.8 kB)
uebug03.jpg (73.1 kB)
more ▼

asked Feb 26 '15 at 03:31 PM in Bug Reports

avatar image

Edoartworks
24 2 4 7

avatar image Lovecraft_K ♦♦ STAFF Mar 06 '15 at 10:09 PM

Hey Edoartworks -

Thank you for your report. So far we have not been able to reproduce this error internally. Can you take a look at your setup and let us know how you are using the Mesh in the Level, what if any materials you have assigned and whether they are imported with the Mesh or created separately? Also any additional information that you think might be relevant?

Thank You and we await your response -

Eric Ketchum

avatar image Edoartworks Mar 07 '15 at 09:35 PM

Hi Eric, I tested it on another pc, with the same version of Maya (2015 sp5) and UE 4.7. I get the exact same result. I'll try to explain it better.

The problem occurs just with FBX files. OBJ work fine. I have a mesh already imported in the project (doesn't matter if in the scene, with materials assigned or anything else). Now, when I modify the mesh in Maya and overwrite the older in the project, it forces the mesh to be deleted and then re-imported as new. I guess this could be due to the way Maya handles the exporting process? It happens in 2 steps, as you can see from my screenshots.

Thanks for your time!

avatar image Lovecraft_K ♦♦ STAFF Mar 08 '15 at 02:18 PM

Hey Edoartworks -

I am trying to track down an exact copy of Maya that you listed above for testing as soon as I am able I will post my results here.

Thank you -

Eric Ketchum

avatar image Edoartworks Mar 08 '15 at 03:24 PM

Hi Eric -

Just to be sure, I tested it on Maya 2010 and the result is the same. At this point i'm quite sure it's due to the fbx exporter working in two different phases and for some reason Unreal thinks the file is being deleted instead of overwritten.

In brief the steps are:

  • In Maya I go to file - export selection (or export all) as FBX;

  • Explorer popup appears. I go to the project folder and save the fbx with the same name; [screenshot 01]

  • It asks to overwrite the file. I select Yes;

  • in Unreal I get the "pending deleted asset" window, and I must choose to delete the mesh (if I cancel the delete, it cancels the whole overwrite); [screenshot 02]

  • Then I come back to Maya where I have the FBX exporter window [screenshot 03] and export it;

  • in Unreal the file gets imported as a totally new mesh, as it has been deleted before.

Thanks for your hard work guys!

avatar image Lovecraft_K ♦♦ STAFF Mar 08 '15 at 04:50 PM

Hey -

When you are exporting from 2010 which FBX Exporter version Number are you using? Are you still using the FBX 2015 Exporter? Can you test both 2010 and 2015 but use the 2014 exporter version?

Let me know and Thank you for the additional Information -

Eric Ketchum

avatar image Edoartworks Mar 08 '15 at 08:50 PM

No, the exporter version is different, v.2010 and v.2015. Modifying the version doesn't effect the result.

avatar image Lovecraft_K ♦♦ STAFF Mar 09 '15 at 04:06 PM

Hello -

We are still not able to reproduce the Deleteing Asset internally, but we are trying. A few more questions, Are you running a Launcher version of 4.7 or a compiled version from GitHub? Also have you done anything to the mesh in UE4 before exporting the FBX from Maya, added a socket, adjusted the Build Settings and rebuilt?

Thank You

Eric Ketchum

avatar image Edoartworks Mar 09 '15 at 07:01 PM

Hi - it's the 4.7 launcher version. I do nothing to the mesh before exporting. Also I tried with two different pcs, with different projects, also a simple untouched primitive from maya to a blank project. Always the same outcome. Tomorrow I could try with the github version and with another modeling software. I'll report here. Thanks!

avatar image Lovecraft_K ♦♦ STAFF Mar 09 '15 at 10:45 PM

Hey Edoartsworks -

If possible can you upload your FBX and the Maya Scene file here for us to test? For the Maya Scene File, please make it readable by Maya 2014.

Thank You -

Eric Ketchum

avatar image Edoartworks Mar 10 '15 at 09:27 AM

Hi Eric -

Okay, here are the scene and fbx file, but as I said, it does not seem to depend on the object, but rather on the way Maya handles the exporting process. I just tested importing the same FBX in 3DS Max and Modo, then exporting to unreal, and both work well, re-importing the changes without deleting the mesh.

FBX file - Maya scene .ma

avatar image Lovecraft_K ♦♦ STAFF Mar 10 '15 at 03:53 PM

Hey Edoartsworks -

Thank you once again for the additional information and assets. I was able to get a "half" reproduction. I never witnessed the delete assets window but was getting consistent results of not updating the asset on reimporting, so I have included mys reproduction steps and your steps and have entered a bug report as UE-11559. As soon as I hear more, I will let you know.

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Eric- I just found the problem and the workaround! I just noticed that long time ago I've changed the maya settings so that it uses the windows dialog when exporting, opening files and all the dialogs in general, instead of the maya dialogs. THIS is why I was getting that error. Using the default maya settings everything works fine. Thank you very much for your support, Edo

more ▼

answered Apr 16 '15 at 04:09 PM

avatar image

Edoartworks
24 2 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question