x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.7 Transient Error and Project Frustration

We've been working on a project since 4.3 (c++/source & blueprints). Over the course of time we've run into the Transient error seen here:

http://1drv.ms/1Bhskld

After doing a lot of research it seems to be it is because we have a lot of circular dependencies issues going on i.e.:
BP relies on BP Function Library which relies on another BP which relies on same BP function library. Honestly, it is a bit frustrating.

In any case we just upgraded to the 4.7 release branch (GitHub) and I'm on a mission to try and clean this up but cannot figure out how to break this chain. I've documented the steps for ONE case that I would like to address:

Please get the latest source/content here:

EDIT: http://1drv.ms/1aq9CxB

After you are able to compile and launch the project all you have to do is the following:

Open the UI Blueprint Library "Content/UI/_ui_library" Click Save. You will receive the error.

I figured it had to do w/the fact that it references the CharmMode blueprint. If that was the case I removed the only place it references it which is in the GeneratePieceDisplay function. After removing the node I still cannot save it. I have no idea how I can start to address the issue.

Please help us get back on the right track.

Thanks, -jeff & team

Product Version: Not Selected
Tags:
more ▼

asked Feb 26 '15 at 05:32 PM in Bug Reports

avatar image

jeffvoigt
423 19 37 63

avatar image Dan.OConnor STAFF Feb 26 '15 at 06:51 PM

Thanks for the details! Is it possible to include the .uproject in your second (4.7) zip? Or is there some reason that you can't? Just want to make sure I'm reproing this correctly before I cobble together a project.

avatar image jeffvoigt Feb 26 '15 at 06:53 PM

I'll get on that and update my original post w/a new link. Give me 2 minutes =)

avatar image jeffvoigt Feb 26 '15 at 07:01 PM

Updated the link above. Our dev team is on Six Forks so you should stop over one day and I can show you a few more transient issues =). The one I documented is the quickest one to find.

avatar image zoid Feb 26 '15 at 07:33 PM

I'm having the same issue with a BPL in our project. It can't be saved at all anymore in 4.7. Opening the BPL and clicking save gives the error.

avatar image jeffvoigt Mar 04 '15 at 08:46 PM

I would just like to know if there are any updates to this issue. Thank you very much!

avatar image Ben Halliday STAFF Mar 04 '15 at 08:58 PM

Hi jeff,

Sorry, no update to report just yet, but we've gotten the project to Dan to look over and we'll post here as soon as we have any new information for you. Thanks for your patience!

avatar image jeffvoigt Mar 05 '15 at 09:12 PM

I want to delete this from the public so can you please make sure it is downloaded on your end? I hope you all are making progress. I run into it in multiple situations which forces me to make additional bp libraries just so I can proceed. It has taken a lot of time away from progress. Perhaps it is because all of the other pieces to the engine are just so darn good! Thanks, -jv

avatar image Ben Halliday STAFF Mar 05 '15 at 09:15 PM

You can take it down, I have a copy here that Dan has access to. Thanks for your patience!

avatar image jeffvoigt Mar 09 '15 at 03:49 PM

Just wanted to see if there was any progress. We have started to create new bp libraries with methods to get around this but they are also getting trapped in this error to where we can't edit them anymore either. At this point we may just have to start duplicating a lot of methods across multiple blueprints.

avatar image Ben Halliday STAFF Mar 09 '15 at 08:30 PM

Hi jeff,

I've contacted Dan O'Connor to ask for an update. I'll let you know when I hear back. Thanks for your patience!

avatar image Dan.OConnor STAFF Mar 11 '15 at 09:23 PM

And I'm back! Sorry the delay, lots of things going on. I just fired your project up in in mainline and was not able to reproduce the issue - I'm trying it in 4.7.3 now.

avatar image jeffvoigt Mar 11 '15 at 09:29 PM

But you were able to reproduce it in 4.7.2 correct!??

avatar image jeffvoigt Mar 11 '15 at 09:30 PM

If you can replicate it in 4.7.2 and it is fixed in 4.7.3 could you at least tell me the specific GitHub pushes I could grab to fix it? I run off source. Or perhaps you could tell me if 4.7.3 will be released to the main 4.7 in the near future. Thanks!

avatar image Dan.OConnor STAFF Mar 11 '15 at 09:45 PM

Updated with answer - the main 4.7 code has the commits in question.

avatar image spyro Jun 11 '15 at 10:16 AM

Still happening in 4.8:

alt text

It's even worse now, I am often not able to save my work, have to restart the editor and start all over.

avatar image Ben Halliday STAFF Jun 11 '15 at 01:12 PM

Heya spyro,

There have been a lot of fixes that have gone in for results of circular dependency issues like this one, but they don't resolve all instances of it. If this specific fix didn't address yours, please create a new post and, if at all possible, include a copy of your project that consistently reproduces the issue so we can find its cause here. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Good news: This appears to have been fixed by the following github commits:

These will be included in the 4.7.3 release, but if you're making your own build you can just pull from the latest version of 4.7. We're eager to hear about any further issues you have in the 4.7 branch, your reports to this point have been incredibly helpful.

Here is the test I ran:

Compiled your sln, ran the Debug Editor config. Loaded into the 'Persistent' map and opened _ui_library asset, saved it. In vanilla 4.7 I got a GLEO, but in 4.7.3 I was able to save the asset without issues.

Edit: links to github commits, fixed commit#

more ▼

answered Mar 11 '15 at 09:42 PM

avatar image

Dan.OConnor STAFF
495 14 7 17

avatar image jeffvoigt Mar 11 '15 at 10:03 PM

Awesome. I just got the changes and am recompiling. I'll let you know what happens. I'm also going to run my other transient error tests to see if they are fixed! I would love to come visit you all and show you the game we are working on. We are right up the road on six forks =)

avatar image Dan.OConnor STAFF Mar 11 '15 at 10:08 PM

Heheh, myself and most of the blueprint team is in Seattle, but I'll keep an eye out for meetups in the Raleigh area.

avatar image jeffvoigt Mar 11 '15 at 10:08 PM

Darn. I have 4.7.2 with those cherry picked items above (3 file changes). Still getting the error. Apparently there are more changes I would need.. Not sure the safest route at this point. Wait until 4.7.3 or figure out a few more related changes?

I rebuilt the source, etc and went through the exact steps you did.

avatar image jeffvoigt Mar 11 '15 at 10:13 PM

Wait, you updated one of the commit codes. Getting it now and trying again...

avatar image Dan.OConnor STAFF Mar 11 '15 at 10:17 PM

Agh, super sorry about that. I was off by one line when I pasted in one of the changes.

avatar image jeffvoigt Mar 11 '15 at 10:20 PM

Hmm. After cherry-picking those hash #'s above and rebuilding I'm still getting the error. This is what Git is telling me. Are these the right commits?
alt text

trans.jpg (27.8 kB)
avatar image jeffvoigt Mar 11 '15 at 10:23 PM

Why does it look like the #'s don't match up when it shows me those changes on GitHub I wonder... I did cherry-pick c9aa7 .. and cherry-pick cb17e.... and on GitHub I see different #'s..

avatar image jeffvoigt Mar 11 '15 at 10:25 PM

Nevermind. Still getting used to Git-hub.. those are my integrated commits. In any case, I do have the right commits you mentioned and still get the error. So there must be something else depending on the fix.

avatar image Dan.OConnor STAFF Mar 12 '15 at 12:17 AM

Unless you have local engine changes can you just grab the latest branch of 4.7? I have not tried running with those changes pulled in selectively - only before those changes and latest.

avatar image jeffvoigt Mar 12 '15 at 01:21 AM

OK. I'm assuming your "latest" is something similar to the "promoted" branch but not quite? I assume your "latest" is something internal to Epic.

avatar image Dan.OConnor STAFF Mar 12 '15 at 09:21 PM

By latest I meant the latest version of 4.7. Just cloning the branch, rather than pulling in individual changes. The command to clone a single branch is:

git clone --branch --single-branch []

so to clone UE4 4.7 into the current directory just do:

git clone https://github.com/EpicGames/UnrealEngine.git --branch 4.7 --single-branch ./

avatar image jeffvoigt Mar 12 '15 at 11:13 PM

OK. I was under the impression that those branches hardly every compile and we should stay out of them until they get pushed into the release branch.

avatar image Dan.OConnor STAFF Mar 12 '15 at 11:37 PM

It's good to be wary of them! For sure... I need to figure out how to identify green (compiling) labels in git. I am not as experienced with git as I am with P4.

avatar image jeffvoigt Mar 12 '15 at 11:58 PM

Well you are right. The 4.7.3 (4.7) branch at the moment fixes that issue. If I run into another one I will be sure to post the steps. Thanks you sir!

avatar image Dan.OConnor STAFF Mar 13 '15 at 12:42 AM

Thank you for confirming the fix. Please do start new threads with new issues. This kind of testing at the bleeding edge really helps 4.7 stabilize.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question