x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lighting build failing "Array Index out of Bounds"

I upgraded to Unreal 4.7, and while I was doing a lighting build, I ran into some lighting build errors saying lightmass crashed array index out of bounds. Its only happening on adding certain static meshes and not all. I have looked the properties of meshes that work and meshes that don't, and there is no difference. Can anyone help in figuring out what is wrong with these meshes? This is really urgent!alt text

Product Version: Not Selected
Tags:
lighting error.jpg (719.7 kB)
more ▼

asked Feb 26 '15 at 07:10 PM in Rendering

avatar image

SiddG
26 3 6 7

avatar image yusufu Feb 26 '15 at 07:11 PM

Ya all a few of my assests have done this too. really hard goign threw each one and find what ones killing my lighting builds.

avatar image CoryJay829 Feb 26 '15 at 07:15 PM

could also use some help with this issue. thanks!

avatar image gameme Feb 26 '15 at 07:16 PM

Yep, I have had this problem recently and dont know how to fix it! Please help!

avatar image abhishek17 Feb 26 '15 at 07:17 PM

GDC is in 3 days....HELP urgently needed

avatar image rleiker13 Feb 26 '15 at 07:19 PM

Help! Please!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi SiddG,

Did you ever get this sorted?

Often with Lightmass there can be several different reasons for the errors that come up. At the moment I'm in the process of getting a general troubleshooting and tips guide up for lightmass on our Wiki here: wiki.unrealengine.com/LightingTroubleshootingGuide

It's still at least a week out before it'll be up though.

Some of the common things that can cause Lightmass to crash are:

  • Lightmap resolution size too high for lots of objects

  • Hardware limitations, specifically not enough RAM, as Lightmass is a heavy process.

  • Clearing derived data cache can help as well: X: / Users / [ Computer name ] / AppData / Local / UnrealEngine/ - Delete everything in this folder.

  • Open Swarm Agent > Menu > Cache > Click Clean and Click Validate.

  • Having multiple Swarm Agents open (check taskbar) will cause issues or failure to build

If this is a specific mesh causing lightmass to crash when in only included in the scene I'd be interested in having a look at the asset if possible. I've not run across that specific issue.

Let me know.

Tim

more ▼

answered Mar 06 '15 at 08:32 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image SiddG Mar 08 '15 at 11:04 PM

It was being caused by certain specific assets. Re-exporting them from Maya and then re-importing them into Unreal fixed them. I believe we over-wrote all the asset files, but I'll see if I can find an older, broken version to send you.

avatar image Tim Hobson ♦♦ STAFF Mar 09 '15 at 02:15 PM

If you get an asset that does this I'd be glad to test and get this reported. It seems very odd for a specific mesh to crash lightmass like that. Usually it's some other contributing factors rather than a single asset, but if it's reproducible and happens when in the scene but not when removed that'd be intriguing.

Thanks and let me know if you get an asset that does this! :)

avatar image SiddG Mar 10 '15 at 08:52 PM

I have a copy of one of the assets that caused this. The light build fails only if that asset is in scene, and succeeds if I remove it. I'm unable to upload it here because it says "file type invalid"

avatar image Tim Hobson ♦♦ STAFF Mar 10 '15 at 10:11 PM

Thanks for getting back to me SiddG!

You can place it in a zip file and upload here or you can send it privately in a zip to me on the forums if you'd like. Either way will work so long as the attachment is under 5.2 mb. If it's over that you can post a link to dropbox or google drive to share.

Thanks!

avatar image SiddG Mar 10 '15 at 10:12 PM

Here you golink text

broken asset.zip (57.3 kB)
avatar image Tim Hobson ♦♦ STAFF Mar 10 '15 at 10:33 PM

hmm...I've just tried this and am not seeing lighting not build on my end.

Everything appears to check out:

alt text

Can you copy the log that lightmass prints in Swarm Agent to a txt file and post here? That may have something useful.

avatar image nobodysproduction Mar 24 '16 at 08:46 PM

Hey there,

I'd the same problem. The problem causer was a static mesh. It was a 3d model of the asteroid Eros Gaskel. It was originally a Stl file. I've imported it to Blender and exported it as an fbx. After that I've imported it as a static mesh into UE4. I had to save the level under a different name and did delete piece after piece and build over and over again in order to evaluate what mesh caused the problem. I'm kind of a noob, so I don't have any idea what caused the fbx to crash the lightning. I had no special options defined in the detail panel or something like that. It was just a very comon static mesh, like I've already hundreds of them hanging around in all my levels. All I can say, it was the first time I was using a Stl file.

Hope that helps in some way...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question