x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Faces pointing X- in my mesh look strange after building lightmaps

The model is a house I made in Blender and it isn't yet properly optimized and triangulated, but all other faces are fine. Like I said in the title, all faces pointing X- look strange, weird, like a different colour in my mesh. I have double checked materials and that doesn't seem to be the problem.

alt text

That's how it looks, the material is the same as in the other walls. I have made a lightmap UV but have not finished making the material UV. I also tried removing the SkyLight, ended up with these walls being pitch black.

Product Version: Not Selected
Tags:
more ▼

asked Feb 27 '15 at 03:45 AM in Rendering

avatar image

ScicoPax
6 2 2

avatar image AndrewHurley Mar 06 '15 at 08:54 PM

Hey ScicoPax,

Try going into your 'World Settings' and changing the 'Environment Color' within the 'Lightmass' section.

If this does not work, if you are comfortable with it, I can test your model on my end to see If we can find a solution that way?

Thank you,

Andrew Hurley

avatar image ScicoPax Mar 06 '15 at 10:19 PM

I already tried changing Environment Color setting but I am having the same problem. Even if I rotate the model, the faces stay the same. But this does not happen in other models I've imported. I'm attaching a zip with the blend file and the fbx file.

link text

house3.zip (214.9 kB)
avatar image AndrewHurley Mar 07 '15 at 12:45 AM

Hey ScicoPax,

After some investigation and pulling from various resources, I was able to determine what I believe is the source of your problem. The face orientation for half of your mesh is flipped while the other half is correct. In order to visualize what I mean have a look at the image below.

Faces Orientation

alt text

I also imported your mesh into the engine to see if there was a problem occurring there as well. I was able to get some clean lighting on your model by changing some of the 'Build Settings'.

Build Settings

alt text

These are the settings I discovered work well for you model. If you are still having trouble or have additional questions let us know.

Cheers,

Andrew Hurley

avatar image AndrewHurley Mar 10 '15 at 06:29 PM

Hey ScicoPax,

I just wanted to check-in to see if you were able to get your mesh to build with Lightmass correctly?

Thanks,

Andrew Hurley

avatar image ScicoPax Mar 12 '15 at 05:12 PM

Hello, sorry for taking too long. Here you can see that the normals are not flipped in Blender. I don't know if I´m understanding correctly but the normals seem correct in Unreal as well, as I should't be able to see the faces if these aren't pointing in the correct direction. Also, the green faces in the screenshot you showed me are showing just fine. I used Recompute Normals and Recompute Tangents, as well as Remove Degenerates.

House_3.fbx normals seen in Blender House_3.fbx normals seen in UE4.7.2 House_3.fbx seen with baked lighting in the viewport

I'm attaching the model source and fbx again in case I somehow attached incorrect ones last time. Download files here.

Thanks for your help and for being patient with me.

avatar image Box of Apps Aug 07 '15 at 09:23 AM

Rotating the object by 0.01 on Y axis solved the problem for me. Totally random, I have no idea why, but couldn't find another way to fix it.

avatar image NODE Visual May 05 '16 at 01:21 PM

Hey,

I ran into the same problem but it seems that I've managed to solve it.

Although we used 3ds Max instead of Blender, but the problem is basically derived from wrong unwrapping. You have to unwrap the object(s) in question manually (we used an Unwrap UVW modifier) instead of Automatic Flatten UVs and reimport it into Editor.

I don't know if there's any function like this in Blender but maybe there is. Anyway, I just wanted to share this little trick with all the users who might run into the same problem.

Regards: Andras

avatar image JonLimHX Sep 03 '18 at 10:07 AM

Hey Andras,

I know this comment is really old, but i just got started on unreal and have been having this problem. However, the objects in question that I'm dealing with are rather complex, and with my understanding of manually unwrapping, this would be very inefficient.

I'm still very new to this side of 3d modelling, and I may be completely wrong. Could you please help me figure this out? You're the first one among many I've seen who uses 3ds max to import your objects and I'm sure you're really proficient in the program.

Also, if this thread is a little old, could we bring this conversation to my post? I haven't had any answers on it yet.

Regards, Jon

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey ScicoPax,

I managed to test your mesh again and found what might be the the source of the problem. Scale up your mesh before exporting it again, and then export using the same settings suggested previously. After importing your mesh into the Engine, use the image as a reference for the settings to use for your Static Mesh.

Static Mesh Build Settings

alt text

The lights in my scene are also important for getting your mesh to render correctly.

Stationary Directional Light Settings

alt text

Stationary Skylight Settings

alt text

House In Level

alt text

This is what your mesh should look like after building. Your inside faces should also look correct.

I hope this gets you on the right track, but let me know if you need some more help.

Regards,

Andrew Hurley

more ▼

answered Mar 13 '15 at 11:38 PM

avatar image ScicoPax Mar 14 '15 at 03:26 AM

Thanks for your help but the problem isn't solved yet. Faces pointing -X in my mesh are still looking different than the others. Even with your settings. I'll leave a screenshot. Also now, with your settings, it seems that only the ceiling is having indirect lighting.

alt text

avatar image AndrewHurley Mar 14 '15 at 03:37 PM

Hello ScicoPax,

From this screenshot the inside faces are indirectly lit correctly. The reason the colors are a bit different is simply because it is not receiving direct light. If you look at your original screenshot and compare it to this one, you will see the difference.

This is how the mesh looked when I had it finalized as well. Notice how your Y-facing walls in this photo are the same color as the X-facing where shadows hit it. Unfortunately, there really is not much else I can do as far as getting your model to render correctly. Unless you are seeing something I do not, but I think what you are seeing is the indirect lighting bouncing color against the white material. This color also comes from the sky itself.

Regards,

Andrew Hurley

avatar image ScicoPax Mar 14 '15 at 07:10 PM

I don't think the mesh is correctly lit. I remade the mesh from scratch and now it isn't having this problem. But please look the screenshots:

Old mesh New mesh

Both are lit under the same lighting settings that you sent me. I don't know where is the origin of the problem, and I wished that I didn't had to remake the mesh from scratch, but please note how that the -X facing faces are still having the problem in the old mesh, but not in the new one, which shape is almost identical.

avatar image AndrewHurley Mar 15 '15 at 02:03 PM

I see what you are mentioning now. Usually with a large architectural structure like a house, breaking your mesh up into different pieces helps with the lighting of the model, as less faces are taking up more of their own 0 to 1 UV space.

I am glad you got your model to look correctly.

Regards,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question