x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Major 4.7 bug? all variables not in scope? no local vectors exist?

Hi there everybody. So I was working in my blueprint for an enemy space fighter and trying to get it to track my position, face my position, and shoot me. After many hours, I still could not get the bullets to fly straight at me. Then, I started noticing some very worrying trends:

  1. No variables were watchable because none were "in scope"

I was trying to debug things like my player's location vector and my fighter's location vector, as well as many other values that should be accessible to my fighter's blueprint, but all were listed as "variable not in scope":

alt text

In case you're not sure what you're looking at, those are the location vectors of a static mesh component "fighter" which is a part of this blueprint, and of a variable of type target point that I repeatedly assign as part of my AI. For some reason, neither of these things are in scope. Fortunately, they still function as intended, but then, I did port these over from 4.6, so maybe that's a thing.

Now into the new territory, where the source of my problem is, and may be getting fuzzy. I was trying to edit some of the code for my fighter's firing logic. As I did so, I realized that none of my vectors were coming out correctly in PIE.

alt text

I have tried every single method I could think of to get a vector to launch my projectile with force at the player (Look at rotation with a get xvector, the turn to face logic by subtracting the start and ending vectors from the Math Hall example, etc.). Every single time, however, I was getting a similar result.

alt text

That really bright ball in the center is my projectile. On fire, it slowly dribbles along the nose cone in either the positive or the negative direction of the world x axis. Even when I tried using the forward vector, it would run along the x axis. Literally nothing works and it all produces this result. I do not understand the source of this problem, or whether it has something to do with the fact that nothing is in scope, but it seems to me to be a bug with pretty much all vector nodes that I have created and used while using 4.7. Is it a bug? or am I just missing something?

Product Version: Not Selected
Tags:
more ▼

asked Feb 27 '15 at 07:04 AM in Bug Reports

avatar image

Bennick
164 26 26 33

avatar image Bennick Feb 27 '15 at 06:53 PM

anybody out there? :/

avatar image Roccinio Mar 01 '15 at 03:30 PM

Same here! In 4.8 everything is out of scope. Makes debugging a nightmare!

avatar image Dr. Whoop DSc Mar 02 '15 at 01:34 AM
  • Every variable on my player is now out of scope Also ported from 4.6 in which it works fine

avatar image Ixiguis Mar 09 '15 at 11:59 PM

I just created a really simple blueprint that changes light intensity during the Tick event. It looks like only variables specific to the blueprint (i.e. variables you created) are watchable.

alt text

I hope this gets hotfixed (rather than waiting for 4.8), as this has a big impact on debugging and productivity.

untitled.png (83.4 kB)
avatar image Mortusnyte Mar 10 '15 at 01:06 AM

The not in scope thing should be reported in the bug report section of answerhubs though it seems to have been brought up already. However, it shouldn't affect the game.

"It looks like the Local Variables being out of scope is a known issue, and has already been reported in UE-2821. I have added a note with your information, and I will let you know if I see an update. Being out of scope does not stop them from working, however, and does not mean that you're looking at the wrong instance of the Blueprint." -Ben Halliday ♦♦STAFF

As far as your projectile not behaving accordingly, are you using a Projectile Component? Could you show the blueprint that governs the projectile mechanics?

avatar image MinxiesDev Mar 11 '15 at 02:00 PM
  • for a fix for this. Is it fixed in source yet? I don't mind using that if needed.

avatar image SaviorNT Mar 20 '15 at 11:05 AM

Having the same issue here with Lerp (Vector) values not being in scope.

avatar image SaviorNT Sep 27 '15 at 07:55 PM

4.9.1 and this is still occuring, which is making debugging a nightmare.

avatar image Rockseller Jan 14 '16 at 03:35 PM

4.10.2 and this is still occuring, this is in fact a nightmare!!!! Help!!! @SaviorNT Have you found any solution to this?

avatar image Adam Davis STAFF Jan 18 '16 at 04:37 PM

Hi Rockseller,

The bug reports we have in for variables out of scope have been primarily resolved as of 4.8. Do you have specific variables/instances of variables that are appearing out of scope? For instance, does this occur within custom functions or anywhere in the event graph? Do you see this in a clean, blank project with no additional content or is it limited to one project? Can you provide me with repro steps for me to be able to recreate this on my end?

avatar image Stephen Ellis ♦♦ STAFF Jan 15 '16 at 06:44 PM

Hey all, I've just seen this and moved it into the Bug Reports section for further investigation by Epic.

Cheers

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi everyone,

We have not had a response on this post in several days. I am marking this as answered for tracking purposes. If anyone is still experiencing this error, please comment with the requested information.

more ▼

answered Jan 22 '16 at 05:19 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question