x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

hot realoding break navigation paths through custom NavArea

If I hot reload a module containing custom nav areas even if I don't make any modify to these NavArea classes the nav igation system will not generate paths through them any more.

NavlinkProxy connection color changes from the custom NavArea's assigned color to black.

Changin navlinkproxy nav area to default area make the connection work again but changing back to custom doesn't fix the problem for custom nav areas.

The only solution seems to restart the editor.

Product Version: Not Selected
Tags:
more ▼

asked Feb 27 '15 at 11:23 AM in Bug Reports

avatar image

Deadlineproof
1 1 5 8

avatar image Tim C ♦♦ STAFF Mar 05 '15 at 06:55 PM

Hi Deadlineproof,

I tried to reproduce this issue in a test project using a simple custom nav area class, but was unable to see the results that you described. Would you be able to provide some more information about the issue?

  • What version of the Engine are you using, and are you using the binary version installed by the Launcher or did you build it from source code?

  • Are you making any specific changes to your custom nav area class?

  • Where are you making changes to need a hot reload?

  • Does this only happen to you in your own project, or does it also occur in a new project?

  • Was your project originally created in the version of the Engine that you are currently using, or had you upgraded it from a previous version?

Tim

avatar image Deadlineproof Mar 05 '15 at 07:05 PM

version was 4.7.0 binary, now i'm using 4.7.2 , but i'm not working on pathing and I'm not using hot reloading as I'm now mainly using blueprint at moment so I didn't check if it has been fixed.

Area class just set a bit in the flag bitfield.

Changes was made in other classes like a custom pawn and relative custom movement controller , but i don't have problem with these classes navigating the mesh but globally the path is not available any more if the area is set.

I didn't check on a newer project I can do it tomorrow and let you know.

the project was originally created on 4.7.

thanks Tim, I will provide you with further data. I hope that meanwile the problem has been solved (4.7.2 /promoted/master)

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I have the same issue described by op (source build 17.2). It makes hot reload practically unusable when a custom NavArea class is in the game module, because it messes up custom links in the navmesh of the map.

To reproduce:

  • Follow AI jump tutorial, making a map with some NavLinkProxy with the NavArea_Jump: ( https://wiki.unrealengine.com/Unreal_Engine_AI_Tutorial_-_1_-_Making_AI_Jump_as_a_Part_of_Path_Following ). Put some distinguishable DrawColor in the constructor of UNavArea_Jump: UNavArea_Jump::UNavArea_Jump(const class FPostConstructInitializeProperties& PCIP) : Super(PCIP) { FNavAreaHelper::Set(AreaFlags, ENavAreaFlag::Jump); DrawColor = FColor::Magenta; }

  • Generate the navmesh in the level, so that when showing paths you can see the custom links with the custom color

  • Do a hot reload

  • Delete the RecastNavMesh-Default actor from the map (if present)

  • Do a paths build: now custom links are black. When the AI tries to traverse the jump links, the jump area flag is 0.

more ▼

answered Dec 02 '17 at 09:57 PM

avatar image

matfer
105 7 15 23

avatar image Tim C ♦♦ STAFF Sep 10 '18 at 08:30 PM

Hi matfer,

Sorry for not getting back to you on this. Are you still having trouble with this issue? If you are, we now have a new method for reporting Engine bugs. Please visit our Report a Bug page and fill out the form there with as much information as you have available.

Tim

(comments are locked)
10|2000 characters needed characters left

Hi Deadlineproof,

We have not heard back from you for a few days. Do you still need any help with this issue? I will be marking this issue as resolved for tracking purposes, but please feel free to re-open it at any time if you need any additional help.

Tim

more ▼

answered Mar 16 '15 at 06:54 PM

avatar image

Tim C ♦♦ STAFF
18.2k 423 69 286

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question