x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editable variables in the view port not affecting BP with Skeletal mesh?

My skeleton enemy has a trigger that makes him head towards the character, but I wanted different trigger box transforms depending on when and where. Considering I have NO idea how to copy a BP with an animation BP attached because it doesn't work at all, I'd just make a second skeleton by duplicating...but that doesn't work and I'm not sure how to get around that. But the construction script was probably a better way any way. Get the Box component set it\s world transform. and set that to a variable. make it editable, tooltip, etx. So it's in the panel on the view port now. But sometimes when I edit it on one of them the trigger box just sisnt there... Actually its lie, All of the skeletons all ready on the map could have the box adjusted...any added to the map afterwards do NOT work... Is there something I may be missing? Or does someone have an idea how I should be doing this??

Product Version: Not Selected
Tags:
more ▼

asked Mar 01 '15 at 10:38 AM in Bug Reports

avatar image

AttemptD
1k 165 164 354

avatar image AttemptD Mar 01 '15 at 07:55 PM

I'm getting a lot of bugs out of these skeletal meshes when they are in a character P anyway... Can someone please tell me what I should do?? I\d like to have a couple different versions of the enemy but making a copy of a BP that has a rigged BP with it seems to not work at all. ...??

avatar image Matt.Williams Mar 02 '15 at 07:19 PM

Heyo AttemptD,

I'm not quite following what is happening with your project. It would be really helpful if you could send us your project with some specific steps on what you're trying to do. If you don't feel comfortable giving a link out publicly, you can PM me on the forums with a link.

avatar image AttemptD Mar 03 '15 at 08:24 AM

Yes I'll send a link Tomorrow first thing.I really just want to Use more than one copy of a BP. If I set two emery BP's on the map they both work and animate and all. But if I DUPLICATE the BP in the content browser so I can make a few changes THEN the animation on the new BP do not work. I understand they are nothing coming from the same animation BP but...Is there a way i can achieve this?

avatar image Matt.Williams Mar 03 '15 at 02:52 PM

When you say you duplicate the BP in the content browser, are you saying that you are duplicating an AnimationBlueprint or a standard Blueprint? We are going to try and figure this out together, but this could very well be unexpected behavior. I just need to reproduce it here before we move forward. Thank you for your patience on this.

-Matt

avatar image AttemptD Mar 04 '15 at 02:06 AM

Ok thank you. I'll have it ready tomorrow early uploaded and ready to go. I'll send it to your PT if that's ok. Thanks again.

avatar image AttemptD Mar 06 '15 at 06:54 PM

O apologize for the wait. It'll be in ur PM later today. My apologies.

avatar image AttemptD Mar 07 '15 at 09:54 PM

My apologies again. i actually had been trying to figure it out to stop from taking up anyone's time. I've solved most things but 1 problem is still there. i just CANNOT duplicate a BP that has a skeletal mesh component that is attached to an Animation BP. If I duplicate that BP it does everything its supposed to BUT there are no animations happening with him.

I don't know if you still want me to upload the project. I can. But I've almost got it figured out. I REALLY appreciate your time, I just enjoy playing with this project a lot and enjoy the challenge of solving the problems. :) If I should still upload I will, but once again it's down to one problem. Duplicating a Character BP. When I do it, the duplicated BP DOES NOT animate. Does that clarify the problem I'm having?? I'm trying to explain it as detailed as possible just in case it's a ample fix.

avatar image DG Gage Mar 07 '15 at 10:20 PM

I believe all you have to do is go into the components, go to the skeletal mesh and re set the anim BP to the one you want. Set it to nothing, compile, play, then set it the correct one, compile, play. I've had a similar bug before that was specific to a single BP

avatar image AttemptD Mar 08 '15 at 10:02 AM

unfortunately that isn't working... I attempted clearing all of it's information connected to the anim BP or the skeleton and it's still showing no animations in game play

avatar image Matt.Williams Mar 08 '15 at 05:55 PM

Hey AttemptD,

We really appreciate it when a user goes the extra mile to try and resolve an issue themselves, but this really does sound like it's a bug. I would definitely still like to get your project so that we can reproduce it locally and get a bug in. That way other users don't have to jump through hoops to find workarounds like you are having to.

Thanks,

Matt W.

avatar image AttemptD Mar 08 '15 at 06:11 PM

Yes sir. Without question. I'm uploading to my media fire now and the link will for you soon. Thank you again.

avatar image AttemptD Mar 10 '15 at 06:07 PM

Matt I'm sorry i was having trouble with the PM. Here is a link to the meidafire link with the project.

http://www.mediafire.com/download/h2m8t2kqkvceptz/Answerhub.rar

the project itself was quite large to so I created a new one simple and added the correct assets and tried it again and I get the same problem anyway. So this will do I'd say and it will be easier.

On the example map there will be two enemies, a Spider and a Skeleton, I'm far from a pro...I've never used game developing software before and I'm six months in so....bare with me...

I'm trying to duplicate either of these enemies but the animations will not work in the duplicated ones.

I'm honestly having a Few problems with it all but...it should be ok.... you'll see I'm using a gun pack from the marketplace but you'll also see the particle system firing in the wrong direction sometimes...I DO NOT know how to fix that...or if its a bug in the product but that's another issue.

ANYWAYS!! Inside of a folder names Alpha 2 Demo there should be folders, one name skeletal meshes will have the enemies inside but i'm sure you'll find all of it, that's why I place the two enemy BP types in the world. I'd like to be able to have multiple versions of both of them AND more but this is as far as I've gotten. If there's any trouble or questions ill stay available just in case. thank you so much for trying to help me!!!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey AttempD,

So when something like this happens, it's usually a good idea to use the debug filter option to see exactly what's happening in realtime to a BP in your game.

alt text

After you PIE, you can select an instance from the debug filter dropdown to see exactly how the BP Instance in the level is interacting with the AnimBP.

So after I duplicated Skeleton_Enemy_BP and placed Skeleton_Enemy_BP_2 in the level, I selected the instance of Skeleton_Enemy_BP_2 from the debug filter dropdown. I noticed that the signal from Event Blueprint Update Animation (in the AnimBP Event Graph) was not making it past your Casting node.

alt text

When you duplicate a BP, it is essentially not associated with the original version. So the AnimBP is trying to cast to Skeleton_Enemy_BP when we need it casting to Skeleton_Enemy_BP_2

We can get around this in one of two ways.

  1. Also create a duplicate of the AnimBP and have that cast to your new BP instead. Orrrrrr...

  2. Make a child of the Skeleton_Enemy_BP instead of a duplicate. You can do this by right clicking the BP in the Content Browser and choosing "Create Blueprint based on this".

alt text

It will use your Skeleton_Enemy_BP as the Parent Class of the Skeleton_Enemy_BP_Child. Casting to Skeleton_Enemy_BP(now the Parent) will also cast to it's children.

Let me know if that helps. :)

-Matt W.

more ▼

answered Mar 14 '15 at 12:59 AM

avatar image AttemptD Mar 14 '15 at 02:26 AM

You are an absolutely amazing person. I'm serious. this opened my eyes on a few things, until now I never used the debugging....this is an extensive tool and I can only imagine the future help this will be.

I made a child of the BP as you said and everything worked perfectly. Thank you so much for EVERYTHING. This was an astonishing amount of knowledge for me.

Thank you forever and ever. Epic, Matt, you are incredible. Cheers.

avatar image Matt.Williams Mar 15 '15 at 08:09 PM

Just FYI, your response kinda made my day

avatar image AttemptD Mar 15 '15 at 08:59 PM

Well deserved good sir. WELL deserved.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question