x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UAssets not showing in content browser

While working on a project, Windows crashed and shut down. On loading the Unreal project again, most of my assets (I'm assuming whichever were in memory) are not appearing in the content browser despite still being in the main Content folder.

alt text

Is there a way to force the content browser to re-load these assets? Restarting the editor hasn't worked.

Product Version: Not Selected
Tags:
more ▼

asked Mar 01 '15 at 03:00 PM in Using UE4

avatar image

DaveFace
16 1 3 6

avatar image CelestialCel Mar 04 '15 at 11:35 AM

I'm having the same issue, can't tell if it's 4.7.1 or a bug on my end, as it's the first time i used this in 4.7.1, in 4.6 it worked perfectly.

avatar image GabrielDamato Sep 26 '17 at 12:11 PM

Not to necro this post, but this still works. I would accept the answer to put this issue to bed. Really helpful, I used it just today, years later.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey, you can delete the asset registry cache which is found inside Game/Intermediate/CachedAssetRegistry.bin when the editor isn't running, which will force a re-population of the assets.

It'd be interesting if this did fix the issue though, as it always scans the folders on start-up - the cache is only used as an optimization.

more ▼

answered Mar 04 '15 at 11:54 AM

avatar image

BrɑκеPɑd STAFF
1.5k 33 22 78

avatar image tahmidk15 Mar 13 '16 at 01:21 PM

Worked for me

avatar image James Guana Jul 02 '16 at 09:37 PM

This worked for me too! I thought the tutorial assets were corrupted but Unreal Engine setup.sh got a hash check so it would detect corrupt downloads, so corruption wouldn't be a case, and when i tried to reload UE4Editor again it ndeed work!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey I was having this exact problem and I got it working. I'll just go through the steps I took to trouble shoot. So first I was trying to import a 4.7 file to a 4.6... so make sure the versions are the same. It still wasn't working so I double checked my path (I have multiple copies of the same project, probably NOT super intelligent but y'know.) So turns out I was pathing to the wrong project. Then I did what Andrew said and deleted my asset registry to force it to look at the assets again. From that point it worked, I just had to re-build the textures because for whatever reason the materials were still build and the textures were there, it just didn't recognize the connection. Hopefully you guys derped like I did and it's an easy fix for you too.

more ▼

answered Apr 30 '15 at 03:01 PM

avatar image

Dyspie
1 1 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question