x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

invalid F drive - can't uninstall/install

I've downloaded UE a while ago, but files were missing. I tried to uninstall it, but it keeps saying invalid F drive. I was looking for traces of any UE files on my computer to see if I could get rid of it manually and I couldn't find any, but it keeps showing up as a program that I could uninstall (control panel -> uninstall a program).

So I tried to install it again and it says invalid F drive. I don't know what it's referring to, I have a C drive, external E drives, but not an F drive and I have no idea how to redirect it.

Thanks.

Product Version: Not Selected
Tags:
more ▼

asked Mar 03 '15 at 05:15 AM in Installation & Setup

avatar image

celc
6 1 2 4

avatar image Steve Hardister ♦♦ STAFF Mar 04 '15 at 08:36 PM

Hi celc,

Can you post the Dxdiag for your machine? Additionally, have you followed the instructions specifically from this link: https://docs.unrealengine.com/latest/INT/GettingStarted/Installation/index.html

What operating system are you running?

Did you see this screen which specifically says it will install to your C drive?

alt text

Please respond with the requested information.

Thanks.

install.jpg (41.8 kB)
avatar image celc Mar 05 '15 at 03:42 AM

I don't see the screen that you posted. The "Invalid F:/ Drive" error automatically pops up when I run the installer. I'm running on Windows 8.1alt text

dxdiag.png (25.5 kB)
avatar image Steve Hardister ♦♦ STAFF Mar 05 '15 at 01:43 PM

Try disabling your external E drive, rebooting. Then go into the control panel and delete any UE4 associated files, if present. With the external drive still disabled, restart the download and installation process from scratch, including re-downloading the installer. (Delete the old installer if present before re-downloading the new one.) Install to your C drive, if possible. If successful, then you can reconnect your external drive.

avatar image celc Mar 06 '15 at 12:57 AM

Thanks, the utility that Pete suggested solved my problem. Thanks for your help!

avatar image Harlena Dec 05 '17 at 09:06 PM

Guys, I have found a solution for this problem. So I downloaded this application called "Revo uninstaller" and selected Epic Games on the list. It deletes all the leftovers from the registries. After I finished deleting everything it let me install the launcher :) I hope it helps!

avatar image aryamgaming Sep 10 '18 at 03:10 PM

yessss this worked!!! thanks!!! easy and it's free! portable as well! no install needed.

avatar image GPH Oct 26 '18 at 12:04 AM

Thanks! It worked pretty well! :D +1 Revo unninstaller

avatar image Wastelandpirate Dec 18 '18 at 02:43 PM

Revo uninstaller totally works, Tried everything else but revo saved me thanks non-epic employee!!

avatar image SuperfuntimesV Mar 26 '19 at 01:37 PM

Honestly Epic, I can't believe this is an issue. You've been buying up exclusives expecting us to come to a store that can't be browsed by genre, doesn't have discussions, has no shopping cart, only one long bland page of games... And if you've changed drives that the app is on it completely breaks and you have to do some genuine Windows Kung Fu to get it working again.

I'm finding people with this issue in 2015, and I'm sitting here this morning just trying to get the app to work.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

7 answers: sort voted first

Well, I had the same issue, I had UE4 installed on F drive, then I renamed the drive to D, so installing new launcher produced the same issue.

How I did solve it ?

My installation dir was F:\UE4\EpicGames, the new location was D:\UE4\EpicGames,

So I looked over the registery (regedit.exe) searched for "F:\UE4\EpicGames" and replaced it with "D:\UE4\EpicGames"

You'll find tons of "F:\UE4\EpicGames", the correct one in my case was located on HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

So I suggest you start your search from this directory,

(I have found it exactly under \Uninstall{325AC861-EDAF-440B-97DD-259906E216D3})

more ▼

answered Oct 10 '15 at 12:23 PM

avatar image

hamokshaelzaki
151 7 11 61

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Celc,

You may also want to give the following utility a try: http://support.microsoft.com/mats/Program_Install_and_Uninstall

I just reproduced the issue you are reporting and this utility was able to remove the Launcher allowing me to install it again.

more ▼

answered Mar 05 '15 at 07:24 PM

[Epic]Pete (suspended)
avatar image celc Mar 06 '15 at 12:56 AM

Thanks! This worked! I used it to fix the uninstall issue which ended up fixing the install issue.

avatar image Nathan253 Jul 19 '17 at 11:11 PM

This link to microsoft is amazing. My f: failed and I couldn't uninstalled programs still linked to it. This solves the issue for you.

avatar image SuperfuntimesV Mar 26 '19 at 01:46 PM

Thank you! The registry and Revo solutions did nothing at all.

Again, Epic... This is a pretty standard-issue app issue. It's been happening for years. I've lost drives in the past but this is a new problem to me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Wow... I'm in shock... I just spent hours trying to fix this after my hard drive committed suicide... luckily I had all my projects backed up :D but couldn't reinstall or uninstall UE4... I seen this post and tried the utility and BOOOOM!! back in action!!! Anybody else have issues like this give this utility a shot for sure it worked for me might for you too.

more ▼

answered May 29 '17 at 03:27 PM

avatar image

dzrealkiller
16 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I just had this problem with an old SSD dying that had my UE4 game and EPIC install on it. I tried editing the registry and other fixes but was failing and couldn't reinstall or uninstall EPIC GAME LAUNCHER.

**MY FIX THAT WORKED FOR ME: I installed another HDD where the old one was, it appeared as F:/ , then Windows would let me uninstall EPIC (even though it wasn't on the new drive) and reinstall it to another drive.

I hope that helps!

more ▼

answered Oct 16 '17 at 03:03 AM

avatar image

Emrico1
6 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The drive you are trying to install the launcher on CHANGE THE DRIVE LETTER TO THE ONE INVALID. Ex. Drive C in computer "INVALID DRIVE (Z:)" Change drive letter C to Z then uninstall epic games launcher. after uninstalling epic CHANGE BACK DRIVE TO ORIGINAL LETTER. this worked for me I hope my instructions are clear im not really good at English.

more ▼

answered Jun 03 '18 at 09:42 PM

avatar image

stéven
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

holyyy smokes. i created an account just to tell you revo worked! it's free! good job man!

more ▼

answered Sep 10 '18 at 03:09 PM

avatar image

aryamgaming
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thanks the guy who said RevoUninstaller, works! But if it say Invalid drive E:// Continously in the Uninstaller just go to select Special and Next and delete the things that are popping up. NP :)

more ▼

answered Dec 19 '18 at 12:35 PM

avatar image

xxxdefageci
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question