x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Mesh isn't smooth when i import from maya with Animation

When i import a mesh from maya whit 1 animation the mesh isnt smooth , I can play the animation

Product Version: Not Selected
Tags:
more ▼

asked Mar 03 '15 at 10:17 AM in Using UE4

avatar image

aikender
16 1 3 3

avatar image IanBreeg Mar 03 '15 at 12:00 PM

Make sure you're exporting Smoothing Groups from Maya and that your edges are soft (Normals->Soften Edges).

avatar image aikender Mar 03 '15 at 01:41 PM

alt text

I did that but does'nt work ,i added some pictures the first picture is my mesh the second are my meshes imported into unreal. the left one is inported whitout bones the right is whit bones and animation.the animation works but not as in a smooth mesh

avatar image IanBreeg Mar 03 '15 at 01:49 PM

Is this a real geometry or just a smooth mesh preview in Maya? If latter, make sure to convert it to polygons first: Modify->Convert->Smooth Mesh Preview to polygons.

avatar image aikender Mar 03 '15 at 01:53 PM

I did that to , but do i have to do that before i add the smooth skin

avatar image IanBreeg Mar 03 '15 at 01:57 PM

No, only after you've enabled Smooth Mesh Preview. Do they have the same wireframe and polycount in engine? The static mesh and the animated one.

avatar image aikender Mar 03 '15 at 02:06 PM

No the the animated has less

avatar image IanBreeg Mar 03 '15 at 02:07 PM

They you' re definetely not exporting something. Would you mind posting a screenshot of your .fbx exporter settings?

avatar image aikender Mar 03 '15 at 02:17 PM

alt text

avatar image IanBreeg Mar 03 '15 at 02:20 PM

Have you tried exporting just the Smoothing Groups and Skin first? Uncheck smooth mesh, Bake Animation and BlendShapes. Try it this way.

avatar image aikender Mar 03 '15 at 02:30 PM

i have the smae reslult no smooth mes

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

When you are importing skeletal mesh, it has a separate normal import method. I think, by default, importing mesh will have "import normal" as default option, but it might be "compute normal" for importing the skeletal mesh in your case. You can read the difference in the documentation:

https://docs.unrealengine.com/latest/INT/Resources/ContentExamples/ImportOptions/1_3/index.html

I did one just for example

alt text

smoothmesh.jpg (130.4 kB)
more ▼

answered Mar 03 '15 at 07:59 PM

avatar image

Wesyc
121 4 2 8

avatar image aikender Mar 04 '15 at 07:24 AM

no have the same its like smothing is not importing

avatar image aikender Mar 04 '15 at 07:28 AM

its when i put the smooth skin on it doesn'nt inport smooth

avatar image aikender Mar 04 '15 at 10:22 AM

i tried some stuff and this is wat have

imported whit: - no reder preview no soft Norm = soft mesh no bone hiërachie - render preview + soft Norm =soft mesh no bone hiërachie - render prev +soft Norm +Smootskin = no soft mesh bone hiërachie

avatar image aikender Mar 04 '15 at 11:12 AM

I also imported it in unity and have the same result .so i think it has somthing to do whit exporting

avatar image aikender Mar 04 '15 at 12:36 PM

Found it i dod not delete my hsitory in maya that was causing the problem . and inoticed that if you delete history you lose your smooth skin.the one animation workse put lost the weight on it

avatar image aikender Mar 04 '15 at 12:41 PM

one more question can i delet history whitout losing the smoothskin

avatar image Ray Arnett STAFF Mar 06 '15 at 05:46 PM

In Maya, you can delete 'Non-Deformer History' which should preserve your skin weighting.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was having the exact same problem - my assets were low poly and not smooth when I imported them in to Unreal. This thread ended a 6 hour search, so thank you! This is what I did:

Delete 'Non-Deformer History' Modify->Convert->Smooth Mesh Preview to polygons. On export choose a preset in the menu - make sure smooth in unticked - this is a bug or something On import import normals and tangents

Thank you to everyone here, I hope other people will find this thread as well.

more ▼

answered May 18 '16 at 09:27 PM

avatar image

Patrick White
6 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello, i have the same problem: First i import into Maya a skeletal mesh from Daz studio. I tried with FBX and DAE)

Insode MAYA: I smooth the mesh.

Next, i export the mesh into UE4. But ue4 always said that "no smoothing group was found"

So i created a LOD group inside MAYA. Then, i export the LOD group inside UE4 (within the LOD option).

The mesh is imported inside UE4 with the full resolution. But....But It's not possible to import the skeletal (without a crash issue) I tried gameexport, all options of export, import.. nothing worked;

I imagine that it's surely exist an issue. Is someone has already met this problem or know how to fix it? Thanks a lo in advance...

more ▼

answered Apr 21 '17 at 05:14 PM

avatar image

Citymmersion
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question