x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I have trouble with creating a project with c++ code

When I create project, the Unreal Engine gives me the error The project failed to compile with this version of the engine

Product Version: Not Selected
Tags:
more ▼

asked Mar 03 '15 at 04:16 PM in C++ Programming

avatar image

Dagter
1 1 2 3

avatar image Samantha Sutton ♦♦ STAFF Mar 03 '15 at 04:20 PM

Hello Dagter,

When you create your project, are you creating a blank template or a pre-made template? Also, are you working out of UE 4.7.1? Did you obtain UE4 from the Launcher or from GitHub?

Looking forward to speaking with you further, thanks!

avatar image Dagter Mar 03 '15 at 07:08 PM

I create my project with blank template.Yes am I working out of UE 4.7.1. I downloaded from the UE 4 launcher. And yet, no matter what the project is created, the error is the same everywhere

avatar image Samantha Sutton ♦♦ STAFF Mar 03 '15 at 08:14 PM

Hey,

I just updated my launcher, opened 4.7.1 and created a blank template with starting content as a C++ project. Visual Studio populated for me, but it wasn't needed to actually compile the project, as it did open up on its own as well.

So my questions to you: Is the project even created when it gives you that error? (Look where your Unreal Projects are saved to.) Do you have Visual Studio installed on your computer. If so, does it even open for you, when you're creating the C++ projects?

Thanks!

avatar image Dagter Mar 04 '15 at 06:14 PM

1 No 2 Yes 3 No. Even after I updated to 4.7.2 Problem engine remained. And when I installed 4.6.1 UE when opening basic code, only opens the file in Visual Studio, and the Projects not

avatar image Samantha Sutton ♦♦ STAFF Mar 04 '15 at 06:47 PM

Hey Dagter,

Thank you for responding to my questions.

Which OS are you on?

I updated to 4.7.2 today, and I just created a C++ project without any errors. Have you tried verifying your version of the engine? If not, please go to 'Library' and click on the drop-down menu beside 'Launch' and select 'Verify'. Make sure it's for 4.7.2.

Do you use Visual Studio regularly? Does the program open up without any errors? What version of Visual Studio do you have installed on your computer? Have you restarted your computer since trying to create a C++ project?

In 4.6.1, C++ projects open up Visual Studio only. You should be able to just right click on your project and select 'build'. Once it's done building, you can then close Visual Studio and open the project up within 4.6.1.

Let me know if any of the suggestions provided help with 4.7.2. If you're still experiencing complications, could you please provide me with a screenshot of the error that you receive?

Thank you!

avatar image Dagter Mar 05 '15 at 02:59 PM

I have Windows 7 Professional. I updated and checked. Similarly 4.7.2. No, do not use regularly. The program runs without any problems. Version of I Do not Know, I know that Microsoft Visual Studio 2013.

avatar image Dagter Mar 05 '15 at 03:01 PM

alt text

avatar image Samantha Sutton ♦♦ STAFF Mar 05 '15 at 06:49 PM

Dagter,

For your operating system, are you on any service pack of Windows? If not, I would suggest updating to the latest one and see if that resolves the issue for you. I've seen it help others in the past.

So with the project conversion failure, have you tried selecting 'open with Visual Studio'? If so, have you been able to right click on the project file and build it for the Engine? If you're able to get that far, you can go back to the Editor and actually open the project.

Looking forward to hearing from you, thanks!!

avatar image Dagter Mar 06 '15 at 01:01 PM

Look at my screenshot and tell me what to do P.s. Windows SDK installed.alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I found a mistake. Since I live in Russia, the username was in Russian, and so the engine would not work korektno. In general, I corrected the username into English and everything worked as it should.

more ▼

answered Mar 06 '15 at 03:20 PM

avatar image

Dagter
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question