x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I change the icon and name of my packaged game?

How do I change the icon of my packaged game? And how do I change the window title and process name of my packaged game? Thank you, Joey

Product Version: Not Selected
Tags:
more ▼

asked Mar 25 '14 at 07:39 PM in Packaging & Deployment

avatar image

JoeyR9970
33 2 6 7

avatar image TheIdesofMay Apr 03 '14 at 11:09 AM

I'd also like to know this. Anyone know how?

avatar image cdrose Apr 03 '14 at 11:46 AM

Go to "Edit" then "Project Settings" in there you can edit all the names, icons and splash screens you want under "Game>Packaging" and "Platforms". Hope this helps.

avatar image Yaw-Way May 11 '14 at 02:55 PM

That seriously does not work. Have you tried it yourself? Everything shows up with the default black Unreal icon, even examples like Sci-Fi Hallway and Shooter Game although it's supposed to have its own icon, shows up with that generic UT icon. And when you package a game (at least when I do), the icon is still the same no matter what you choose. This is something no one is talking about perhaps because either no one thinks it's a big deal, they haven't noticed it, or everyone is still taking time to learn the engine without bothering to test its game deployment function, well I have and apparently the icon customization isn't working for any game (even the ones provided by Epic). That little bit of lack in customization may cost Epic a customer or 2. I myself am seriously considering CryENGINE now simply because of this.

avatar image Xenome May 11 '14 at 03:08 PM

After setting the splash and icon, did you also click the "Set as Default" button in the top right corner of the Project Settings window?

avatar image AlejoS May 18 '14 at 06:45 PM

I´ve been handwriting de default settings in the project´s ini files O.o I´ll try the Set as default button

avatar image Yaw-Way May 11 '14 at 06:01 PM

No I did not. I thought doing that would simply make it the "Default" which isn't what I want. Is that what must be done in order to get the chosen icon to be included in the package?

avatar image Xenome May 11 '14 at 06:05 PM

Other settings, such as default start map, input mappings and so on, are at least not properly applied in a shipping build unless you set-as-default, so I presume the same thing goes for icons and splash graphics.

The key question though, is if it worked as expected when you clicked that?

avatar image Yaw-Way May 11 '14 at 06:11 PM

OK I'll try clicking it and report back with the results. Puzzled, I was under the impression that something was wrong with my files so I'm in the process currently of backing up the engine and re-compiling it from source. I'll test that theory promptly after it's done.

avatar image Xenome May 11 '14 at 07:15 PM

Did some testing, and it turns out that you can't actually click the set-as-default button on that particular page of the project settings. Hehe. But, it doesn't matter, because it works anyway. I've got a functional splash and icon in a shipping build by performing the following (assuming windows platform):

  • Save the .ICO file to use in projectname\Source\projectname\Resources\Windows

  • Set it in the project settings

  • Save the splash to projectname\Content\Splash

  • Set it in the project settings

One thing that can go wrong is if the .ICO file doesn't contain all the required icon sizes, or isn't big enough (I'm not really up to date on the whole icon business... they go up to 512x512 these days?). Anyway, with a less than perfect icon file, depending on the zoom level in the windows explorer window, you might see either your icon or the default UE icon. So, make sure the .ICO is created by the book so to speak.

avatar image Xenome May 11 '14 at 08:09 PM

After more fiddling, it seems the icon configuration should be entered into the bug database. Even a perfectly crafted icon with all sizes and color depths will turn into the default UE icon once you start increasing the scale in windows explorer. The smaller version shows the correct icon, but the larger size does not.

avatar image Yaw-Way May 11 '14 at 10:03 PM

So you confirm that it's a bug then? I hope future versions remedy this. It's essential to customization. But, you know, when I packaged Shooter Game, it only showed the default UE icon although it should already be in the right place. Funny how no one else is mentioning this problem. As I said, it's probably because no one is there yet (packaging games), I just wanted to test that feature as customization is essential to art and product.

avatar image Xenome May 11 '14 at 10:11 PM

I'm not really in a position to confirm any bugs. That's something the Epic Staff should do, I guess. But I agree that there is no obvious way to make it work, that's for sure. Sorry if I led you astray!

Hopefully there's a solution coming down the road. I'm probably 3 - 4 years away from shipping anything, so personally I'm not really in a rush here...

avatar image IIZEROXII May 02 '15 at 12:18 AM

Sounds like you need to have all the sizes of the icon not just the small one because when you change the icon size it go's back to the unreal icon picture because you haven't provided the larger sizes try a program called IconFX hopefully that will help you create your icon as for the splash screen I know they work because all I did was upload a picture and it worked one thing to try is keep them the same size as the defaults because it may not like different sizes good luck.

avatar image AlejoS May 18 '14 at 06:59 PM

What about changing the project´s name? (or project´s build name)

avatar image DazPetty Aug 20 '14 at 09:25 AM

Yeah I want to know how aswell, this is one of those typical problems with a game engine that you get right at the end of a project because the people who have actually ever finished a game and had it ready to pack off are few and far between.

avatar image wittlief ♦♦ STAFF Apr 06 '15 at 04:56 PM

Hi JoeyR9970,

Thank you for your report. There have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

Thanks very much!

avatar image Chaoss Nov 23 '15 at 07:11 AM

I believe (I have not tested this, but I have gotten the icon issue resolved in the past!) that the icon needs some very specific icon sizes. Each icon 'size' has an index associated with it (for example 16x16 = 0, 32x32 = 1 and so on) and if UE4 is anything like many other game engines it will expect a specific icon size at a set index, so if UE4 expects index 0 to = 16x16, then index 1 to = 32x32 but you've gone and made an icon with sizes 16x16, 24x24 then 32x32, Index 1 would = 24x24 and not the expected 32x32 and UE4 will switch to it's default icon.

I suspected that this would be the case when I tried to add an icon and although in explorer the correct icon showed, it still had the default icon in the title bar and on larger icon desktops. Again I do not know what the actual sizes UE4 expects are but most applications expect the following sizes and I would expect it to be no different than other engines. Those sizes are 16x16, 32x32, 48x48 and 256x256.

avatar image RVillani Jan 07 '16 at 07:17 AM

Using Resource Hack, the sizes of the Unreal icon on the shipped exe are: - 16 - 24 - 32 - 40 - 48 - 64 - 256

avatar image Steve Hardister ♦♦ STAFF Jan 18 '16 at 04:26 PM

Because this is a question of popular interest, I've consolidated all comments, suggestions, and answers into this one comprehensive answer:

  1. Follow steps listed on this doc page:Launching to Devices

  2. Make sure your icon is in the correct format: ICON.ico (You can convert png files to ico files for free online.)

  3. Under Project Settings>Platforms>(appropriate platform(s)), make sure your custom icon pixel dimensions match the default example's for all instances. (Hover over each image with mouse to display all default dimensions for the appropriate platform(s))

  4. Make sure your custom icon is set as default in project settings for the appropriate platform(s) (ie. Windows, Android, Mac, HTML5, etc.) by replacing the default icon with your own

  5. To change directory name from "WindowsNoEditor" to custom game name, follow steps listed on this wiki page: Packaged Game Paths, Obtain Directories Based on Executable Location

(*Tested to work with a custom project in UE 4.10.2 packaged for both Shipping and Development)

Thanks,

Steve H.

avatar image makai Feb 22 '16 at 05:55 PM

i feel stupid, but i still don't know, can you explain point 5 a bit more?

avatar image Steve Hardister ♦♦ STAFF Feb 26 '16 at 09:25 PM

The easy answer is just to output to the directory: WindowsNoEditor and rename the folder after the fact. Experiment with packaging some of the Blank Templates and you will see this does not interfere with the executable.

The previous #5 above shows where this directory originates so advanced users can change the name there if desired. Another user posted a way for this to be done in the following post:

https://answers.unrealengine.com/questions/54543/can-the-editor-not-add-windowsnoeditor-to-pak-file.html

avatar image Yun-Kun Aug 06 '16 at 01:06 PM

Sorry to bump this but I've followed these steps and the icon of my .exe is still displaying the editor default image depending on the current zoom of windows explorer.

My image is exactly 256*256 and of the same file format than the default unreal icon (.ico) so I don't know what to do more.

My project contains both Blueprint and C++.

The source image is stored at the same folder location than the default unreal icon.

avatar image Steve Hardister ♦♦ STAFF Aug 08 '16 at 03:47 PM

Do you have your icon selected for the correct platform that you are packaging for in your project settings?

Icon

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I followed all the required steps to set icon and process name however it just wouldnt work. Turns out its an Engine code issue.

See my question here - https://answers.unrealengine.com/questions/501161/not-able-to-correctly-set-icon-and-name-for-packag.html

Note the comment on the accepted answer by project.gheist. If you follow his links (his PRs), you should be able to successfully set icon and process name correctly, as I was able to.

I shall link project.gheist pull requests here as well -

  1. For icon issues - https://github.com/EpicGames/UnrealEngine/pull/2840

  2. For process name issues - https://github.com/EpicGames/UnrealEngine/pull/2799

An issue was created for only the icon issue and can be tracked here - https://issues.unrealengine.com/issue/UE-36945

more ▼

answered Oct 17 '16 at 09:19 AM

avatar image

mutp
43 6 11 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey all. So as of UE4 version 4.13 the following works 100% for windows projects. I have not tested on other platforms, but I'm confident it will work for those as well. The problem isn't with Unreal, it's the fact that icon files need to have multiple sizes for them to work properly in Windows.

Step 1 - Create your icon file as a 256x256 PNG image and upload it to http://icoconvert.com/

Step 2 - After uploading your icon image, scroll down to Step 4 and select the following sizes: 16x16, 32x32, 64x64, 128x128, 256x256. Then hit the Step 5 Convert and Download link to download your new icon file. alt text

Step 3 - Under the Project Settings in the UE4 editor, scroll down to your target platform (windows for example) to specify the new icon. You can also change the splash screen images here. These can be PNG files at 600x200 pixels in size. alt text

Step 4 - Package your project and your new icon file will replace the Unreal U icon.

more ▼

answered Jun 01 '17 at 12:01 AM

avatar image

TorQueMoD
1.2k 86 116 146

avatar image Genova Nov 19 '17 at 12:50 AM

Nice, Thanks !

avatar image TorQueMoD Jul 09 '18 at 11:26 AM

You're welcome. It took me a while to figure out what was wrong too :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

looks like source control was blocking me :

SourceControl: Error: The following paths are ignored by one of your .gitignore files: SourceControl: Error: Build/Mac/Application.icns SourceControl: Error: Use -f if you really want to add them.

Simply modifying the folder so that it was included allowed the icon to be set as would be expected through the ui

more ▼

answered Nov 27 '17 at 05:24 AM

avatar image

beau.casey
1 3 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question