x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Gear VR - 4.7] Straight to Oculus Store on Launch

Before I start, congrats on the 4.7 Release :), I can tell this update had a lot of blood, sweat, and tears put into it.

Moving on, the problem I'm having is my project (LaserTraining) on the note 4 will give the "insert gear vr" message when I try to run it, but once I plug it into the headset (and put it on my head) the screen goes to the oculus home app after about 5-10 seconds of black screen. I know the project and world settings are correct, because I was able to get the AdvancedVehicle template working.

Is the Oculus Store redirect an indication of a crash? The fact that both projects use the same settings leads me to believe there's something content-wise that is causing the issue.

Sidenotes about the LaserTraining project:

  • Has C++ code

  • Works on Oculus Dk2

  • In-editor Stat unit shows (in ms): Game-7.26, Draw-1.78, and GPU-8.33 so performance should be scalable

  • Uses 3D umg and 2D umg

I know that this description is vague and probably not enough information for anyone to help, so let me know if there's any other info I need to provide.

Thanks,

Fenra

Product Version: Not Selected
Tags:
more ▼

asked Mar 03 '15 at 11:29 PM in VR

avatar image

Fenra
276 9 15 185

avatar image wittlief ♦♦ STAFF Mar 04 '15 at 05:16 PM

Hi Fenra,

Thanks for the goodwill! It was a lot of hard work, but very worth it. In reference to your problem, have you successfully used the Note to GearVR in the past and it is not working now, or has it never worked? If it is the latter, there is a plugin that must be installed and some manual setup. Apologies that we do not yet have official documentation for this, but here is a forums thread with many questions and answers related to the GearVR specifically. Please have a look and see if any of these help with your issue. If they do not, report back here and we'll try harder to suss out your issue.

Thanks very much!

avatar image Fenra Mar 04 '15 at 08:38 PM

Ah yes that forum thread has been what I've been referencing, it has been very helpful so far for getting a template to work. I have successfully configured the First Person Template to work on my Gear VR yesterday (and today) using the non-github 4.7 engine version (I've never downloaded the preview versions or github versions). After implementing some tricks to optimize the FP template, the project runs smoothly on the Gear too. I can make other templates work as well using the same configuration, but not my project unfortunately.

My project is not big or complicated(no extra plugins needed aside from the built-in ones), basically the player stands still in a room and removes rust from a metal panel, and I've optimized it with mobile devices in mind. It's only a little more graphically intensive than the template versions, and it can be scaled to increase frame rate due to the GPU being the bottleneck. The only "crazy" thing that I do in my project is the c++ class I made to create and edit a dynamic texture at run-time. To get it working, I had to edit the project's build.cs file and include "RHI" and "RenderCore" to the public dependency module line (see picture below).

alt text

avatar image wittlief ♦♦ STAFF Mar 09 '15 at 06:39 PM

Ah, ok so you were successful in getting the template to run on the GearVR and it is your specific project that is seeing the problem? If that is the case, I am going to add the C++ tag to this as it seems to be more related to that than to packaging/deployment for Android, do you agree? If so we will see if someone with more C++ experience has any insights.

avatar image Fenra Mar 09 '15 at 08:08 PM

Exactly, the templates work, but not my specific project. I'm not sure if the c++ portion is causing the problem, it could be the UMG's or something else that I'm doing that may be messing it up. I'm trying to remove parts of my project to narrow down the problem areas, but cloning a test subject project from my current project currently causes packaging errors (target rules or something) which I'm trying to debug currently.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

alt text

Figured out a solution to the problem. Had to change "Development" to "Shipping" and "On the fly" to "By the book."

Although now the coordinate system seems to be messed up a bit for certain things, like my 3D UMG is upside down, but the hitboxes aren't. And my BP logic system ("Get Forward Vector" "Get Up Vector") to figure out which way an actor is facing outputs a different (and wrong) result than the pc version. Oh well, that's for another thread.

Thanks, Fenra

launchconfig.png (313.6 kB)
more ▼

answered Mar 10 '15 at 04:11 PM

avatar image

Fenra
276 9 15 185

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Alright, so I've spent sometime deleting almost everything in my project that could be causing problems (widgets, etc.) and still no luck. However, I realize now that this is not a gear vr problem (yet), because the project has errors simply being launched to my note 4 android device without gear vr being involved.

I launch to my device from the editor, and these are the errors I'm getting on my note 4. http://imgur.com/a/9aqWB

Note: These images are from another question, but seem to be exactly what I'm getting. The answer to the question posted below wasn't very helpful for me though. And I still can't figure out the problem yet.

Anyway, my question should probably be deleted, moved, etc. since the problem is no longer VR related.

https://answers.unrealengine.com/questions/174942/android-error-cd0-constructor-umgpaper2d-files.html

more ▼

answered Mar 09 '15 at 10:14 PM

avatar image

Fenra
276 9 15 185

avatar image wittlief ♦♦ STAFF Mar 09 '15 at 10:44 PM

Hi Fenra,

Since we're narrowing down the root of your problem, I will go ahead and close this VR thread out as resolved.

I did a little searching around, and here is a thread from last year wherein the user was having a C++ problem that was returning some similar errors to what you are seeing. If this doesn't help, please open a new thread tagged for C++ with your output logs, and we'll see if someone in that area of expertise can help. Thanks very much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question