x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7] - Blueprintable Component causes "Graph is linked to private object(s) in an external package" while saving a map

  1. Create Blueprintable Component file, i.e. Scene Component.

  2. Put this as component to Actor Blueprint.

  3. Use this actor in map.

  4. Compile BP Component, Compile Actor, save map. It's fine so far.

  5. Edit graph of BP Component, compile it. Compile Actor, save map. Now I'm often getting error - map behaves like change BP Component is object "in external package".

I found only one annoying workaround so far. Remove BP Component from actor, save actor and map. Insert this BP Component again, save actor and map. No errors.

Could be related to https://answers.unrealengine.com/questions/179442/470-461-inherited-macro-causes-graph-is-linked-to.html It's similar nonsense ;)

I could provide more detailed repro and/or some files, if this would difficult to replicate. But it looks like common issue in fresh system of Blueprintable Components.

Product Version: UE 4.7
Tags:
more ▼

asked Mar 04 '15 at 01:44 PM in Blueprint Scripting

avatar image

Doctor Ergot
265 15 28 38

avatar image DerCrow Mar 05 '15 at 07:08 AM

I am getting this exact same issue in 4.7.1.

I have not yet updated to 4.7.2 but maybe it is corrected in that release.

avatar image VSZ Mar 11 '15 at 03:52 PM

Same issue here too. I hope Epic releases a hotfix for this as it's a huge cost on productivity for anyone making extensive use of the blueprint components.

Thanks a lot to miligram9 for posting both the repro and workaround, I just confirmed your keen observation and it works as suggested.

@Purecyn - AFAIK this particular issue is not related to any circular dependency, miligram9's repro is accurate, blueprintable components indeed seem to be the root cause.

avatar image DaveTheFreak Jan 18 '16 at 08:21 PM

I am frequently getting this error, when working with the savegame file in the construction script of the blueprint (does save game exist, load game from slot etc).

Putting it in the EventGrap and triggering it via BeginPlay helped.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I've had this issue several times. It is usually followed by doing something it didn't like. For instance, undoing something that was deleted. I am fairly certain at that point it is a corrupted BP and will need to be remade. I have seen this in 4.6 and 4.7, though 4.7 seems to have more crash bugs at the moment then Window XP.

more ▼

answered Mar 05 '15 at 04:26 PM

avatar image

Purecyn
466 9 7 14

avatar image Purecyn Mar 05 '15 at 07:00 PM

An update: I found that a not-so-obvious circular dependency could cause this error. In one example: a function in a function library calling another function in the same function library.

This helped: https://answers.unrealengine.com/questions/80010/cant-save-blueprint-referenced-in-enginetransient.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have had this issue come up and i think i know why this error happens. First i will ask a question did any of you copy the component or duplicate a component?

i had this error about a week ago so i deleted a component until the save error went away then recreated them , and no problem.

i just had the same error about 5 minutes ago , right after i duplicated a static mesh component. so im pretty sure if add a new component instead of trying to duplicate one you should be fine. .....

yup thats it i was just able to recreate the error again.

more ▼

answered Apr 28 '15 at 02:22 AM

avatar image

Dyme220
6 1 1

avatar image DoctorPC Jun 09 '15 at 06:06 PM

oh christ... I guess it is time to resize & locate 18 spheres.... >.<

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I just got this same error I copied components from one blueprint put them in another and re-named them however it apparently still tracks some data from copied component.

My Solution: Delete all copied components and re-create from scratch

more ▼

answered Apr 30 '15 at 01:22 AM

avatar image

NanoVoxel
116 2 18 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question