x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.1] In-editor mouse offset when ejected

Since 4.7 or 4.7.1, I don't really know, I have a recurrent bug when playing the game in the editor and clicking "eject", to inspect actors at runtime.

The mouse cursor doesn't fire events at its real position. It's like UE receives the click on the lower right side of the cursor, by an offset of 100,100 for example. When the offset position would be in the widgets, and not in the game viewport, the cursors changes from the cross to the default mosue cursor.

Product Version: Not Selected
Tags:
more ▼

asked Mar 04 '15 at 03:23 PM in Bug Reports

avatar image

Sahnvour
46 2 6 8

avatar image Rudy Q ♦♦ STAFF Mar 04 '15 at 04:08 PM

Hello Sahnvour,

I have a few question for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this in a clean project?

  2. If so, can you provide a detailed list of steps to reproduce this issue on our end?

  3. Have you adjusted the settings of the Widget Reflector?

Here is what it looks like. Try setting this back to 1 if it is not already.

alt text

avatar image Sahnvour Mar 05 '15 at 08:21 AM

I'll try to reproduce the problem when I find some time, what I can tell you at the moment is that I'm not the only one on my team to have noticed that. The application scale is at 1.0 as shown on your screen.

Here is a screen to illustrate the offset, I can move the cat yet the mouse isn't on the arrow. alt text

offset.png (120.4 kB)
avatar image Rudy Q ♦♦ STAFF Mar 07 '15 at 01:49 PM

Hello Sahnvour,

I am still unable to reproduce this on our end. Please let me know when you get a chance, if this can be reproduced in a clean project.

avatar image Sahnvour Mar 07 '15 at 04:10 PM

Hi, I'm sorry I didn't try to reproduce it yet, and I'm not sure I will have the time to investigate. The issue is gone now, but I can't say what solved it. Note that I upgraded to 4.7.2 in the mean time.

avatar image Rudy Q ♦♦ STAFF Mar 08 '15 at 05:01 PM

Hello Sahnvour,

I am happy to hear that your issue has been resolved. I am going to mark this question as answered for now. If the problem occurs again please feel free to reopen this issue and post any additional information at which time I would be more than happy to assist you further.

Make it a great day

avatar image Xenophont Apr 26 '15 at 12:07 AM

Hi there!

I have exactly the same issue, in all of my projects since an hour. I'm trying to identify what broke my unreal engine but I can't narrow it. If someone has the slightest idea of how to fix it, I'll accept any suggestions!

Thanks in advance!

avatar image Xenophont Apr 26 '15 at 12:16 AM

Ok, I think this happened when I switch quality from epic to normal, in order to procedurally spawn a LOT of actors. I've taken back quality to Epic and the bug is gone.....

avatar image Sahnvour Apr 27 '15 at 07:38 AM

That would explain why some people had this issue and some hadn't, and also why it disapeared for some time. However I can't test this solution at the moment but I'll try as soon as possible.

avatar image Sahnvour Nov 29 '15 at 04:10 PM

Hi

Just occured to me again (I didn't use UE4 for a long time) on 4.10, and as Xenophont said this happens when lowering the resolution scale in the editor's quality settings. The lower the resolution is, the farthest you have to point from the actual object you want to click.

avatar image Rudy Q ♦♦ STAFF Nov 30 '15 at 03:10 PM

Hello Sahnvour,

I was unable to reproduce this issue on our end. Could you provide the exact steps needed to reproduce this issue in a clean project?

avatar image Sahnvour Nov 30 '15 at 07:10 PM
  1. Launch UE 4.10, create new basic C++ project

  2. Play the default map inside the editor

  3. Eject

  4. Settings > engine scalability settings > switch to another preset than Epic, or just move the resolution scale slider under 100%

  5. Clic on the plane or sphere and try to move it by the 3d arrows, you'll see that you have to point your mouse at an offset as shown in my screenshots. screenshot

sans titre.png (843.6 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello Sahnvour,

I was able to reproduce this issue on our end. I have written up a report (UE-23924) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

more ▼

answered Nov 30 '15 at 07:58 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Sahnvour Nov 30 '15 at 08:52 PM

Well that's strange because I was able to reproduce it on two computers with different configurations. Thanks anyway, I hope that will be successful.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question