x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Projectiles not colliding with wall

Hello,
I am trying to create projectiles which are shot by a weapon and collide with everything in the world. I did it as it is done in the FPS template, except I created a base class for projectiles which actually has no properties. It is just a base class.
Then the actual projectile blueprint which I use has a collision component, a mesh (as a child) and a projectile movement component.
I created a collision object channel which has default response "block". I also created a collision preset which is just like the projectile preset in the FPS template. Here are the properties: alt text

But the projectiles collide with nothing. They just go through all walls. Did I miss something?

Product Version: Not Selected
Tags:
more ▼

asked Mar 05 '15 at 02:28 PM in Using UE4

avatar image

DawnNDeath
33 6 8 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Your collision settings look good.

I had a simialar error when using the third person template project.

In my projectile blueprint, in it's components, I had to merge the collision mesh to the root. (click and drag on the icons) my component list went from:

[root]

SphereCollision

-Mesh

Projectile movement component

To

[root]SphereCollision

-Mesh

Projectile movement component

As soon as I did this the projectiles started hitting things and even had the base speed i had entered. Hope this helps someone

more ▼

answered Feb 17 '16 at 03:52 PM

avatar image

Starskimmer
86 1 45 13

avatar image Arkandias Feb 27 '16 at 03:24 AM

Totally worked for me, thank you sir! I can't really figure out why it solved the problem though.

avatar image Starskimmer Feb 27 '16 at 06:09 PM

You're Welcome, I know basically nothing of the Engine, but based on the behavior I've observed I'd venture that when you make a new blueprint the root in left blank as who knows what you want to make, and the root overrides all its children settings. So it being blank overrides all our nice settings with Null. By assigning an object to the root level we are telling the engine that this is what it is and that we want these settings.

Again pure speculation. But glad the Data(from last post) helped.

Fly Free ~D

avatar image Anansi- Apr 20 '19 at 03:02 PM

You are my hero, I was searching for hours but setting the collision to the root of my projectile made id work! (I have a projectile setup like in the twin stick shouter tutorial) Overlap with other pawns worked. But I could make it generate hit events when hitting was. This is needed because fast traveling bullets will not allways generate the overlap event.

So thanks again! :) by the way this official doc is very good for the rest of the fysics configuration https://docs.unrealengine.com/en-us/Engine/Physics/Collision/Overview

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So this really bothered me as I've been having a ton of issues with collision. This is how you fix it:

Step 1: Go to this link https://answers.unrealengine.com/questions/134934/how-do-i-make-a-projectile-hit-the-walls.html and scroll down to azennig's answer. Copy the image of the blueprint he posted labeled "collisionevent.png (170.0 kB)."

Step 2: Create 3 components for your projectile: ProjectileMovement, Collision, and a mesh/sprite/flipbook (whatever your object is).

Step 3: Click on your capsule component and tick the boxes that say "Simulation Generates Hit Events" and "Generate Overlaps Events. Then set Collision Presets to > "OverlapAllDynamic."

Step 4: Click on your mesh/sprite/flipbook component. Tick the boxes that say "Simulation Generates Hit Events" and "Generate Overlaps Events. Then set Collision Presets to > "BlockAllDynamic.

Step 5. Make your collision (capsule, box, etc.) component the parent of your mesh/sprite/flipbook component.

You shouldn't need a root scene. And ProjectileMovement's placement doesn't matter. What does matter is the hierarchy of your custom capsule/box and your sprite/mesh. Since I used a Capsule and a sprite, I made the capsule the parent and I made the sprite the child. I made my capsule component the parent because it will be colliding with everything before the actual sprite does. So it only makes sense for the parent object to interact with the world before the child.

I hope that helps.

more ▼

answered Apr 16 '16 at 03:21 PM

avatar image

NinjaFrankJaeger
11 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You need to add a collision to the walls as well.

Load the mesh in to the Shape Editor and add a collision there ... or add it in the level from the properties window.

more ▼

answered Mar 05 '15 at 02:33 PM

avatar image

qdelpeche
649 31 10 42

avatar image DawnNDeath Mar 05 '15 at 02:50 PM

I am not sure what exactly you mean. Do you mean the wall itself? I looked at the collision properties of the wall, and everything seems correct. It is supposed to block the Projectile.
Here is an image of this (you can see the selected wall and the collision properties): alt text

avatar image qdelpeche Mar 05 '15 at 02:52 PM

Is it a BSP Brush or a Static Mesh?

avatar image DawnNDeath Mar 05 '15 at 02:53 PM

It is a static mesh.

avatar image qdelpeche Mar 05 '15 at 02:56 PM

You need to give the static mesh a collision.

Static Mesh Collision Reference

FBX Static Mesh Pipeline

Creating collision on static meshes <-- Previous AnswerHub

avatar image DawnNDeath Mar 05 '15 at 03:53 PM

Hello,
Well, the Walls and floor used are the walls and floor in the 3rd Person template in the example level.
I examined the mesh which belongs to the wall and it has a collision. I also deleted that collision and added a new simple box collision. That changed nothing.
Here is an image of the mesh in the editor: alt text

avatar image Shadowaecat Oct 24 '15 at 02:41 PM

Did you solve this? I am having this issue with the static meshes from the Infinity Blades package. My enemies (prefabs from the Shooter Game demo) shoot through everything, even though they have collision and Block set for projectiles.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I could solve this error. But the cause seems very strange to me.
I deleted the Base class and created a projectile which is just a subclass of Actor. Then I set up everything as before and it worked.

Conclusion: Having a base class for projectiles which is a subclass of actor seems to induce this error.
Is this a bug?

more ▼

answered Mar 06 '15 at 10:05 AM

avatar image

DawnNDeath
33 6 8 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question