x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project Launcher not signing APK

Hi,

I've been struggling with this problem for some time now. I've been trying to lower APK file size using -compressed -pak commands in cooker commandline. It is exposed in Project Launcher, which is why I used this method. My APK builded from standard packaging method File>Package Project>Android>Android_ETC1 is properly recognized by google play but it's size is too big (64mb). Now, using -compressed -pak allows me to shrink file down to 40MB which is under 50 mb required by Google Play. Unfortunately file is set as debuggable, and even signing it manually after packaging (using jarsigner) doesn't solve issue. Build and cooker are set to shipping. I'm attaching screenshot from my Project Launcher and log.

Cokker_commandsProject_log

Product Version: Not Selected
Tags:
more ▼

asked Mar 05 '15 at 04:07 PM in Packaging & Deployment

avatar image

Turbo Marian
11 2 3 4

avatar image wittlief ♦♦ STAFF Mar 05 '15 at 11:11 PM

Hi Turbo Marian,

Thanks again for bringing this to the AnswerHub, and most especially for attaching the logs. :D I'm going to see if we can get more eyes on your issue. In the meantime, when you tried manually signing your apk using jarsigner, did you get any sort of error? Something like "invalid entry compressed size"? If you did, please have a look at this thread, which may help. If you didn't, no worries, we're still working on it.

Thanks very much!

avatar image Turbo Marian Mar 06 '15 at 11:24 AM

At first I did have problems with invalid entry size but deleting META-INF folder from compiled package solved this issue. I'm using this method to resign package. Will try now with lower java version.

avatar image Turbo Marian Mar 06 '15 at 02:24 PM

Searching through log I have found some interesting data

 ProjectParams.ValidateAndLog: Distribution=False

and

 ProjectParams.ValidateAndLog: SignedPak=False
 ProjectParams.ValidateAndLog: SignPak=

Does it mean Project Launcher reads these values from somwhere else than AndroidManifest.xml? Also I'm on 4.7.2, but this particular problem persists from 4.4.

avatar image piXelicidio Jun 27 '15 at 01:46 PM

Where I can't find this ProjectLauncher settings? or how I can set the "-compressed" comand?

avatar image wittlief ♦♦ STAFF Jun 29 '15 at 03:08 PM

hi piXelicidio,

Please see the answer below, it's part of the command line settings.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Turbo Marian,

Unfortunately, we currently don't have a way to specify a game is meant for distribution via the Project Launcher. However, you can do this from a command line with the following command (tailored from your log):

"C:\Program Files\Epic Games\4.7\Engine\Build\Batchfiles\RunUAT.bat" BuildCookRun -project="C:/Users/Tomato/Documents/Unreal Projects/Vitalick4.6 4.7/Vitalick.uproject" -noP4 -clientconfig=Shipping -serverconfig=Shipping -rocket -platform=Android_ETC1 -targetplatform=Android -cookflavor=ETC1 -build -cook -map=Basic_Level+Minimal_Default -compressed -pak -pak -iterativecooking -stage -package -cmdline=" -Messaging" -addcmdline="-SessionId=3AFB3BE641109EE43B6A2EA6567B2977 -SessionOwner=Tomato -SessionName='New Profile 0'" -NoCompile -distribution

That will do everything you specified in the custom profile as well as build it for distribution.

-Pete

more ▼

answered Mar 06 '15 at 03:04 PM

avatar image

Ravlek STAFF
1.9k 4 6 34

avatar image Turbo Marian Mar 09 '15 at 01:47 PM

Solved! I also backed up to 4.6.1 engine version and my package weight 31.5 mb :). I'll stick with it for now, and wait for 4.8. TY for help!

avatar image BrunoChaves Jun 14 '17 at 03:59 PM

How i generate a file to upload in web browser with this method? I tried, but just opened the web browser to test it. I don´t get it.

I´ve configured the package way to build. But when i hit the "Launcher" button in ProjectLauncher window, looks like my configuration i made don´t work. Can you explain how does it work and how i do to launch properly, creating an APK file. Thanks

avatar image piXelicidio Jun 14 '17 at 04:07 PM

APK is for Android devices. In order to run in your Browser you need to export as HTML5, that's a different target.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had the same problem. Added "-distribution" to Additional Cooker Options in Project Launcher

more ▼

answered Jul 28 '17 at 09:52 PM

avatar image

VinnyBlood
129 6 18 20

avatar image Lucas-G-Farina Nov 09 '17 at 05:49 AM

Yep! Tested and working! Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question