x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Static Shadows not saving 4.7

For some reason our static shadows do not appear to be saving after closing and reopening the editor. We recently upgraded to 4.7 and this issue is new. After the bake is complete the shadows appear fine but its only after save+close+reopen that they disappear.

Product Version: Not Selected
Tags:
more ▼

asked Mar 05 '15 at 04:52 PM in Rendering

avatar image

THREEONEZERO
131 6 7 18

avatar image JakobP Mar 14 '15 at 10:27 AM

Same problem here, after lighting build the shadows are there but after reopening they dissaper in the editer. When I hit PIE the static shadows/lighting are there again. In standalone, the shadows only appear when I change the effects quality.

Sometimes they also reappear in the editor, but I don't know why...

And it also seems to only happen in composite levels with streaming levels.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

We discovered the work around and it's on udn if you have access.

https://udn.unrealengine.com/questions/238588/static-lighting-invalidated-after-closing-the-edit.html

If you don't have access then look in scenecore.cpp. Look for where it checks for num cached > numu cached threshold and invalidates the lighting. It's a Cvar currently set to 500. Either make the Cvar much bigger or remove the check all together.

This code has been there for a while but for some reason in 4.7 has been caused to fire prematurely. Check out the udn if you can. Lots more detail.

more ▼

answered Mar 14 '15 at 12:52 PM

avatar image

THREEONEZERO
131 6 7 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi,

Does this problem occur with foliage meshes? Because I had a similar issue and the solution was to update the "Foliage Settings" for each foliage actor. I did so by changing the culling distance for the affected meshes. Hope this helps.

more ▼

answered Mar 06 '15 at 12:25 PM

avatar image

slayniak
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question