x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[4.7] Serious Android Development Crashes and Build Errors

Original Forum Post Here

We recently upgraded our project to 4.7, and found that we get instant crashes when attempting to load into a game from the menu screen we have built. We are not given any kind of screen or debug information despite running through Visual Studio on the device. We are explicitly targeting the NVidia Shield hardware.

Although there appear to be a number of issues related to Android crashes on 4.7 recently, the fruit of my searching has been this forum post & answerhub link, which indicates there was a known issue with Opening Levels on Android prior to release. We haven't made any changes to the project during the upgrade, other than switching the engine version and re-compiling. We also re-built our source files just in case. I must stress that using the GitHub build / non-compiled version of the editor isn't really an easy option for us, but if we can be certain the issue has been fixed we may consider moving to it.

Here's some additional details on how we're doing this:

  • We package the game for Android. We use a Development Build, use Pak file and do not have 'For Distribution' checked. There is an attached screenshot of the build settings.

  • We install the built game onto the Shield Tablet and run the game.

  • The game immediately loads to our main menu level as expected.

  • We now attempt to join the server (which is a PC running the same version of the software), and we get an instant crash on level load. We do not however, get any logs on the tablet (perhaps this is by design).

  • This ALL worked in 4.6 without any errors, we we're able to join and play the game.

  • When doing all of the above using the Debugger in Visual Studio, we get the same crash in the same location, but Visual Studio gives us no crash information whatsoever, so we have no idea why the crash has been triggered.

  • This is NOT a failure to join the network, we have tested this and when the tablet can't connect to the PC, it returns to the main menu.

Here are the build settings: alt text

Additionally, when attempting to build our latest Android version of the game, the output logs reaches the end of the build and then tells us it can't find the .EXE file in the Binaries folder. When we navigate to that location in Explorer however, it does in fact exist. I have attached the build log in a .zip file.link text

Product Version: Not Selected
Tags:
buildlog.zip (253.3 kB)
more ▼

asked Mar 05 '15 at 04:49 PM in Bug Reports

avatar image

TheJamsh
815 59 97 140

avatar image TheJamsh Mar 19 '15 at 03:11 PM

Sorry guys, have to open this up again. The initial crashing was caused by our code, but it seems the issue of building for Android has come up again.

This is the actual issue we're experiencing, our programmer posted the callstack on the forums. Something to do with the Engines checkf Macro potentially?

https://forums.unrealengine.com/showthread.php?63526-Asserts-on-Android-4-7

avatar image [Epic] Gribbs ♦♦ STAFF Mar 20 '15 at 05:14 PM

Howdy TheJamsh,

I spoke with our Android Dev and was informed that thPath problem error should be have been resolved in the 4.7.3 hotfix. Would you be using this hotfix or another version of 4.7?

As for the assert issue, an assert on device will not assert in VS unless you are in debugging.

Let me know if this helps with your issue.

Thanks!

avatar image [Epic] Gribbs ♦♦ STAFF Mar 25 '15 at 07:23 PM

Hey TheJamsh,

Just wanted to check in with you and see if that helped to clear up any issues that you have been experiencing. Be sure to let me know so that I may be able to further investigate if needed.

Thanks!

avatar image TheJamsh Mar 26 '15 at 03:50 PM

Hi Sean,

I'm attempting to do it right now, but currently I can't seem to build or package the project due to 'WChar.H' being missing, whatever that is... apparently the file is an Include in PlatformIncludes.h

I'm packaging for Shield with DXT, tried other settings but they're all the same.

avatar image [Epic] Gribbs ♦♦ STAFF Apr 13 '15 at 01:31 PM

Hey TheJamsh,

Just wanted to check in with you and see if you have still been running into these errors with your project since the release of a couple of hotfixes since my last comment. Be sure to let me know when you get the chance so that I may be able to further investigate.

Thanks!

avatar image TheJamsh Apr 21 '15 at 10:41 PM

Hey Sean, this appears to have been fixed in one of the hotfixes, not seeing the issue anymore :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey TheJamsh,

Glad to hear that the issue has been resolved. Let me know if you run into any similar errors in a later release.

Thanks and have a great day.

more ▼

answered Apr 22 '15 at 09:13 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

To rule out any issues on NVidia tablet side (graphics driver not liking a shader, memory constraints,..) you should provide Epic with your Android logs.

more ▼

answered Mar 05 '15 at 06:06 PM

avatar image

ngrts
88 3 8 9

avatar image TheJamsh Mar 05 '15 at 09:31 PM

Thanks ngrts, I'll forward that link along!

I think the Tablets are coping okay, we actually cut out a lot of content since this issue started just incase, and there's a new cap on the size of the package you can install which we never used to hit in 4.6.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question