x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Using exact Timeline vector values on Cam (add local offset) still displaces camera over time

I am trying to achieve a camera walking animation without the use of external tools like the often suggested bone camera joint animation.

I have a small timeline vector animation which makes the camera bounce slightly, What I have noticed though is that, even if I have the vector points set by entering the values manually instead of drawing them, the camera ends up getting displaced a little bit every time the timeline loops through. So after a bit of walking in the game my camera ends up higher than when the game compiles and started.

Now I tried to add relative offset to both camera directly and I've tried put the camera into a sphere instance hierarchy and apply the offset to the sphere which you can see here as the target of the add local offset. Both end in same result.

alt text alt text

Product Version: Not Selected
Tags:
more ▼

asked Mar 05 '15 at 05:54 PM in Blueprint Scripting

avatar image

TobiasRipper
103 44 47 68

avatar image Purecyn Mar 05 '15 at 08:53 PM

I have ran into similar issues with timline minipulation on objects. If you print out your cameras cords every time this timeline loops I bet you'll see that they are different; even with a 0 in and 0 out. I'm not sure what causes it, but I'd be interested in this answer myself.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question