x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to work around this bug when packaging?

So, there is this bug. A custom AIController gets reset to the standard AIController when closing and reopening the editor.

It's not that much of a problem to go through every single AI Character Class and reset the AIController. But what if I want to package my game? I tried this and apparently AIController instead of MySpecificAIController gets used.

Is there a way for me to package my game correctly?

Product Version: Not Selected
Tags:
more ▼

asked Mar 05 '15 at 08:39 PM in Packaging & Deployment

avatar image

Deventico
214 19 20 30

avatar image MieszkoZ STAFF Mar 06 '15 at 09:58 AM

I recall a bug like that, pre 4.7 I think. Which UE4 version are you using?

--mieszko

avatar image Deventico Mar 06 '15 at 10:22 AM

Hey mieszko,

I use 4.7.2.

You might recall the bug I linked in the first line; it's from August '14. It seems like the issue has reappeared.

One important thing to note: My Character is derived from a Parent Character which is derived from the Character class. It does not matter which AIController the Parent Character has set, but the bug did not happen before I had this Parent-Child relationship.

avatar image MieszkoZ STAFF Mar 06 '15 at 10:34 AM

Yeah, it looks like it's been reintroduced. I'm guessing it has something to do with fixes to circular dependencies. I'll escalate this so that it gets addressed as soon as possible. Thanks for reporting!

avatar image Deventico Mar 06 '15 at 10:37 AM

You're welcome!

avatar image User-1420270633 STAFF Mar 06 '15 at 06:18 PM

Hi Deventico,

We've been unable to reproduce this issue. As it may be specific to a cyclic dependency issue unique to your assets, is there anyway you could provide us with a stripped down version of your project with the problematice asset and its dependencies?

Also, to help us confirm this is related to the recent cyclic dependency issue fixes, could you try disabling bDeferDependencyLoads in BaseEngine.ini (set it to: bDeferDependencyLoads=false). If that resolves your issues, then it is definitely related.

Thanks!

avatar image Deventico Mar 06 '15 at 06:49 PM

Hey Mike,

thank you for investigating!

when I set bDeferDependencyLoads=false, the engine crashes upon startup. I attached the error log. When I set it to true again, it doesn't crash anymore.

I'll upload a stripped down-version later.

avatar image User-1420270633 STAFF Mar 06 '15 at 06:54 PM

So this is a sign that you do have a cyclic dependency, and that our stuff is working (mostly). If you get us assets to investigate, then we'll be able to better narrow down the issue.

We've already made some fixes in this area that will be in the next release, but I'd like to confirm that yours is not a unique issue that we haven't seen.

avatar image Deventico Mar 06 '15 at 06:58 PM

Oops, forgot to upload the error log.

Here it is

I'll strip down my version soon, I'm just a bit busy right now.

avatar image Deventico Mar 06 '15 at 08:33 PM

Ok, so the upload just finished.

I basically deleted just about everything that's not a blueprint, but the critical AI Controller and the Characters compile fine and the bug still persists.

You can find those blueprints in Blueprints/AI. The AIController that the Characters should have is called Follower_AI_Con. The Base Class for Characters is Melee_Character. Here the AI Controller stays the one it should be, there is no issue.

The two 'broken' characters are the children of Melee_Character: Barbarian and Sword_Fighter.

If you run into any issues with the project, let me now.

Good luck and thank you again!

avatar image User-1420270633 STAFF Mar 06 '15 at 11:13 PM

Seems like you've left out some source code from the project. The visual studio solution is there, but none of the source.

If you're worried about securing your code, you could close off the google drive link and only share it with mike.beach@epicgames.com.

avatar image Deventico Mar 06 '15 at 11:55 PM

Sorry, I must've missed that folder. We mostly programmed with blueprints, C++ is currently only usd for a few things regarding ServerTravel.

Here you go.

I'll close the google link however.

source.zip (109.0 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Great news! We already fixed your issue, just this week.

This was fixed by this commit: https://github.com/EpicGames/UnrealEngine/commit/5b06ef7cd541deb6dc0c57fc7ed19868ba7a1916, and is slated for a release in the near future.

If you cannot wait until it is released, then you can temporarily integrate the change and build the editor yourself (it sounds like you're already working in code).

Thanks for working with us to narrow down the issue!

more ▼

answered Mar 07 '15 at 01:33 AM

avatar image

User-1420270633 STAFF
968 27 26 58

avatar image User-1420270633 STAFF Mar 07 '15 at 01:36 AM

Oh, I should mention: that if you do integrate the change into your codebase. Then DO NOT take the change here that was made to UObjectGlobals.cpp (only take the change to BlueprintSupport.cpp).

The UObjectGlobals.cpp changes caused other issues that we're later fixed up in a different change.

avatar image Deventico Mar 07 '15 at 07:39 AM

Great! I'm glad, that it's solved.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question