x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

New Code Folders in the Editor

EDIT: It was an error elsewhere. Sorry.

And sorry, Unreal Engine 4, for doubting you. I still love you.

I can't find a working answer to this problem, which is odd because it seems like it'd be a pretty glaring issue. Maybe its just me messing up.

I tried creating code (a class called "FolderProblemActor") with Unreal Engine under a new folder ("Source[ProjectName]\DifferentFolder") for organization:

alt text

Unreal Engine 4.7.2, however, won't play along. When I clicked Create Class, it gave me this:

alt text

The code files were indeed created, and the folder was made, and Visual Studio was very politely informed of this - all by UE4. Unreal Engine seems to have forgotten that it just made the files and folder; consequently, it will not recognize the folder nor the files. Instead, it says that it had an error.

If Unreal Engine doesn't recognize the code files, then I can't do programmy stuff. If I can't do programmy stuff, then Unreal Engine is essentially bricked.

I have closed and reopened both UE4 and VS. I have regenerated the source code from the .uproject file. I have tried yelling in frustration. None of those worked. Do any of you have suggestions so this problem can be swept away, and I can get back to enjoying the remarkable (and now free! Hurrah!) game engine?

Product Version: Not Selected
Tags:
more ▼

asked Mar 06 '15 at 03:00 AM in C++ Programming

avatar image

Kowbell
150 17 26 38

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

It's a poorly worded error. It hasn't actually failed to add the new class, but it has failed to recompile and hot-reload your game module afterwards (which is why the class doesn't appear in the Content Browser).

Does the Output Log (File -> Developer Tools -> Output Log) show any more details about why this failed?

Are you able to build your game module normally via Visual Studio?

more ▼

answered Mar 06 '15 at 10:46 AM

avatar image

Jamie Dale STAFF
7.4k 176 66 304

avatar image Kowbell Mar 06 '15 at 12:00 PM

Nevermind. It was the InteractableActor error. My bad

Output Log gave me this: alt text

Too big to paste here, so here it is in a .txt file:

And I can still build in VS, but UE4 still doesn't respond. Also, that error about the InteractableActor and whatnot does not arrive when I compile normally - neither in VS or UE4.

avatar image Jamie Dale STAFF Mar 06 '15 at 12:33 PM

So to clarify, was that a genuine linker error that you have now fixed, or are you still having a problem when adding new classes via a hot-reload in the editor?

avatar image Kowbell Mar 06 '15 at 11:53 PM

It was entirely faulty code on my end. It now recognizes folders and works beautifully.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question