x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Build Geometry mess up every material into the map

EDIT: [FOUND A HALF SOLUTION] - When build, set the alignment of all the materials placed on the map to "Align Surface Default", if it doesn't work, set the alignment to "Align Surface Fit" and then reset it to "Align Surface Default"

EDIT: I found another topic that talked about this problem, IT IS ACTUALLY A BUG! That's the CODE OF THE BUG: UE-11368

First of all... these are the assumptions for my map:

  • It is an imported t3d. (EDIT: It doesn't happen only with imported BSPs, but with the new BSPs too).

  • I scaled it to x100 y100 z100 (cause it was small like a foot of a standard character).

  • I did put a Lightmass Importance Volume covering all the map.

So, the problem is that when I Build, or just applying a Build Geometry, it mess up every material of my map, also, I can't even pan and scale the material anymore after that. With mess up every material I meant that they become a lot pixellated. EDIT: I tried setting the detail of the texture to "NoBitMap", it works but, when I build the geometry, it resets all the textures, even if I scaled them or rotated them or whatever.

Here the screenshoots:

  • Before reduild: alt text

  • After rebuild: alt text

  • Trying to rebuild a second time: alt text

  • Trying to rescaling the applied materials: alt text

p.s. Already tried with restarting the editor.

Product Version: Not Selected
Tags:
more ▼

asked Mar 07 '15 at 12:31 AM in Bug Reports

avatar image

Francesco Biscazzo
8 1 6 6

avatar image Lovecraft_K ♦♦ STAFF Mar 07 '15 at 01:05 AM

Hey Francesco Biscazzo -

The t3d file that you imported, was it from UDK (UE3)? If so, there are some major differences in how the two engines handle the BSPs. One of which is how UVs are handled which would explain why when you told the UE4 to rebuild the Materials seemed to change and stretch but the vertices did not.

Thank You

Eric Ketchum

avatar image Francesco Biscazzo Mar 07 '15 at 01:14 AM

Eric Ketchum : I imported it from Unreal Editor 2.0 , the one of the old Unreal Tournament

EDIT: And anyway, it doesn't happen only with imported BSP, but new BSP too, I'll add this on the main post.

avatar image Lovecraft_K ♦♦ STAFF Mar 07 '15 at 01:23 AM

Hey Francesco -

Ok, so my first suggestion is to use the layout that the t3d gave you and actual rebuild the map from scratch in UE4. I want to make this my first suggestion as it will give you a chance to really learn the new aspects of the engine and create something that you already know how it works, so the learning is all about the tool and not the level design.

The key issue is that you have turned in several BSPs from UE2 to one giant and BSP in UE4 and the unwrap of the mesh is all over the place which is causing the scaling and material issue you are responding.

Besides rebuilding the level, you can try to convert the BSP into a Static Mesh and then export it to a modeling program to unwrap and then bring it back into the engine.

Thank You -

Eric Ketchum

avatar image Francesco Biscazzo Mar 07 '15 at 01:33 AM

I already tried with converting it into Static Mesh, nothing changes :/ But I don't know what you meant with "exporting it to a modelling program to unwrap". By the way: I saw that the NoBitMap actually works, I just didn't save the texture.

But still... the geometry buil reset every material, even if I, or example, rotated the materials :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Francesco Biscazzo -

I have added your information to our internal bug report as you mentioned above, UE-11368, and will keep you informed as we work toward a solution.

Thank You

Eric Ketchum

more ▼

answered Mar 08 '15 at 01:48 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image Francesco Biscazzo Mar 08 '15 at 07:59 PM

Hey, thank you very much! I finished my map, that's the last of 2 issues I encountered.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I wanted to say that the problem still persists. Did you find any solution?

more ▼

answered Oct 31 '15 at 03:03 PM

avatar image

Francesco Biscazzo
8 1 6 6

avatar image Lovecraft_K ♦♦ STAFF Nov 02 '15 at 03:06 PM

What version of the Engine are you in ? This issue was resolved in the 4.7.4 Hotfix. If it is recurring for you, please give as much information about your engine version and setup as possible.

Thank You -

Eric Ketchum

avatar image Francesco Biscazzo Nov 03 '15 at 09:14 PM

I couldn't of install the 4.7.4 version because it didn't work on my old laptop, now I've a new one and so I downloaded this version using the official launcher: version 4.8.0-2739211+++depot+UE4-UT-Releases

I'm not so sure, but I think the problem does now appear even building light only.

avatar image Lovecraft_K ♦♦ STAFF Nov 04 '15 at 08:49 PM

Hi -

We are currently unable to reproduce this issue in the most current version of the Editor or in the version of the UT Editor you mention above? Can you attach a sample project here for us to test on?

Thank You

Eric Ketchum

avatar image Francesco Biscazzo Nov 06 '15 at 03:28 AM

You're correct, but my map still has that problem, so I thought it was related to the t3d I imported time ago, I tried reimporting it into a blank map, but I couldn't, I don't know why, If you tell me a place where to send the t3d file, I'll try to do it.

avatar image Lovecraft_K ♦♦ STAFF Nov 06 '15 at 03:49 PM

Just place the t3d in a zip and then attach it here. If it happens to be over 5MB, then you can share a google drive or dropbox link here.

Thank You -

Eric Ketchum

avatar image Francesco Biscazzo Nov 06 '15 at 10:07 PM

The t3d is around 36Kb, I zipped it but nothing, the attachment is not valid, I'll share it with dropbox: https://www.dropbox.com/s/p9ejsgireqsiq2j/w00tabulous.t3d?dl=0

It is a t3d file I exported using Unreal Editor from Unreal Tournament (1999)

avatar image Adam Davis STAFF Nov 10 '15 at 06:45 PM

Hi Francesco,

Unfortunately I was unable to use the .t3d files that you posted here. Does this occur in a clean, blank level with no additional content or is it limited to one level/set of bsp brushes?

avatar image Francesco Biscazzo Nov 12 '15 at 01:34 AM

Mainly only BSP Brushes. I placed only four standard cubes as static meshes, but I didn't check if the materials get messed on their surfaces.

avatar image Adam Davis STAFF Nov 12 '15 at 03:24 PM

Try creating a brand new level and place a single bsp brush within the level to try and see if the material error occurs when you use the build geometry. Are you seeing the same error occur in this scenario?

avatar image Francesco Biscazzo Nov 13 '15 at 07:55 PM

I just placed a BSP cube inside the map I showed in the first post, and that BSP cube is not affected by this bug. Plus, I tried creating a new empty map to import the t3d file, and yes, the import doesn't work with that t3d now. But it worked when I created this topic, on that Unreal Editor version.

avatar image Adam Davis STAFF Nov 16 '15 at 06:45 PM

Hi Francesco,

Unfortunately, UE4 is not intended to support files from previous engine iterations. While it may have been able to be imported in a previous engine version, this was more by chance than intended functionality. I am happy to hear this issue does not occur for you with other bsp brushes or files. I am marking this as answered for tracking purposes. If you experience this error again with BSPs outside of this file, please feel free to re-open this thread and we'll continue looking into it.

avatar image Francesco Biscazzo Nov 19 '15 at 02:06 AM

Oh ok, thank you for your support, I'll try to replace all the old BSP brushes with the newer ones :).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question