x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Right Click Menu Delay

Hi

Does anyone else have a slight delay when you right click to open the blueprints menu? for me it delays like a second every time I one it, is a little annoying

is there a set delay time before that menu appears? I really want it to appear instantly I have to wait to search for my nodes.

any workarounds ?

Thanks

Product Version: Not Selected
Tags:
more ▼

asked Mar 07 '15 at 02:21 AM in Blueprint Scripting

avatar image

varomix
252 19 22 34

avatar image Mortusnyte Mar 07 '15 at 03:41 AM

I was getting similar lag on a blueprint that was getting quite big. Otherwise no lag. Especially since 4.7. That big blueprint barely lagged any more after 4.7. I have a pretty strong pc, that could be your issue?

avatar image varomix Mar 07 '15 at 04:39 AM

My computer is not bad and I have a good graphics card GTX 970 so I know is not that, also this happens even on a new empty project and blueprint

avatar image varomix Aug 20 '15 at 05:20 PM

This is still freaking bothering me, every were else the menu comes up instantly, only on the blueprints is delayed a little, even if I right click on a node in the blueprint the menu comes up super fast, PLEASE HELP, drives me crazy.

THANKS :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The issue is with each node by default it checks if everything in your BP is legit. I seem to remember that you could turn this off somewhere but the easy and obvious workaround is to keep each graph small.

Now it's perfectly possible to create huge BPs but after a hundred or so nodes you should start thinking about collapsing some of them (Select an area, rightclick on a node -> Collapse Nodes). It splits it up for development into a new graph but is technically still the same. You can even get inputs and provide outputs. It's just a way to clean things up.

This should also cause a delay when moving nodes. There is no specific delay on the opening so if only the actual opening of the menu is causing troubles it'd be rather strange.

Cheers

more ▼

answered Mar 07 '15 at 10:08 AM

avatar image

Erasio
5.9k 291 86 293

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question