x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

make : fatal error: 'new' file not found

I checked out the latest UE4 version from git (4.7). Setup.sh worked without problem. $ ./GenerateProjectFiles.sh -> works make

 Engine/Build/BatchFiles/Linux/Build.sh UE4Client Linux Debug 
 Building UE4Client...
 Using clang version '3.5.1' (string), 3 (major), 5 (minor), 1 (patch)
 Building UnrealHeaderTool...
 Using clang version '3.5.1' (string), 3 (major), 5 (minor), 1 (patch)
 Performing 19 actions (4 in parallel)
 [4/19] Compile Module.Core.3_of_5.cpp
 [3/19] Compile Module.Core.4_of_5.cpp
 [1/19] Compile Module.Core.2_of_5.cpp
 [2/19] Compile Module.Core.1_of_5.cpp
 In file included from /mnt/storage/jarvis/newgen/ue4/UnrealEngine/Engine/Intermediate/Build/Linux/x86_64-unknown-linux-gnu/UnrealHeaderTool/Development/Core/Module.Core.4_of_5.cpp:2:
 In file included from /mnt/storage/jarvis/newgen/ue4/UnrealEngine/Engine/Source/Runtime/Core/Private/CorePrivatePCH.h:16:
 Runtime/Core/Public/HAL/PlatformIncludes.h(5,10) : fatal error: 'new' file not found
 #include <new>
          ^


This keeps repeating. What am I missing?

Product Version: Not Selected
Tags:
more ▼

asked Mar 08 '15 at 12:45 PM in Installation & Setup

avatar image

thecr3w
26 3 6 7

avatar image Ben Halliday STAFF Mar 08 '15 at 01:42 PM

Hey thecr3w,

I'm assigning this post to someone on our team, but I just want to check one thing: are you intentionally trying to build for Linux?

avatar image thecr3w Mar 08 '15 at 01:53 PM

Hello Ben,

well, I was told that UE4 is capable to run unter linux (although I expect even more crashes than in osx or windows).

Since the app I am trying to migrate to UE will run mainly in linux (and the only fast system I have is running fedora linux)... thats why I try running it under linux directly. So yes, it's my intention.

avatar image Doug E ♦♦ STAFF Mar 10 '15 at 04:50 PM

Hey thecr3w-

I have a couple other questions for you to help me test the issue you're having. You seeing the message while ./GenerateProjectFiles.sh is running, correct? Have you tried any other engine versions and received the same error? When you mention "This keeps repeating" are you referring to everything from line 1 to line 14 or only line 14?

Cheers

Doug Wilson

avatar image thecr3w Mar 10 '15 at 07:44 PM

Hi, ./GenerateProjectFiles.sh works fine. I get this error while running "make".

I will try other versions, but I had the same problem with version 4.6.

While running make, the following error repeats:

Runtime/Core/Public/HAL/PlatformIncludes.h(5,10) : fatal error: 'new' file not found

Checking PlatformIncludes.h, I can see in line 5: #include

However: "new" is not found. It seems Unreal overloads the "new" operator with their own "new". Sadly, I have no clou, where that "new" is defined...

avatar image Doug E ♦♦ STAFF Mar 11 '15 at 07:50 PM

Are you running the entire line of "$ make ShaderCompileWorker UnrealLightMass UnrealPak UE4Editor"? If so try doing a different make for each which could tell us exactly where in the make process it is failing.

avatar image thecr3w Mar 11 '15 at 08:31 PM

I have tried:

  • make ShaderCompileWorker

  • make UnrealLightMass

  • make UnrealPak

  • make UE4Editor

Each different make command generates the error mentioned above. They all seem to rely on

  • Runtime/Core/Public/HAL/PlatformIncludes.h(5,10) : fatal error: 'new' file not found

In the mean time, I downloaded the UnrealEngine-Release.zip from git, extracted it and repeated the installation. However, I get stuck at the same error.

avatar image thecr3w Mar 13 '15 at 10:31 AM

Ok, I just realised that Setup.sh checks only for Ubuntu, Debian and LinuxMint. Sadly, I am running Fedora. Therefore, I assume that the Setup Script bypasses some requirements.

avatar image Olifante Jun 30 '15 at 07:44 PM

I'm having the same problem on debian stable (jessie) when trying to build version 4.8. The strangest thing is that building in a virtual machine with the same debian version works, so it must be something in my configuration.

avatar image Humroben Jan 12 '16 at 12:22 PM

Although the User's problem was solved, I've discovered another reason why this error would occur:

 fatal error: 'new' file not found
  #include <new>

This took me a little longer to solve, as I've already got all of the dependencies on my Debian machine. I've got 2 identical systems, Debian 8, with jessie-backports repository enabled (for latest drivers and dependencies for gaming). One a Laptop, and the other a desktop PC. I managed to install UE4 on the laptop, but not the Desktop.

This is because of the environment variables, C_INCLUDE_PATH and CPULS_INCLUDE_PATH. On the laptop, they were set by default as and when packages were installed. But on my Desktop, these weren't set. It took trial and error with using locate locate -b new | egrep 'new$' or locate -b 'someheaderfile' and then amending the variables where needed.

I now have a new error, but this I can work with. Hope this helps anyone who experiences the same issue as stated

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey thecr3w-

We currently only have automation for installing dependencies for Ubuntu and Ubuntu forks. The following page details the important dependencies if you do not already have them on your machine. Once you have installed those necessary you should be able to continue with the installation.

https://github.com/EpicGames/UnrealEngine/blob/release/Engine/Build/BatchFiles/Linux/README.md

Cheers

Doug Wilson

more ▼

answered Mar 13 '15 at 03:35 PM

avatar image pav5000 Sep 07 '15 at 07:44 PM

I'm facing the same problem "'new' file not found" on Ubuntu 14.04. Trying to build 4.9 Is there any solution available?

This is a link to full build log http://pastebin.com/XCE9T7iW

avatar image RCL STAFF Sep 07 '15 at 07:46 PM

Make sure you have both g++ and clang-3.5 installed.

avatar image pav5000 Sep 07 '15 at 08:08 PM

They are both installed

 $ clang --version
 Ubuntu clang version 3.5.0-4ubuntu2~trusty2 (tags/RELEASE_350/final) (based on LLVM 3.5.0)
 Target: x86_64-pc-linux-gnu
 Thread model: posix

 $ g++ --version
 g++ (Ubuntu 4.8.4-2ubuntu1~14.04) 4.8.4
 Copyright (C) 2013 Free Software Foundation, Inc.
 This is free software; see the source for copying conditions.  There is NO
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


avatar image Doug E ♦♦ STAFF Sep 16 '15 at 03:37 PM

Hey pav5000-

Are you able to compile a "Hello World" program with clang? If you're still having trouble compiling C++ then there may be something wrong with the setup on your machine.

Cheers

Doug Wilson

avatar image pav5000 Sep 16 '15 at 03:51 PM

Hello world compiles perfectly.

 $ cat hello.cpp 
 #include <iostream>
 
 int main() {
     std::cout << "Hello, world!\n";
     return 0;
 }
 $ clang++ -stdlib=libc++ hello.cpp 
 $ ./a.out 
 Hello, world!
avatar image RCL STAFF Sep 16 '15 at 03:53 PM

Do not pass -stdlib=libc++ since the engine doesn't do that.

avatar image pav5000 Sep 16 '15 at 04:02 PM

Oh, that's may be a problem.

 $ clang++  hello.cpp 
 hello.cpp:1:10: fatal error: 'iostream' file not found
 #include <iostream>
          ^
 1 error generated.

What can cause this? I launched setup.sh and it inslatted a lot of dependencies but problem is still there =(

avatar image RCL STAFF Sep 16 '15 at 04:03 PM

Install libstdc++ package, it should fix that.

avatar image pav5000 Sep 16 '15 at 04:31 PM

Looks like clang3.5 in Ubuntu 14.04 is trying to use libstdc++-4.9-dev. But in default repo threre is only libstdc++-4.8-dev. I've added ppa:ubuntu-toolchain-r/test and installed libstdc++-4.9-dev from there. Hello world now compiles succesfully. Will try to build Unreal Engine now!

avatar image RCL STAFF Sep 16 '15 at 07:44 PM

Glad to see it resolved, but FWIW other 14.04 user (including on our side) did not have that problem, which is baffling.

avatar image pav5000 Sep 17 '15 at 08:56 AM

Editor has compiled successfully! Great thanks for your help!

It looks like clang is trying to use the latest gcc available in the system. In my case it was 4.9, which came as a dependency to some other software. This software was installed from third party ppa, so gcc4.9 was downloaded from it. But in that ppa there was no libstdc++-4.9-dev. It caused fail in UE4 build process.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Ok, I switched from fedora to a current debian. Now, I am stuck even before this original problem. The new problem is already described here by someone else...

https://answers.unrealengine.com/questions/131817/generateprojectfilessh-fail-on-debian.html#

sight After several days of try and failure with these dependencies, i get really tired of this bugsearch. I killed my old Fedora linux, reinstalled my full disk encrypted System with debian... fixed the nvidia driver ... and now, after several hours I am facing THIS stupid bug?

Apologies for sounding frustrated, but it feels unbelievable unfair that f***k windows and even mac users just double click, while with my 8cpu server with 24gb ram and multiple grafic cards it's simply not possible. I begin to have doubts that UE4 is the right game engine to migrate my 2 year old project within linux...

We can close this thread unresolved, since I am not reinstalling fedora again.

more ▼

answered Mar 13 '15 at 03:33 PM

avatar image

thecr3w
26 3 6 7

avatar image RCL STAFF Mar 13 '15 at 05:18 PM

Could you elaborate on what you are running into? The bug you linked to is old and specific to 4.5/4.6, we don't use GetAssets.py anymore.

As for the OS, the latest Ubuntu/Kubuntu is your safest bet. I understand the frustration, but alas, part of the problem is that there's no single Linux "OS", and as much as we try to stay reasonably distro-agnostic, we cannot test them all.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question