x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Importing datatable with array struct member

I want to import data from a csv into a datatable.

The struct I created for the table contains a variable (FollowUpId) of type string-array. How do I format the column in csv in such a way that the importer of the engine recognizes this column as an array and will import the array?

I tried comma-separating the items within the column FollowUpId but that doesn't do much. I get an error message: Unsupported Property type for struct member 'FollowUpId_22_BDA804434825D471523C599DC8970348'.

The other columns are then imported fine. The 'unsupported' part of the error message makes me suspect what I want is not possible but to be sure I post it here.

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Mar 08 '15 at 04:54 PM in Using UE4

avatar image

scratchyback
1 1 2 2

avatar image Douglas Lassance Mar 24 '15 at 08:37 AM

I am curious about this too. Tried many combinations without success.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Arrays are not well supported at the moment; you will have to wait until 4.8 (which is currently in release preview); they added exporting of Datatables (both with and without arrays), Importing with arrays and you can also export your tables as JSON.

p.s. if this was helpful it would be super cool if you accept it as the answer.

more ▼

answered May 20 '15 at 04:54 AM

avatar image

magnetomage
79 4 7 14

avatar image Douglas Lassance May 20 '15 at 05:23 PM

Is there a page somewhere that describes the new workflow?

avatar image magnetomage May 21 '15 at 12:06 AM

to import a datatable in 4.8 with arrays you simply add parentheses around the array. so using the provided Datatable example ( from this page ) if you want to import integers you might put something like this "(1,2,16,128)" sans quotes.

avatar image Douglas Lassance May 21 '15 at 12:34 AM

Sounds like a valid answer for this post.

avatar image scratchyback May 22 '15 at 02:07 PM

thanks! I implemented a work around by now with a string-splitter function but as soon as 4.8 is there, I'll replace it for some proper code

avatar image Triblade Jun 15 '15 at 12:06 PM

Hi, we've just given this a try in 4.8 and have run into a problem:

We've got a struct containing two ints (min/max) and an array of another struct (extra). For testing this, 'extra' simply contains two ints (A/B).

The image shows the data we tried to import. 'TestRow1' works perfectly. 'TestRow2' doesn't work at all and will generate errors on import (i.e. you need to use the full, internal variable name for it to work).

alt text

csvdata.png (7.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question