x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Steam Overlay Opens On Player Join

I'm using UE 4.7.2 (from GitHub) with Steam SDK v1.3.2. Whenever a remote client joins the session, the steam overlay opens up over the game on the listen server's machine. I don't think I'm doing anything particularly odd, and I can't seem to figure out where this would be getting triggered from. Anyone have any ideas?

Product Version: Not Selected
Tags:
more ▼

asked Mar 09 '15 at 07:08 AM in Bug Reports

avatar image

BrainDx
146 10 15 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Well that certainly is a bizarre behavior.

We didn't upgrade to 1.32 before the 4.7.2 release but have since then. We will try to repro this locally.

In the meantime, did you catch all the locations in the .cpp and .cs files where the version of Steam is stored/referenced? Searching for "Steamv130" in those files should reveal all of that.

Did you make sure to replace all the DLLs (both 32/64) in the third party directory in binaries (Engine\Binaries\ThirdParty\Steamworks\Steamv132\Win64 and Win32)? The redist directories of the SDK don't always include every one, so you have to go to your latest copy of the Steam client and copy out the missing files.

I've seen weird but "stable" behaviors sometimes when Steam isn't updated properly. Typically you get a weird function linkage error, but maybe something weird caused it to manifest this way.

We never call "open external UI" in our engine code paths, it would have to be explicitly called by the game code otherwise. All the FOnlineExternalUISteam::ShowXXX(), but I imagine simply putting a breakpoint in these has already been tried. edit I didn't see your response when I composed this, so I see you've done this.

more ▼

answered Mar 09 '15 at 09:14 PM

avatar image

Crzyhomer STAFF
1.2k 34 26 103

avatar image BrainDx Mar 09 '15 at 09:33 PM

Yeah, I modified WinPlatform.Automation.cs, UEBuildConfiguration.cs, and OnlineSubsystemSteamPrivatePCH.h with the new version. I copied the DLLs from the SDK into the v132 directory, both Win32 and Win64, and grabbed the other DLLs from my local Steam installation. Consistently seeing an overlay popup on the host when a remote client connects. Very strange.

avatar image Crzyhomer STAFF Mar 10 '15 at 01:36 PM

Is there a way you could also engage Valve in this? Maybe they have some logging you can turn on to see the IPCs with the Steam client. Or some debugging trick to reveal the callstack. If you can switch back to 1.30 and not exhibit this problem, I'm not sure what the engine is doing wrong.

avatar image BrainDx Mar 10 '15 at 08:01 PM

Well, our project isn't yet green lit so I don't think we have access to any support from Valve. The problem definitely goes away with 1.30.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi BrainDx,

Did you integrate Steamworks v1.32 into the engine yourself? Currently, 1.32 is not supported (it's being integrated into 4.8).

more ▼

answered Mar 09 '15 at 07:50 PM

avatar image BrainDx Mar 09 '15 at 08:08 PM

Yeah, I followed the instructions in the docs. It was seemingly very straight forward. Unfortunately, I don't see any link to download an older version of the SDK. Everything works fine except the overlay opening on player join. Is there really something that would be different from v1.30 to v1.32 in this regard? For the record, I've tried it using both bUsesPresence set to true and false, so it doesn't seem to be a Lobby vs. older sessions thing. None of the calls to the steam overlay opening functions are called from UE (I've set breakpoints), so I don't know what would be triggering this.

avatar image BrainDx Mar 09 '15 at 08:19 PM

Well, I was able to get my hands on v1.30 by modifying the link to the latest SDK (changing the filename to v1.30). The problem went away, so I guess that means that this is, in fact, an issue with v1.32.

avatar image Ben Halliday STAFF Mar 09 '15 at 08:24 PM

Thanks for testing that. I've let the developers know, and they're looking into it for when 1.32 is integrated.

avatar image BrainDx Mar 09 '15 at 09:19 PM

No problem. I really appreciate the reply. I know you guys are always super busy and that this likely isn't an issue with your code, so thanks for taking the time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question