x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Refraction isn't affecting particle system in-game

My refraction emitter distorts the particle system when previewing in Cascade. However, when placed inside a level it seems to only distort everything that's not the particle system itself.

Product Version: Not Selected
Tags:
more ▼

asked Mar 09 '15 at 08:04 AM in Using UE4

avatar image

Wintershock
1 1 2 2

avatar image RimmyD Mar 10 '15 at 12:22 AM

Can you post a screenshot? I feel like it may be a sorting issue but not 100% certain what you mean.

avatar image Wintershock Mar 10 '15 at 03:07 AM

In the following picture:http://puu.sh/gtZPZ/902925e182.jpg In Cascade, you can see my refraction emitter is distorting my sparks emitter quite heavily.

However, as seen in this picture: http://puu.sh/gtZSw/f9e1622d5b.jpg The refraction seems to only affect everything that's not the sparks emitter, meshes and such.

avatar image Wintershock Mar 10 '15 at 11:22 PM

I tried changing the screen alignment and it doesn't change. Perhaps refraction just doesn't affect particles in the level?

Here's my material if it helps: http://puu.sh/gv7l7/c02c498554.jpg

avatar image RimmyD Mar 10 '15 at 11:30 PM

Hmm, I have it working in map for myself but my material is much more sane, I have a random normal map multiplied by 2 and plugged into the refraction. I will investigate more when i get home but I would go ahead and recommend a simpler setup (and try not plugging particle color into the refraction). Any number of things could be the issue at the moment so start with a simpler case and lets work up.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Try going in the material of the assets/particles you want to be affected by refraction (the material of those currently unaffected by refraction) look for the Separate translucency tab under translucency. If you uncheck this it should be affected by refraction of other effects. Keep in mind that no doubt this might/will cause other problems. But it does solve for me when my priority is the particles to be affected by refraction of other vfx.

Separate Translucency can be found left hand side in your material detail panel. (Click on empty space in your material) Under the translucency tab.

more ▼

answered May 21 '15 at 12:47 PM

avatar image

IngmarRs
11 1

avatar image mxnko Mar 06 '16 at 04:02 AM

Thank you!

(comments are locked)
10|2000 characters needed characters left

Try setting your refraction particle to Camera Facing? It works for me this way and it appears to be a bug that some particle Screen Alignments do not support refraction currently:

https://answers.unrealengine.com/questions/149019/particle-refraction-not-working-in-certain-modes.html

more ▼

answered Mar 10 '15 at 02:13 PM

avatar image

RimmyD
2.6k 98 15 96

avatar image NurtNurt May 25 '17 at 03:04 AM

This trick solved it for me, in combination with 'Separate Translucency' disabled. Thanks!

(comments are locked)
10|2000 characters needed characters left

Depending on what version of the engine you are using you may be encountering an old bug. Try placing a static mesh in your level with the same VFX and put a refractive material on the mesh. If the particle renders with the mesh visible you are experiencing a bug that I thought was fixed in the most recent release of the engine.

more ▼

answered Mar 19 '15 at 10:21 PM

avatar image

[Epic]homeRye STAFF
1.2k 22 3 42

avatar image Wintershock May 06 '15 at 01:36 PM

Sorry for the late reply. I'm not quite sure what you mean.

The refraction I have created in cascade would typically be used for something like heat haze, but after increasing the size to ridiculous levels, I noticed the refraction would distort meshes and such behind it, but not any particle systems.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question