x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Launch and Package creating 'old' version of game.

Hey,

I'm using the Stylized Kingdom example map, and I've added a few custom classes and made a whole bunch of changes.

When I play in PIE mode, everything works great, but if I Launch or Package my game, it's creating what looks like my game as it was 6 hours ago.

I've tried cooking, compiling, building, saving, closing and reopening, and nothing seems to fix it.

Here's a screenshot of playing in editor after just cooking, building and compiling: http://i.imgur.com/g8GiSfF.jpg

I immediately clicked launch, and got this: http://i.imgur.com/bjH66ME.jpg

As you can see, there's a lot different. The lighting is different, there's no monsters, there's an old testing monster I used previously to the left, the new UI changes haven't gone though, and the post-process "Drawn on paper" border and texture is back, after I deleted it hours ago.

No idea what's going on, but it's super frustrating, as I'd love to package it and show it to someone.

Any ideas?

Thanks.

Product Version: Not Selected
Tags:
more ▼

asked Mar 09 '15 at 09:04 AM in Bug Reports

avatar image

Kayar
6 3 4 5

avatar image Kayar Mar 09 '15 at 09:27 AM

Exporting it to a different location gives me: http://i.imgur.com/enbm6El.jpg

This is bizarre. There's no models showing now =/

avatar image [Epic] Gribbs ♦♦ STAFF Mar 09 '15 at 11:47 PM

Howdy Kayar,

Thank you for reporting this issue. Have you used our Materials for Mobile Platforms documentation to check and make sure that all materials meet the mobile criteria? Also, what device would you be using to deploy your project to?

Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image Kayar Mar 10 '15 at 03:37 AM

It's deploying to windows 64 bit. Windows 10 if that makes a difference. It seems like if I export to the same location, it's 'rediscovering' previous assets and taking a shortcut by not generating new ones.

avatar image [Epic] Gribbs ♦♦ STAFF Mar 10 '15 at 01:04 PM

Thank you for the additional information. I believe that the issue is that we currently do not support Windows 10. The highest Windows platform that we do support, at this time, is Windows 8. Would you be able to test this issue on a different computer to see if the same errors are occurring?

Thanks!

avatar image Kayar Mar 11 '15 at 12:11 AM

It's not the OS. There's other people experiencing the same bug. Might as well merge it with this: https://answers.unrealengine.com/questions/184662/bp-inheritance-skeletal-mesh-wrong-appearance.html

"I changed some positions of objects but this won't show up. It somehow loads an old "version" of the map?"

It's something to do with blueprint inheritance, I think.

avatar image [Epic] Gribbs ♦♦ STAFF Mar 11 '15 at 01:05 PM

Thanks for the update Kayar. I will talk with Matt, the staff member on the other post, and see if this issue may be related. Judging from the Bug that was placed into database, they seem to be similar. I will keep you updated once I speak with him.

Thanks!

avatar image [Epic] Gribbs ♦♦ STAFF Mar 11 '15 at 02:58 PM

Hey Kayar,

After speaking with Matt, we are fairly certain that these issues are related. In order to confirm, would you be able to share your project with us so that I may be able to further investigate. You can send it to me privately via the forums at https://forums.unrealengine.com/member.php?4890-Sean-Gribbin

Thanks and have a great day!

avatar image Detech Mar 14 '15 at 10:06 AM

Same happens to me aswell. After some unreal editor crushes my project start "launch" "3-day ago" version instead current. Im reopen project dozen times, but its not help. Packaged not work, its crushed without any error in log.

Then i start project launcher as admin and its help. Its strange bcoze my project launched and packaged 3-day ago without any admin prev. whatever

avatar image [Epic] Gribbs ♦♦ STAFF Mar 16 '15 at 01:37 PM

Thank you for the information Detech. I will be sure to include that this issue is happening for more then 2 users.

I will also be sure to update you when I know more about this issue.

Thanks!

avatar image whitetigle Apr 27 '15 at 01:49 PM

This morning everything was working. Then this bug started for me.

There's a few things I made. Could they be linked? - include Rama's victory BP and add a C++ component. (prior to this it was a 100% BP based project - cook the game - package the game

I did not do many things else this morning. So maybe if you ask me I could find something relevant with your issue.

Anyway, "Bon courage !" Good luck!

avatar image [Epic] Gribbs ♦♦ STAFF Apr 27 '15 at 08:16 PM

Howdy Whitetigle,

Thank you for reporting that you are seeing this issue as well. I went into our bug database and checked on the reported bug. It is currently still open but has been assigned. I will be sure to link this thread to the report, as it may help with the issue.

Thanks!

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hey,

I have a temporary solution that worked for me at least once. Going to test more.

  1. Go to Project Settings > Supported Platforms, then uncheck all the platforms you are not going to use, just leave Windows. Otherwise you will get errors after the third step.

  2. Copy your project to the new directory.

  3. Go to the project directory, then "Saved" and delete all the folders. Always backup everything.

  4. Add the project to your Unreal Launcher.

  5. Voila, it SHOULD package the latest version of your project.

Let me know you if you have any luck!

more ▼

answered Apr 12 '15 at 11:37 AM

avatar image

Nillasky
36 1 2 4

avatar image whitetigle Apr 27 '15 at 12:59 PM

As a side note: just did this without #2 & #4 (copy to another directory and manually add) and it works. Thanks!

avatar image FakePlasticTree Sep 22 '15 at 03:49 PM

The temporary solution doesn't seem to work in 4.9.1. Will there be a fix for this?

avatar image Samantha Sutton ♦♦ STAFF Sep 24 '15 at 01:57 PM

Hey FakePlasticTree,

Are you saving your project before you launch it onto your platform? If not, that could be part of the reason why it's not updating however, I have not yet been able to reproduce this. Each time I've made an update on a project, it updates appropriately for each launch on to the device.

Do you have any exact reproduction steps you could provide?

Thanks!

avatar image Retro11231 Apr 09 '16 at 04:09 AM

Thank you! Huge help!

(comments are locked)
10|2000 characters needed characters left

Hey Kayar,

Since this issue is related the UE-11458, I am going to mark this issue as resolved for tracking purposes. At this time, I am uncertain as to when this fix may be implemented but I will be sure to keep you updated as i see any reports regarding this issue.

Thanks and have a great day!

more ▼

answered Mar 13 '15 at 07:58 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.9k 292 13 76

avatar image Nillasky Apr 12 '15 at 11:38 AM

Hey Sean,

Please tell me you already have a solution :) because for such a long time we cannot package or even properly launch our projects... All we get is old versions.

avatar image [Epic] Gribbs ♦♦ STAFF Apr 13 '15 at 12:46 PM

Howdy Nillasky,

Thank you for your comment about this issue. I have looked into our bug database and checked on this report. This bug is slated to be fixed for the 4.8 release of UE4. At this time, I am uncertain as to when this version of UE4 will be released, but I will be sure to keep you updated as I know more.

Thanks!

(comments are locked)
10|2000 characters needed characters left

This may not be a fix for this exact issue but I had a related issue that took us hours to sort out.

When we built the project, a bunch of the new changes to maps (and content) were not being properly added in. Turns out the DefaultGame.ini file had the wrong map list, even though we were building with the correct map list. Apparently much of our new content was linked to those maps in some way that caused the build to make those meshes not show up in our packaged Release build.

Very odd indeed.

Anyway, check your DefaultGame.ini and that it has the correct maps populating the map list.

2019 Edit: Found my old post when I encountered this exact same issue (lol.) I deleted my Binaries, Intermediate, Build, and Saved folder -- still didn't fix it. Will edit this post with fix when I have resolved it.

more ▼

answered Apr 30 '17 at 04:51 AM

avatar image

Zaggoth
271 8 109 34

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question