x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android app crashes on startup: "ICU data directory was not discovered"

I am having trouble running a game on Android devices, with UE 4.7.2. I have tried on both Nexus 7 and One Plus One. I get the following error:

 03-09 12:11:42.564: D/UE4(5318): ==============> GameActive.onCreate complete!
 03-09 12:11:42.567: D/UE4(5318): Assertion failed: HasFoundDataDirectory [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\Core\Private\Internationalization\ICUInternationalization.cpp] [Line: 118] 
 03-09 12:11:42.567: D/UE4(5318): ICU data directory was not discovered:
 03-09 12:11:42.567: D/UE4(5318): ../../../DontDropJim/Content/Internationalization
 03-09 12:11:42.567: D/UE4(5318): ../../../Engine/Content/Internationalization
 03-09 12:11:42.567: A/libc(5318): Fatal signal 11 (SIGSEGV), code 1, fault addr 0x0 in tid 5341 (Thread-577)

This is a Blueprint-based project, so I haven't used Visual Studio or any coding at all for this app. I am deploying from a Win8.1 machine.

I tried using the "Launch" button as well as the "Package" option, with both ATC and ETC1.

EDIT: I should note that the TappyChicken game provided works. But I still do not know what causes the crash in the other project.

Product Version: Not Selected
Tags:
more ▼

asked Mar 09 '15 at 11:34 AM in Packaging & Deployment

avatar image

Avrdan
21 4 5 9

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I figured it out. I simply had a different name in the "Android Package Name" field. I had a suffix at the end of the name which I had to remove, to make it identical to the UE4 Project's name.

more ▼

answered Mar 09 '15 at 01:34 PM

avatar image

Avrdan
21 4 5 9

avatar image mblogest Feb 21 '17 at 04:29 PM

can say what you type exactly???i have 2 week this problem

avatar image TriNityGER Mar 09 '17 at 04:17 PM

I fixed this error by making sure that my Overall Project name is the same as the android project name. So these are my working Settings:

Project Name: Test Project Android Package Name: com.company.[PROJECT] Application Display Name: Test Project

Using these settings I am able to create a working Android build!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question