x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blender .fbx animations problem

Hi

I am encountering several problems with importing animations from Blender. So far I did manage to figure out two things:

  1. There is a problem with exporting/importing single actions from Blender. It did work before, but now I can only import animtations to UE if I choose 'All actions' in Blender fbx exporter options. Otherwise UE claims that there is no skeletal data in the .fbx file.

  2. The exporter's scale setting gets ignored. I used to work with normal scale in Blender and than using the 'Scale = 100' in export settings. And it still works fine with static meshes. However, when using this setup with Skeletal meshses and animations it gets ignored and the animations are 1/100 of their proper size.

I am using Blender 2.73a and UE 4.7.2

I was trying both the 6.1 and 7.4 format and it seems like the 7.4 shows more promise, as the 6.1 skeletal mesh fails to import at all.

Product Version: Not Selected
Tags:
more ▼

asked Mar 09 '15 at 01:50 PM in Bug Reports

avatar image

rimau
192 12 18 23

avatar image Steve Hardister ♦♦ STAFF Mar 09 '15 at 07:52 PM

Hi rimau,

There are known issues with fbx exporting from Blender 2.73 to other programs besides UE4 which they are trying to resolve. Until Blender is able to resolve the issue, you can export trouble free from Blender 2.0 if you are able to regress.

Thanks

avatar image rimau Mar 10 '15 at 12:00 PM

Hi Steve

Are you sure about this 2.0 version? Not 2.70 or something more up to date? Blender 2.0 is kind of ancient history. I have just tried 2.72 and the problem is still there. I did a workaround for the size by scaling my character but what I get now is some random animation errors.

avatar image Steve Hardister ♦♦ STAFF Mar 10 '15 at 01:46 PM

Hi Rimau,

I am not a Blender expert. I just looked this up in a local discussion and they referred to it as the "0" version which I took to mean 2.0 -It is likely they meant 2.70 (vs 2.72.)

avatar image rimau Mar 10 '15 at 02:32 PM

Well I did try the 2.70, 2.71 and the 2.72. Still no remedy for the random bones' errors. I can work with the need to scale the character x100 in Blender and export all the animations in a single .fbx file as a workaround. But these random errors are really strange. I do have other project (4.6.1) with animations from Blender and it was perfectly fine. Now it's a mess, and it's really hard to figure it out what's really going on with these .fbx files. Are you guys somehow in touch with the Blender team? I can post the .blend file with the animations, if you want to test it out, it's really super simple stuff in there, just a single basic character.

avatar image Steve Hardister ♦♦ STAFF Mar 10 '15 at 03:25 PM

Hi rimau,

Yes please post the blender file with animations (in a zip file) and I will test them by exporting from blender and importing into both 4.6.1 and 4.7.2 to see if there is a difference/bug.

Thanks

avatar image rimau Mar 10 '15 at 04:11 PM

Here you are:

link text

penguin_100.zip (547.9 kB)
avatar image Steve Hardister ♦♦ STAFF Mar 11 '15 at 07:51 PM

Hi rimau,

After opening your files and comparing them to the proper set up I found your character was scaled 100 times to large and oriented along -y forward instead of positive x. While the scaling is not that big of an issue, the character must be set up correctly along the correct axis before creating the animations, otherwise this could cause the distortions you are encountering. Please set up your files according to this video guide: https://www.youtube.com/watch?v=aC1_m0VdKIY

If you are still experiencing problems after setting your files up accordingly, let us know and we will investigate this further.

Thanks

avatar image rimau Mar 15 '15 at 10:29 PM

Hi

I have checked the video you provided. The scale in my .blend file, and in the video example is exactly the same. The only difference is that the video shows how to set scaling of the display units in Blender. This is just a UI setting, that displays your units with a multiplier, the size of the objects itself is the same (and correct) in both cases. But the 'Scale' slider on the .fbx export settings does not work anymore as intended for animations. It used to apply the correct scale at export, but now this seems to be broken.

The axis switch is not a problem at all, I did rotate my mesh both in Blender and in UE after importing. In both cases the character rotation does not cause any problems for me.

However I still didn't find the solution to corrupted bones data in some of the animations. I will perform some more testing in a few days and provide you with as detailed description as possible.

avatar image Steve Hardister ♦♦ STAFF Mar 16 '15 at 02:36 PM

Hi rimau,

Thanks for the update. Regarding corrupted bone data from Blender, often it is related to the rotation of those bones not being set to "0" in the bind pose before exporting.

avatar image rimau Mar 21 '15 at 09:07 PM

Ok, after some more testing I can confirm that: - exporting the skeletal mesh and animations in 6.1 format does not work properly anymore - you can not use the 'Scale' setting during export from Blender, you have to make your mesh 100 times bigger, whether you set a multiplier for your display units in Blender is irrelevant, as this is only a display setting, if you want to use the 7.4 fbx format (and you have to use it), the exported assets need to be scaled 100 times up - importing animations exported as single actions does not work anymore, you have to export all off the actions in a single .fbx file - and now the worst part, Steve you are probably right about the initial rotations of the bones that are causing the problem, however I do not see a solution to this problem... take a look at the screenshots, - the first one shows the default state of the Blender skeleton, all bones are having 'W: 1.00", this is their rest state - the second screen shows what happens in Blender when I set this value to 0 - and it is exactly the kind of behaviour that I get in UE4, so this would mean that this is exactly the value that is causing the problem

But I can not really have this value at 0 in Blender, if I rotate the bone, than it deforms my skeleton according to the applied rotation, if I try to use this pose as the rest pose for the bone, than the 'W' value is reset to 1

I can not find a workaround for this problem at the moment, and this is a complete game braker in the current state. I did post about the problem at the blenderartists forum as well, you can find it here: link text

alt text alt text alt text

screen1.jpg (373.9 kB)
screen2.jpg (375.7 kB)
screen3.jpg (283.1 kB)
avatar image Clunk47 Mar 21 '15 at 09:20 PM

I'm not sure if this will help or not, but I posted an answer HERE and combined with the OP's solution posted as a comment to the answer, you may be able to resolve the issues you're having. I hope it helps in some way.

avatar image Positivity Mar 23 '15 at 10:37 AM

I had a same problem with animations from Blender .. but i know workaround what works always and is Easy I myself Imported in Unreal Engine more then 60 animations from Blender and they all work just like i need just sometimes applying that workaround when some bones is out of place .. the Workaround is described in this post https://developer.blender.org/T43593?workflow=create

I use newest blender and use -Y for my forward Axis Because when i started to make animations i Used Epics Blue guy as Reference and i made more then 40 of them and now i cant rotate animations in blender because that mess up everything ... i Dont know why Epic use that Blue guy who is not on +X axis them self and then tell ppl to use +X if they clearly have all templates with -Y this is weird for me .. You can clearly see in Epic tutorials how they Rotate blue guy to face +X.

In the picture you can see i have 73 Animations in UE4 and they all work like i made them in blender :) alt text

avatar image rimau Mar 23 '15 at 05:39 PM

Hi Positivity

I did read you comment on developer.blender.org, but I do not fully understand. I always have my values colored in green when I do change a frame, and I still do have corrupted rotations. There needs to be somethings else in there, which we can't find. None of us.

And Steve, here is the link to the task on the developer.blender.org. Maybe you will find this kind of contact helpfull in some way.

avatar image Positivity Mar 23 '15 at 08:13 PM

Hey Rimau you need to move bone a little bit or Rotate it when the values change color . Like i say i use this trick On my Own and it works :) you can upload corrupt file for me and i will show that export from blender will work :) i could try to make video tutorial but im bad at thous thing, but if you willl not be able still understand i will make one

avatar image rimau Mar 23 '15 at 08:32 PM

If you would be so kind to test it and let me know how to apply a workaround, that would be great.

link text

penguin_error.zip (228.3 kB)
avatar image Positivity Mar 23 '15 at 08:53 PM

It was easy and fast .. :) Im attaching the Fixed file and you can see What i did there .. and im attaching image how it is fixed in unreal Engine 4
this took me less then minute ti fix :) link textalt text

penguin_error.zip (402.7 kB)
pingineu4.png (507.6 kB)
avatar image rimau Mar 23 '15 at 09:38 PM

If you ever are in Poznan, Poland, let me know, I owe you a beer. I have just tried with the other foot and it seems like everything is ok. Just to make it clear for anyone who will fight with this kind of issue and finds this thread: you need to add an extra keyframe at the beginning of your animation for the bones that are having corrupted rotations in UE4. Just some slight transformation that is not even visible, but will not be 0. Thank you very much Positivity for your help. I mean seriously: THANK YOU. PS I still hope the issue will get resolved ;)

avatar image Positivity Mar 23 '15 at 09:53 PM

Good that i can help :) and about that Extra keyframe at beginning of your animation .. sometimes it is not helping to add at beginning that's why you need to add keyframe where Value change color in blender . If you look closely at your file you see i added keyframe in between starting and midle kayframe, thats because in that place for me Value Tab changed Color to Green .. For Default blender theme it will be orange i think ... If you can Mark this Tread as Resolved it would be grate and take care :) Edit: I Added my old explanation images alt textalt text

moving bone.png (220.9 kB)
movingbone2.png (209.6 kB)
avatar image rimau Mar 24 '15 at 08:27 AM

Hi

Well by the beginning I meant somewhere in the begining- after the first frame, just looks like I didn't make that clear enough for others. Good point.

As for marking as resolved I guess it should stay open, after all it's about a bug somewhere in the export/import process that needs to be resolved. What you have found is a great workaround, that should also help in fixing the problem by the joint forces of Epic and Blender teams, they should have a better idea what to look for now. But as the bug is still alive and kicking let's leave the thread open as a bug report.

avatar image StipendAwarded Jan 24 '19 at 10:16 PM

Hi, I know this is a long while, but I have an urgent question. I keep trying to do what you say and it does not work. I add an extra keyframe at 0 (no translation), but when I import into Unreal it never works, one way or another. The mesh disappears within the animations.

avatar image Positivity Jan 25 '19 at 06:35 PM

This bug I think is more or Less fixed.. maybe you are doing something wrong with your animations? Also when you add Extra keyframe you Must Move Bone Slightly .. just a little bit .. So it registers something.. but I have not Encountered this bug anymore so i don't know. Also, Post some Picture or something so we can see what is happening..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi rimau,

Thanks for posting the link to the Blender forums. I passed this along to our developers and this is being looked at as a bug which they will likely have to collaborate with the Blender team to resolve. Since I cannot speak to anything regarding the Blender side of things, I can only say that we are doing what we can to resolve the anomalies in the animation fbx workflow from Blender to UE4.

In the meantime, users experiencing this issue can use the workaround provided here by Positivity. If we are able to get this resolved officially, an update will be added to this post.

Thank you for the feedback and workaround steps.

more ▼

answered Mar 27 '15 at 05:07 PM

avatar image rimau Mar 27 '15 at 05:47 PM

Hi Steve

The test build linked in the developer.blender.org thread solves most of the problems. As far as I understand the problems still occur only when you import the standard UE4 skeleton into Blender, and then export the animations. As I do not use the standard skeleton in my project I can confirm that for rigs created from scratch everything works fine.

You can also have a look here, as the tasks have been merged in the meantime: link text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question