x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7] Play in Editor crashing after compiling certain Blueprints.

Hello all.

Since the 4.7 update, we've been experiencing certain crashes related to the following situations.

  • One Blueprint (a standard Class BP), caused a crash everytime it was compiled

However, it worked perfectly ingame. We fixed this by duplicating the Blueprint and replacing all the references to the old BP with references to the new BP.

  • A set of Blueprints (our custom Player Controller, our custom HUD Blueprint, and all of our Widget Blueprints) cause a crash if we compile them and THEN try to Play in Editor.

Playing in Standalone Mode works correctly. Restarting the project causes Play in Editor to work correctly as well. But if we compile any of them and then Play in Editor, it causes a crash. Duplicating these Blueprints and replacing their references does not seem to work (the new ones cause a crash as well, perhaps because they reference each other, even though there are absolutely zero circular reference scenarios).

-In all these crashes, the error message is exactly the same:

alt text

If there is any further information I can provide or steps I can take to help the support team, I'm glad to try and do so.

Product Version: Not Selected
Tags:
captura.png (126.6 kB)
more ▼

asked Mar 09 '15 at 02:59 PM in Bug Reports

avatar image

IMC.Wander
53 1 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Well, I found a workaround. There were many more "corrupted" blueprints than I initially thought. Duplicating all these blueprints and re-referencing everything seemed to solve the issue.

more ▼

answered Mar 09 '15 at 08:22 PM

avatar image

IMC.Wander
53 1 3 6

avatar image TJ V ♦♦ STAFF Mar 09 '15 at 10:00 PM

Hi IMC.Wander,

I'm glad you got it working properly. If you would like to continue to investigate this issue though, please keep reading. If not, it's no problem.

Did you submit that crash report? The only crash I could find in the system was for a launcher crash a few days ago. This could be due to how slow our crash reporter site can sometimes be (especially with the rate that we are currently getting crash reports).

If you still have access to it, could you post the entire call stack in text from that crash? Also any Log files could help as well. You can find more info on where to find the logs in the link below.

https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

avatar image IMC.Wander Mar 09 '15 at 11:00 PM

Of course. I'll do my best to cooperate with you to help solve this bug tomorrow first thing in the morning. It would be easy to reproduce the crash as I am 99% positive I have pre-fix backups of my project.

I did send several crash reports though.

Thank you for your answer, TJ.

avatar image IMC.Wander Mar 10 '15 at 12:49 PM

Okey, here we go. I will post the two differentiated issues, one for the Blueprint which crashes on compile, and another for one of the Blueprints which crash after compiling and then hitting Play in Editor. I include a .rar with all the data I could find for each case, plus an example Blueprint for each as well.

Blueprint crashing on compile

https://drive.google.com/uc?export=download&id=0B9OWAvgok5KlbXV1ek1WZUd2YmM

Blueprint crashing on compile then Play in Editor

https://drive.google.com/uc?export=download&id=0B9OWAvgok5KlZ0pibnN1WDh2cEk

Hope this helps

avatar image TJ V ♦♦ STAFF Mar 10 '15 at 08:32 PM

Thanks for all of the info! I'm unsure of what caused the blueprint to become corrupted but we now have several crash reports showing in our system. That should give us a good start if this happens again or if another user experiences it.

Thanks again,

TJ

avatar image IMC.Wander Mar 10 '15 at 11:29 PM

My pleasure!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question