x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Persistent level dirty when loading sub level 4.7.2

Immediately after opening my project i RMB a sub-level in the Levels tab and "Make Current" this causes the persistent level as well as the now-current level to become dirty. This is different from the behavior in 4.6.1 where levels are not dirty unless a change is made.

Creation method: These levels were created with "Import tiled landscape" which is also broken in 4.7.2 due to the "overlapping render component at location" error upon tiled import. to work around the import problem, the project was created, tiles imported and saved in 4.6.1, then opened in 4.7.2 and converted as a copy. Perhaps these two issues are related?

I feel that the dirty levels issue is a showstopper for svn or perforce collaboration, and the important foliage feature of temporal blending (AWESOME!) for LOD levels in 4.7.2 are absent from 4.6.1.

What's to be done?

Product Version: Not Selected
Tags:
more ▼

asked Mar 09 '15 at 04:11 PM in Bug Reports

avatar image

sloppyjava
31 2 4

avatar image Adam Davis STAFF Mar 09 '15 at 07:57 PM

Hi sloppyjava,

Can you walk me through what steps you are taking to reproduce this error? I attempted loading a tiled landscape built in WM into the editor via 4.6.1, then converting the project using the "copy project" method, however when I loaded the levels nothing seemed to be broken.

avatar image sloppyjava Mar 10 '15 at 10:32 AM

the levels seem to load just fine, it's that they are marked as needing to be saved as if changes have been made. both the persistent level as well as whatever level I make the current level alt text Double click to make current as the tool tip indicates has the same effect. If the project is under source control, I'm prompted to check out, or when closing the project, save changes when nothing has been changed, only loaded or made the current level. Unless there is an option I'm missing somewhere, this isn't the intended behavior, and is different from the (expected) behavior in 4.6.1 alt text

There are no error messages displayed.

dirtyflag.jpg (38.4 kB)
nodirtyflag.jpg (56.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi sloppyjava,

I was able to reproduce this on my end and have entered a bug report, UE-11834 to be assessed by the development staff.

more ▼

answered Mar 13 '15 at 07:49 PM

avatar image Büke Jul 09 '17 at 10:35 PM

The entered issue UE-11834 claims unreproducible.

If console "grass.Enable 0" solves the problem, then you are dealing with this: https://answers.unrealengine.com/questions/585238/landscape-grass-causes-map-to-be-marked-dirty-ever.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question